blob: c390fcf33c412273d69a4c56542957db80610ab5 [file] [log] [blame]
Andrew Geissler5a43b432020-06-13 10:46:56 -05001SUMMARY = "Socket-based service activation daemon"
2HOMEPAGE = "https://github.com/xinetd-org/xinetd"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05003DESCRIPTION = "xinetd is a powerful replacement for inetd, xinetd has access control mechanisms, extensive logging capabilities, the ability to make services available based on time, can place limits on the number of servers that can be started, and has deployable defence mechanisms to protect against port scanners, among other things."
Andrew Geissler5a43b432020-06-13 10:46:56 -05004
Andrew Geissler5199d832021-09-24 16:47:35 -05005LICENSE = "xinetd"
Andrew Geissler5a43b432020-06-13 10:46:56 -05006LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=55c5fdf02cfcca3fc9621b6f2ceae10f"
7
8UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
9
Andrew Geissler595f6302022-01-24 19:11:47 +000010SRC_URI = "git://github.com/openSUSE/xinetd.git;protocol=https;branch=master \
Andrew Geissler5a43b432020-06-13 10:46:56 -050011 file://xinetd.init \
12 file://xinetd.default \
13 file://xinetd.service \
14 "
15
16SRCREV = "6a4af7786630ce48747d9687e2f18f45ea6684c4"
17
18S = "${WORKDIR}/git"
19
William A. Kennington IIIac69b482021-06-02 12:28:27 -070020# https://github.com/xinetd-org/xinetd/pull/10 is merged into this git tree revision
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000021CVE_CHECK_IGNORE += "CVE-2013-4342"
William A. Kennington IIIac69b482021-06-02 12:28:27 -070022
Andrew Geissler5a43b432020-06-13 10:46:56 -050023inherit autotools update-rc.d systemd pkgconfig
24
Patrick Williams213cb262021-08-07 19:21:33 -050025SYSTEMD_SERVICE:${PN} = "xinetd.service"
Andrew Geissler5a43b432020-06-13 10:46:56 -050026
27INITSCRIPT_NAME = "xinetd"
28INITSCRIPT_PARAMS = "defaults"
29
30PACKAGECONFIG ??= "tcp-wrappers"
31PACKAGECONFIG[tcp-wrappers] = "--with-libwrap,,tcp-wrappers"
32
Patrick Williams92b42cb2022-09-03 06:53:57 -050033CFLAGS += "-D_GNU_SOURCE"
34
Patrick Williams213cb262021-08-07 19:21:33 -050035CONFFILES:${PN} = "${sysconfdir}/xinetd.conf"
Andrew Geissler5a43b432020-06-13 10:46:56 -050036
Patrick Williams213cb262021-08-07 19:21:33 -050037do_install:append() {
Andrew Geissler5a43b432020-06-13 10:46:56 -050038 install -d "${D}${sysconfdir}/init.d"
39 install -d "${D}${sysconfdir}/default"
40 install -m 755 "${WORKDIR}/xinetd.init" "${D}${sysconfdir}/init.d/xinetd"
41 install -m 644 "${WORKDIR}/xinetd.default" "${D}${sysconfdir}/default/xinetd"
42
43 # Install systemd unit files
Andrew Geissler5199d832021-09-24 16:47:35 -050044 install -d ${D}${systemd_system_unitdir}
45 install -m 0644 ${WORKDIR}/xinetd.service ${D}${systemd_system_unitdir}
Andrew Geissler5a43b432020-06-13 10:46:56 -050046 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
47 -e 's,@SBINDIR@,${sbindir},g' \
Andrew Geissler5199d832021-09-24 16:47:35 -050048 ${D}${systemd_system_unitdir}/xinetd.service
Andrew Geissler5a43b432020-06-13 10:46:56 -050049}
50
Patrick Williams864cc432023-02-09 14:54:44 -060051# Script for converting inetd.conf files into xinetd.conf files
52PACKAGES =+ "${PN}-xconv"
53FILES:${PN}-xconv = "${bindir}/xconv.pl"
54RDEPENDS:${PN}-xconv += "perl"