blob: 4e009d262554b1516265a340a34d35deade58bfc [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Note, we can probably remove the lzma option as it has be replaced with xz,
2# and I don't think the kernel supports it any more.
3SUMMARY = "Tools for manipulating SquashFS filesystems"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06004HOMEPAGE = "https://github.com/plougher/squashfs-tools"
5DESCRIPTION = "Tools to create and extract Squashfs filesystems."
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006SECTION = "base"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "GPL-2.0-only"
Patrick Williams03907ee2022-05-01 06:28:52 -05008LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
Patrick Williams03907ee2022-05-01 06:28:52 -050010PV = "4.5.1"
11SRCREV = "afdd63fc386919b4aa40d573b0a6069414d14317"
Andrew Geissler595f6302022-01-24 19:11:47 +000012SRC_URI = "git://github.com/plougher/squashfs-tools.git;protocol=https;branch=master \
Patrick Williams03907ee2022-05-01 06:28:52 -050013 file://0001-install-manpages.sh-do-not-write-original-timestamps.patch \
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050014 "
Andrew Geissler9aee5002022-03-30 16:27:02 +000015UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016
Patrick Williams03907ee2022-05-01 06:28:52 -050017S = "${WORKDIR}/git"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018
Brad Bishop19323692019-04-05 15:28:33 -040019EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS}"
20
Andrew Geissler87f5cff2022-09-30 13:13:31 -050021PACKAGECONFIG ??= "gzip xz lzo lz4 lzma xattr zstd reproducible"
Brad Bishop19323692019-04-05 15:28:33 -040022PACKAGECONFIG[gzip] = "GZIP_SUPPORT=1,GZIP_SUPPORT=0,zlib"
23PACKAGECONFIG[xz] = "XZ_SUPPORT=1,XZ_SUPPORT=0,xz"
24PACKAGECONFIG[lzo] = "LZO_SUPPORT=1,LZO_SUPPORT=0,lzo"
25PACKAGECONFIG[lz4] = "LZ4_SUPPORT=1,LZ4_SUPPORT=0,lz4"
26PACKAGECONFIG[lzma] = "LZMA_XZ_SUPPORT=1,LZMA_XZ_SUPPORT=0,xz"
27PACKAGECONFIG[xattr] = "XATTR_SUPPORT=1,XATTR_SUPPORT=0,attr"
Brad Bishop96ff1982019-08-19 13:50:42 -040028PACKAGECONFIG[zstd] = "ZSTD_SUPPORT=1,ZSTD_SUPPORT=0,zstd"
29PACKAGECONFIG[reproducible] = "REPRODUCIBLE_DEFAULT=1,REPRODUCIBLE_DEFAULT=0,"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030
31do_compile() {
Patrick Williams03907ee2022-05-01 06:28:52 -050032 cd ${S}/squashfs-tools
Brad Bishop64c979e2019-11-04 13:55:29 -050033 oe_runmake all
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034}
Brad Bishop19323692019-04-05 15:28:33 -040035
Brad Bishop64c979e2019-11-04 13:55:29 -050036do_install() {
Patrick Williams03907ee2022-05-01 06:28:52 -050037 cd ${S}/squashfs-tools
William A. Kennington IIIac69b482021-06-02 12:28:27 -070038 install -d "${D}${includedir}"
Patrick Williams03907ee2022-05-01 06:28:52 -050039 oe_runmake install INSTALL_PREFIX=${D}${prefix} INSTALL_MANPAGES_DIR=${D}${datadir}/man/man1
40 install -m 0644 "${S}"/squashfs-tools/squashfs_fs.h "${D}${includedir}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050041}
42
Patrick Williams213cb262021-08-07 19:21:33 -050043ARM_INSTRUCTION_SET:armv4 = "arm"
44ARM_INSTRUCTION_SET:armv5 = "arm"
45ARM_INSTRUCTION_SET:armv6 = "arm"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050046
47BBCLASSEXTEND = "native nativesdk"
Brad Bishopc342db32019-05-15 21:57:59 -040048
49CVE_PRODUCT = "squashfs"