blob: ab2ff01b62303695a6de8af094ac0f6c34b585ff [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Note, we can probably remove the lzma option as it has be replaced with xz,
2# and I don't think the kernel supports it any more.
3SUMMARY = "Tools for manipulating SquashFS filesystems"
4SECTION = "base"
Brad Bishop19323692019-04-05 15:28:33 -04005LICENSE = "GPL-2"
6LIC_FILES_CHKSUM = "file://../COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007
8PV = "4.3+gitr${SRCPV}"
Brad Bishop96ff1982019-08-19 13:50:42 -04009SRCREV = "f95864afe8833fe3ad782d714b41378e860977b1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010SRC_URI = "git://github.com/plougher/squashfs-tools.git;protocol=https \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050011 file://squashfs-tools-4.3-sysmacros.patch;striplevel=2 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050012"
Brad Bishop316dfdd2018-06-25 12:45:53 -040013UPSTREAM_CHECK_COMMITS = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014SRC_URI[lzma.md5sum] = "29d5ffd03a5a3e51aef6a74e9eafb759"
15SRC_URI[lzma.sha256sum] = "c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e0880aa0fa1e"
16
17S = "${WORKDIR}/git/squashfs-tools"
18
Brad Bishop15ae2502019-06-18 21:44:24 -040019# needs FNM_EXTMATCH
20COMPATIBLE_HOST_libc-musl = 'null'
21
Brad Bishop19323692019-04-05 15:28:33 -040022EXTRA_OEMAKE = "${PACKAGECONFIG_CONFARGS}"
23
Brad Bishop96ff1982019-08-19 13:50:42 -040024PACKAGECONFIG ??= "gzip xz lzo lz4 lzma xattr reproducible"
Brad Bishop19323692019-04-05 15:28:33 -040025PACKAGECONFIG[gzip] = "GZIP_SUPPORT=1,GZIP_SUPPORT=0,zlib"
26PACKAGECONFIG[xz] = "XZ_SUPPORT=1,XZ_SUPPORT=0,xz"
27PACKAGECONFIG[lzo] = "LZO_SUPPORT=1,LZO_SUPPORT=0,lzo"
28PACKAGECONFIG[lz4] = "LZ4_SUPPORT=1,LZ4_SUPPORT=0,lz4"
29PACKAGECONFIG[lzma] = "LZMA_XZ_SUPPORT=1,LZMA_XZ_SUPPORT=0,xz"
30PACKAGECONFIG[xattr] = "XATTR_SUPPORT=1,XATTR_SUPPORT=0,attr"
Brad Bishop96ff1982019-08-19 13:50:42 -040031PACKAGECONFIG[zstd] = "ZSTD_SUPPORT=1,ZSTD_SUPPORT=0,zstd"
32PACKAGECONFIG[reproducible] = "REPRODUCIBLE_DEFAULT=1,REPRODUCIBLE_DEFAULT=0,"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033
34do_compile() {
35 oe_runmake mksquashfs unsquashfs
36}
Brad Bishop19323692019-04-05 15:28:33 -040037
Patrick Williamsc124f4f2015-09-15 14:41:29 -050038do_install () {
39 install -d ${D}${sbindir}
40 install -m 0755 mksquashfs ${D}${sbindir}/
41 install -m 0755 unsquashfs ${D}${sbindir}/
42}
43
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080044ARM_INSTRUCTION_SET_armv4 = "arm"
45ARM_INSTRUCTION_SET_armv5 = "arm"
46ARM_INSTRUCTION_SET_armv6 = "arm"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050047
48BBCLASSEXTEND = "native nativesdk"
Brad Bishopc342db32019-05-15 21:57:59 -040049
50CVE_PRODUCT = "squashfs"