blob: 14d64320fa0cfbc5c66dae00260fe8ea266ce054 [file] [log] [blame]
Andrew Geissler82cfa662020-02-17 15:11:03 -06001SUMMARY = "OpenPOWER processor control services installation"
2PR = "r1"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit allarch
8
Adriana Kobylak8c6707f2021-08-06 17:35:36 +00009RDEPENDS:${PN} += "op-proc-control"
10RDEPENDS:${PN} += "phosphor-state-manager-obmc-targets"
Andrew Geissler82cfa662020-02-17 15:11:03 -060011
Adriana Kobylak8c6707f2021-08-06 17:35:36 +000012ALLOW_EMPTY:${PN} = "1"
Andrew Geissler82cfa662020-02-17 15:11:03 -060013
Adriana Kobylak8c6707f2021-08-06 17:35:36 +000014pkg_postinst:${PN}() {
Andrew Geissler55bd4492020-03-31 13:43:46 -050015 mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants
Andrew Geissler82cfa662020-02-17 15:11:03 -060016 mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -050017 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
Andrew Geisslerb9b3a4a2023-05-12 14:10:34 -050018 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -050019 mkdir -p $D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires
Andrew Geisslerf95063e2020-04-14 15:08:43 -050020 mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires
Andrew Geisslerc3f1beb2020-12-09 15:05:02 -060021 mkdir -p $D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants
Andrew Geissler82cfa662020-02-17 15:11:03 -060022
Andrew Geissler55bd4492020-03-31 13:43:46 -050023 LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -060024 TARGET="../op-stop-instructions@.service"
25 ln -s $TARGET $LINK
26
Andrew Geisslerc3f1beb2020-12-09 15:05:02 -060027 LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/op-stop-instructions@0.service"
28 TARGET="../op-stop-instructions@.service"
29 ln -s $TARGET $LINK
30
Andrew Geisslerf95063e2020-04-14 15:08:43 -050031 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
32 TARGET="../op-cfam-reset.service"
33 ln -s $TARGET $LINK
34
Andrew Geisslerb9b3a4a2023-05-12 14:10:34 -050035 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/xyz.openbmc_project.Control.Host.NMI.service"
36 TARGET="../xyz.openbmc_project.Control.Host.NMI.service"
37 ln -s $TARGET $LINK
38
Andrew Geisslerf95063e2020-04-14 15:08:43 -050039 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -060040 TARGET="../op-cfam-reset.service"
41 ln -s $TARGET $LINK
Andrew Geissler4e174d12020-02-26 14:11:53 -060042
43 # Only install cfam override if p9 system
44 if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then
45 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
46 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
47 TARGET="../cfam_override@.service"
48 ln -s $TARGET $LINK
49 fi
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -050050
51 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
52 TARGET="../op-continue-mpreboot@.service"
53 ln -s $TARGET $LINK
54
Andrew Geissler88eef192020-12-17 11:37:11 -060055 # Only install certain units if phal enabled
Patrick Williams8c561ee2021-10-22 14:20:12 -050056 if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" = phal ]; then
Andrew Geisslerf158d902022-04-08 16:24:35 -050057 LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-clear-sys-dump-active@0.service"
58 TARGET="../op-clear-sys-dump-active@.service"
59 ln -s $TARGET $LINK
60
61 mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
62 LINK="$D$systemd_system_unitdir/multi-user.target.wants/op-clear-sys-dump-active@0.service"
63 TARGET="../op-clear-sys-dump-active@.service"
64 ln -s $TARGET $LINK
65
Ramesh Iyyard6d9b542020-09-17 10:02:08 -050066 mkdir -p $D$systemd_system_unitdir/obmc-host-start@0.target.requires
67 LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
68 TARGET="../phal-reinit-devtree.service"
69 ln -s $TARGET $LINK
Chirag Sharma5ec16a32020-12-11 03:45:15 -060070
71 LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
72 TARGET="../proc-pre-poweroff@.service"
73 ln -s $TARGET $LINK
Andrew Geissler4d2fd8d2021-06-24 15:28:47 -050074
75 LINK="$D$systemd_system_unitdir/obmc-host-reset@0.target.requires/op-reset-host-check@0.service"
76 TARGET="../op-reset-host-check@.service"
77 ln -s $TARGET $LINK
Jayanth Othayothad68ba32021-07-30 06:35:44 -050078
Jayanth Othayothad68ba32021-07-30 06:35:44 -050079 LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service"
80 TARGET="../phal-import-devtree@.service"
81 ln -s $TARGET $LINK
Jayanth Othayothce7dbec2021-07-30 06:46:57 -050082
83 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants
84 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/phal-export-devtree@0.service"
85 TARGET="../phal-export-devtree@.service"
86 ln -s $TARGET $LINK
Ramesh Iyyard0aedb92022-02-24 03:35:40 -060087
88 mkdir -p $D$systemd_system_unitdir/obmc-host-start@0.target.wants
89 LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.wants/phal-create-boottime-guard-indicator.service"
90 TARGET="../phal-create-boottime-guard-indicator.service"
91 ln -s $TARGET $LINK
92 LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/phal-create-boottime-guard-indicator.service"
93 ln -s $TARGET $LINK
Jayanth Othayoth633a9cc2022-09-12 06:23:45 -050094
95 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants
96 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/op-clock-data-logger@0.service"
97 TARGET="../op-clock-data-logger@.service"
98 ln -s $TARGET $LINK
Andrew Geisslerb9b3a4a2023-05-12 14:10:34 -050099
100 mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.wants
101 LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.wants/set-spi-mux.service"
102 TARGET="../set-spi-mux.service"
103 ln -s $TARGET $LINK
Jayanth Othayothad68ba32021-07-30 06:35:44 -0500104 fi
Andrew Geissler88eef192020-12-17 11:37:11 -0600105
Andrew Geissleraa25e2c2021-02-01 14:14:25 -0600106 # If the memory preserving reboot feature is enabled, set it up
107 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'mpreboot', d)}" = mpreboot ]; then
108 # on mpreboot systems, obmc-host-crash@.target is used for mpreboot
Andrew Geissler88eef192020-12-17 11:37:11 -0600109 mkdir -p $D$systemd_system_unitdir/obmc-host-crash@0.target.requires
110 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-force-warm-reboot@0.target"
111 TARGET="../obmc-host-force-warm-reboot@.target"
112 ln -s $TARGET $LINK
113
114 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/op-enter-mpreboot@0.service"
115 TARGET="../op-enter-mpreboot@.service"
116 ln -s $TARGET $LINK
117
Andrew Geissleraa25e2c2021-02-01 14:14:25 -0600118 # ensure diagnostic mode is shown for MPREBOOT
Andrew Geissler88eef192020-12-17 11:37:11 -0600119 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-diagnostic-mode@0.target"
120 TARGET="../obmc-host-diagnostic-mode@.target"
121 ln -s $TARGET $LINK
122 else
Andrew Geissleraa25e2c2021-02-01 14:14:25 -0600123 # If not a mpreboot system, default to quiesce target in crash target to support
Andrew Geissler88eef192020-12-17 11:37:11 -0600124 # older system designs like witherspoon
125 mkdir -p $D$systemd_system_unitdir/obmc-host-crash@0.target.wants
126 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.wants/obmc-host-quiesce@0.target"
127 TARGET="../obmc-host-quiesce@.target"
128 ln -s $TARGET $LINK
Ramesh Iyyard6d9b542020-09-17 10:02:08 -0500129 fi
Andrew Geissler82cfa662020-02-17 15:11:03 -0600130}
131
Adriana Kobylak8c6707f2021-08-06 17:35:36 +0000132pkg_prerm:${PN}() {
Andrew Geissler55bd4492020-03-31 13:43:46 -0500133 LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -0600134 rm $LINK
Andrew Geisslerf95063e2020-04-14 15:08:43 -0500135 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
136 rm $LINK
137 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -0600138 rm $LINK
Andrew Geisslerb9b3a4a2023-05-12 14:10:34 -0500139 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/xyz.openbmc_project.Control.Host.NMI.service"
140 rm $LINK
Andrew Geissler4e174d12020-02-26 14:11:53 -0600141 # Only uninstall cfam override if p9 system
142 if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then
143 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
144 rm $LINK
145 fi
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -0500146 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
147 rm $LINK
Ramesh Iyyard6d9b542020-09-17 10:02:08 -0500148
Andrew Geissler88eef192020-12-17 11:37:11 -0600149 # Remove phal specific units if enabled
Patrick Williams8c561ee2021-10-22 14:20:12 -0500150 if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" = phal ]; then
Ramesh Iyyard6d9b542020-09-17 10:02:08 -0500151 LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
152 rm $LINK
Chirag Sharma5ec16a32020-12-11 03:45:15 -0600153
154 LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
155 rm $LINK
Jayanth Othayothad68ba32021-07-30 06:35:44 -0500156
Andrew Geisslerb9b3a4a2023-05-12 14:10:34 -0500157 LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.wants/set-spi-mux.service"
158 rm $LINK
159
Jayanth Othayothad68ba32021-07-30 06:35:44 -0500160 LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service"
161 rm $LINK
Jayanth Othayothce7dbec2021-07-30 06:46:57 -0500162
163 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/phal-export-devtree@0.service"
164 rm $LINK
Ramesh Iyyard0aedb92022-02-24 03:35:40 -0600165
166 LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.wants/phal-create-boottime-guard-indicator.service"
167 rm $LINK
168 LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/phal-create-boottime-guard-indicator.service"
169 rm $LINK
Jayanth Othayoth633a9cc2022-09-12 06:23:45 -0500170
171 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/op-clock-data-logger@0.service"
172 rm $LINK
Andrew Geissleraa25e2c2021-02-01 14:14:25 -0600173 fi
Andrew Geissler88eef192020-12-17 11:37:11 -0600174
Andrew Geissleraa25e2c2021-02-01 14:14:25 -0600175 # Remove mpreboot specific units if enabled
176 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'mpreboot', d)}" = mpreboot ]; then
Andrew Geissler88eef192020-12-17 11:37:11 -0600177 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-force-warm-reboot@0.target"
178 rm $LINK
179
180 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/op-enter-mpreboot@0.service"
181 rm $LINK
182 else
183 LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.wants/obmc-host-quiesce@0.target"
184 rm $LINK
Ramesh Iyyard6d9b542020-09-17 10:02:08 -0500185 fi
Andrew Geissler82cfa662020-02-17 15:11:03 -0600186}