blob: 47785616625717a49ba32d503c00adbdc63ab6d6 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Libyui is a widget abstraction library providing Qt, GTK and ncurses frontends."
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "LGPL-3.0-only"
Andrew Geisslere34f8962021-04-15 15:53:51 -05003LIC_FILES_CHKSUM = "file://../COPYING.gpl-3;md5=d32239bcb673463ab874e80d47fae504 \
4 file://../COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \
5 file://../COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
Brad Bishop316dfdd2018-06-25 12:45:53 -04006 "
7
Andrew Geissler595f6302022-01-24 19:11:47 +00008SRC_URI = "git://github.com/libyui/libyui.git;branch=master;protocol=https \
Brad Bishop316dfdd2018-06-25 12:45:53 -04009 file://0001-Fix-build-with-clang.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010 file://0001-Use-relative-install-paths-for-CMake.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040011 "
12
Andrew Geisslere34f8962021-04-15 15:53:51 -050013SRCREV = "718ac672374a2b0f50cbc7d637d90e6471babc3d"
Andrew Geissler97771a32021-03-05 15:23:11 -060014
Andrew Geisslere34f8962021-04-15 15:53:51 -050015S = "${WORKDIR}/git/libyui"
Brad Bishop316dfdd2018-06-25 12:45:53 -040016
17inherit cmake gettext pkgconfig
18
19DEPENDS += "boost"
20
Andrew Geissler97771a32021-03-05 15:23:11 -060021EXTRA_OECMAKE += "-DCMAKE_BUILD_TYPE=RELWITHDEBINFO -DWERROR=OFF"
Brad Bishope42b3e32020-01-15 22:08:42 -050022
Brad Bishop316dfdd2018-06-25 12:45:53 -040023BBCLASSEXTEND = "native nativesdk"
24
Patrick Williams213cb262021-08-07 19:21:33 -050025do_install:append () {
Brad Bishop316dfdd2018-06-25 12:45:53 -040026 if [ "${libdir}" = "${base_prefix}/usr/lib" ] && [ -d ${D}/usr/lib64 ]; then
27 mv ${D}/usr/lib64 ${D}/usr/lib
28 fi
29}
30
Patrick Williams213cb262021-08-07 19:21:33 -050031do_install:append:class-nativesdk () {
Brad Bishop316dfdd2018-06-25 12:45:53 -040032 mkdir -p ${D}/${base_prefix}
33 mv ${D}/usr ${D}/${base_prefix}
34}
35
Patrick Williams213cb262021-08-07 19:21:33 -050036FILES:${PN}-dev = "${libdir}/* ${includedir}/yui*"