blob: f7b0a47be1bb701459977459a08379d89b7693ad [file] [log] [blame]
Ed Tanous9936f862022-09-19 09:13:20 -07001LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=9aa91e13d644326bf281924212862184"
Patrick Williams12fc9392021-08-06 09:16:53 -05002FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
Ed Tanousd9aea6f2019-01-11 16:26:13 -08003DEPENDS += "systemd"
Ed Tanous9936f862022-09-19 09:13:20 -07004SRCREV = "c3939dac2c060651361fc71516806f9ab8c38901"
5PV = "1.8.18+git${SRCPV}"
Ed Tanousd9aea6f2019-01-11 16:26:13 -08006
Patrick Williamsbb99d222022-01-24 15:55:09 -06007SRC_URI = "git://github.com/ipmitool/ipmitool.git;protocol=https;branch=master"
Vernon Mauerye0b32cb2020-03-04 11:02:02 -08008# TODO: when a new company joins the OpenBMC project by signing
9# a CLA, if they have an enterprise number on file with the
10# IANA, the versioned file, $PWD/ipmitool/enterprise-numbers
11# needs to be updated to add their entry. The canonical
12# version of the file is locatede here:
13# https://www.iana.org/assignments/enterprise-numbers
14#
15# This file is manually downloaded so it can be versioned
16# instead of having the makefile download it during do_compile
Vernon Mauery5896a232019-04-23 15:31:51 -070017SRC_URI += " \
Vernon Mauerye0b32cb2020-03-04 11:02:02 -080018 file://enterprise-numbers \
Vernon Mauery5896a232019-04-23 15:31:51 -070019 "
20
Ed Tanous9936f862022-09-19 09:13:20 -070021S = "${WORKDIR}/git"
22
23EXTRA_OECONF:append = " --disable-ipmishell --enable-intf-dbus DEFAULT_INTF=dbus "
24
Patrick Williams12fc9392021-08-06 09:16:53 -050025do_compile:prepend() {
Vernon Mauerye0b32cb2020-03-04 11:02:02 -080026 # copy the SRC_URI version of enterprise-numbers
27 # to the build dir to prevent a fetch
James Feist19841272020-05-01 14:35:25 -070028 mkdir -p "${WORKDIR}/build"
Vernon Mauerye0b32cb2020-03-04 11:02:02 -080029 cp "${WORKDIR}/enterprise-numbers" "${WORKDIR}/build/enterprise-numbers"
30}
31
Ed Tanous9936f862022-09-19 09:13:20 -070032# make sure that the enterprise-numbers file gets installed in the root FS
33FILES:${PN} += "/usr/share/misc/enterprise-numbers"