blob: 46bfcbd11dc8c716659ff93a8f20b2ed6db13741 [file] [log] [blame]
Vishwanatha Subbanna9cd1b332017-01-09 16:02:27 +05301SUMMARY = "Phosphor Physical LED Controller daemon"
2DESCRIPTION = "Daemon to trigger actions on a physical LED"
3HOMEPAGE = "http://github.com/openbmc/phosphor-led-sysfs"
Vishwanatha Subbanna9cd1b332017-01-09 16:02:27 +05304LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Vishwanatha Subbanna9cd1b332017-01-09 16:02:27 +05306DEPENDS += "sdbusplus"
Brad Bishop44f3cce2019-03-22 23:41:42 -04007DEPENDS += "systemd"
Xo Wang0d7ad402017-03-14 16:40:31 -07008DEPENDS += "phosphor-dbus-interfaces"
Andrew Geissler39b2f922019-06-25 02:12:26 +00009DEPENDS += "boost"
Ed Tanous9936f862022-09-19 09:13:20 -070010SRCREV = "02f366d68bb9752e6de04db0efc8eb885b19b219"
11PV = "1.0+git${SRCPV}"
12PR = "r1"
William A. Kennington III088a2ba2021-06-02 13:27:47 -070013
Patrick Williamsbb99d222022-01-24 15:55:09 -060014SRC_URI += "git://github.com/openbmc/phosphor-led-sysfs;branch=master;protocol=https"
Brad Bishop807fdd22017-01-26 12:36:52 -050015SRC_URI += "file://70-leds.rules"
Ed Tanous9936f862022-09-19 09:13:20 -070016
Vishwanatha Subbanna9cd1b332017-01-09 16:02:27 +053017S = "${WORKDIR}/git"
Brad Bishop807fdd22017-01-26 12:36:52 -050018
Ed Tanous9936f862022-09-19 09:13:20 -070019inherit meson pkgconfig
20inherit obmc-phosphor-dbus-service
21
22EXTRA_OEMESON:append = " -Dtests=disabled"
23
Patrick Williams12fc9392021-08-06 09:16:53 -050024do_install:append() {
Anton Blanchard782d7192021-08-16 23:51:27 -060025 install -d ${D}/${nonarch_base_libdir}/udev/rules.d/
26 install -m 0644 ${WORKDIR}/70-leds.rules ${D}/${nonarch_base_libdir}/udev/rules.d/
Brad Bishop807fdd22017-01-26 12:36:52 -050027}
Ed Tanous9936f862022-09-19 09:13:20 -070028
29DBUS_SERVICE:${PN} += "xyz.openbmc_project.led.controller@.service"