Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Userspace NFS server v3 protocol" |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 2 | DESCRIPTION = "UNFS3 is a user-space implementation of the NFSv3 server \ |
| 3 | specification. It provides a daemon for the MOUNT and NFS protocols, which \ |
| 4 | are used by NFS clients for accessing files on the server." |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 5 | SECTION = "console/network" |
| 6 | LICENSE = "unfs3" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e" |
| 8 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 9 | DEPENDS = "flex-native bison-native flex" |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 10 | DEPENDS += "libtirpc" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 11 | DEPENDS_append_class-nativesdk = " flex-nativesdk" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 12 | |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 13 | ASNEEDED = "" |
| 14 | |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 15 | S = "${WORKDIR}/git" |
| 16 | SRC_URI = "git://github.com/unfs3/unfs3.git;protocol=https \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 17 | file://unfs3_parallel_build.patch \ |
| 18 | file://alternate_rpc_ports.patch \ |
| 19 | file://fix_pid_race_parent_writes_child_pid.patch \ |
| 20 | file://fix_compile_warning.patch \ |
| 21 | file://rename_fh_cache.patch \ |
| 22 | file://relative_max_socket_path_len.patch \ |
| 23 | file://tcp_no_delay.patch \ |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 24 | file://0001-daemon.c-Libtirpc-porting-fixes.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 25 | file://0001-attr-fix-utime-for-symlink.patch \ |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 26 | file://0001-Add-listen-action-for-a-tcp-socket.patch \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 27 | file://no-yywrap.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | " |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 29 | SRCREV = "c12a5c69a8d59be6916cbd0e0f41c159f1962425" |
| 30 | UPSTREAM_CHECK_GITTAGREGEX = "unfs3\-(?P<pver>.+)" |
| 31 | |
| 32 | PV = "0.9.22+${SRCPV}" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 33 | |
| 34 | BBCLASSEXTEND = "native nativesdk" |
| 35 | |
| 36 | inherit autotools |
| 37 | EXTRA_OECONF_append_class-native = " --sbindir=${bindir}" |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 38 | CFLAGS_append = " -I${STAGING_INCDIR}/tirpc" |
| 39 | LDFLAGS_append = " -ltirpc" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 40 | |
| 41 | # Turn off these header detects else the inode search |
| 42 | # will walk entire file systems and this is a real problem |
| 43 | # if you have 2 TB of files to walk in your file system |
| 44 | CACHED_CONFIGUREVARS = "ac_cv_header_mntent_h=no ac_cv_header_sys_mnttab_h=no" |