blob: 9948b9e6e7ca979d7fe045a67fc8da1b731eb9f4 [file] [log] [blame]
Cyril Burb73580e2017-01-12 18:13:30 +11001SUMMARY = "Phosphor OpenBMC MBOX Daemon"
2DESCRIPTION = "Phosphor OpenBMC MBOX Daemon"
Cyril Burb73580e2017-01-12 18:13:30 +11003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Cyril Burb73580e2017-01-12 18:13:30 +11005DEPENDS += "autoconf-archive-native"
Andrew Jeffery5ade8402017-04-21 10:18:24 +09306DEPENDS += "systemd"
Patrick Williamsf55db882017-06-30 12:01:49 -05007DEPENDS += "phosphor-logging"
Ed Tanous9936f862022-09-19 09:13:20 -07008PROVIDES += "mboxctl"
Andrew Geissleraf6dc722022-09-21 13:41:10 -05009SRCREV = "a75dcde3638fde9173619e4d8f6cc8114247fbfb"
Ed Tanous9936f862022-09-19 09:13:20 -070010# Enable virtual-pnor by DISTRO_FEATURE openpower-virtual-pnor.
11PACKAGECONFIG:append:df-openpower-virtual-pnor = " virtual-pnor"
12PACKAGECONFIG[virtual-pnor] = "--enable-virtual-pnor,--disable-virtual-pnor"
13PV = "1.0+git${SRCPV}"
14PR = "r1"
Cyril Burb73580e2017-01-12 18:13:30 +110015
Patrick Williams98b47062022-09-21 11:30:38 -050016SRC_URI += "git://github.com/openbmc/hiomapd.git;branch=master;protocol=https"
Andrew Jeffery2a0cb542017-01-25 13:17:13 +103017SRC_URI += "file://99-aspeed-lpc-ctrl.rules"
Cyril Burb73580e2017-01-12 18:13:30 +110018
Ed Tanous9936f862022-09-19 09:13:20 -070019S = "${WORKDIR}/git"
Cyril Burb73580e2017-01-12 18:13:30 +110020SYSTEMD_SUBSTITUTIONS += "FLASH_SIZE:${MBOXD_FLASH_SIZE}:${PN}.service"
Ed Tanous9936f862022-09-19 09:13:20 -070021SYSTEMD_SERVICE:${PN} += "mboxd.service"
22SYSTEMD_SERVICE:${PN} += "mboxd-reload@.service"
23SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
24
25inherit autotools pkgconfig
26inherit obmc-phosphor-systemd
Cyril Burb73580e2017-01-12 18:13:30 +110027
Patrick Williams12fc9392021-08-06 09:16:53 -050028do_install:append() {
Anton Blanchard782d7192021-08-16 23:51:27 -060029 install -d ${D}/${nonarch_base_libdir}/udev/rules.d
30 install -m 0644 ${WORKDIR}/99-aspeed-lpc-ctrl.rules ${D}/${nonarch_base_libdir}/udev/rules.d
Cyril Burb73580e2017-01-12 18:13:30 +110031}
Matt Spinler9f77d282017-01-20 15:32:07 -060032
Ed Tanous9936f862022-09-19 09:13:20 -070033MBOXD_FLASH_SIZE ??= "32M"
Matt Spinler9f77d282017-01-20 15:32:07 -060034TMPL = "mboxd-reload@.service"
Andrew Geissler18e71272020-01-13 15:57:38 -060035TGTFMT = "obmc-host-startmin@{0}.target"
Matt Spinler9f77d282017-01-20 15:32:07 -060036INSTFMT = "mboxd-reload@{0}.service"
37FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"