blob: ce0fa1ee8aca0ef6ca798e316675974d30567f63 [file] [log] [blame]
Patrick Williams9e206392017-01-19 21:20:46 -06001SUMMARY = "Phosphor State Management"
2DESCRIPTION = "Phosphor State Manager provides a set of system state \
3management daemons. It is suitable for use on a wide variety of OpenBMC \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager"
6PR = "r1"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10STATE_MGR_PACKAGES = " \
11 ${PN}-host \
12 ${PN}-chassis \
Josh Kingd2b95c72017-01-19 14:04:03 -060013 ${PN}-bmc \
Michael Tritzb6e965c2017-04-18 17:01:12 -050014 ${PN}-discover \
Patrick Williams9e206392017-01-19 21:20:46 -060015"
16PACKAGES =+ "${STATE_MGR_PACKAGES}"
Brad Bishop1a5a5972017-03-01 16:08:45 -050017PACKAGES_remove = "${PN}"
18RDEPENDS_${PN}-dev = "${STATE_MGR_PACKAGES}"
19RDEPENDS_${PN}-staticdev = "${STATE_MGR_PACKAGES}"
20
Patrick Williams9e206392017-01-19 21:20:46 -060021DBUS_PACKAGES = "${STATE_MGR_PACKAGES}"
22
Michael Tritzb3b58992017-03-31 12:04:32 -050023SYSTEMD_PACKAGES = "${PN}-discover"
Patrick Williams9e206392017-01-19 21:20:46 -060024
25inherit autotools pkgconfig
26inherit obmc-phosphor-dbus-service
27
28DEPENDS += "autoconf-archive-native"
29DEPENDS += "sdbusplus"
30DEPENDS += "phosphor-logging"
Patrick Williams1815f6b2017-01-30 11:06:16 -060031DEPENDS += "phosphor-dbus-interfaces"
Adriana Kobylak86354212017-01-30 20:30:00 -060032RDEPENDS_${PN} += "sdbusplus"
Patrick Williams9e206392017-01-19 21:20:46 -060033
Patrick Williams1815f6b2017-01-30 11:06:16 -060034RDEPENDS_${PN}-host += "libsystemd phosphor-dbus-interfaces"
35RDEPENDS_${PN}-chassis += "libsystemd phosphor-dbus-interfaces"
36RDEPENDS_${PN}-bmc += "libsystemd phosphor-dbus-interfaces"
Michael Tritzb6e965c2017-04-18 17:01:12 -050037RDEPENDS_${PN}-discover += "libsystemd phosphor-dbus-interfaces"
Patrick Williams9e206392017-01-19 21:20:46 -060038
Patrick Williams9e206392017-01-19 21:20:46 -060039FILES_${PN}-host = "${sbindir}/phosphor-host-state-manager"
40DBUS_SERVICE_${PN}-host += "xyz.openbmc_project.State.Host.service"
41
Patrick Williams9e206392017-01-19 21:20:46 -060042FILES_${PN}-chassis = "${sbindir}/phosphor-chassis-state-manager"
43DBUS_SERVICE_${PN}-chassis += "xyz.openbmc_project.State.Chassis.service"
44
Josh Kingd2b95c72017-01-19 14:04:03 -060045FILES_${PN}-bmc = "${sbindir}/phosphor-bmc-state-manager"
46DBUS_SERVICE_${PN}-bmc += "xyz.openbmc_project.State.BMC.service"
47
Michael Tritzb6e965c2017-04-18 17:01:12 -050048FILES_${PN}-discover = "${sbindir}/phosphor-discover-system-state"
Michael Tritzb3b58992017-03-31 12:04:32 -050049SYSTEMD_SERVICE_${PN}-discover += "phosphor-discover-system-state@.service"
50
51TMPL = "phosphor-discover-system-state@.service"
52INSTFMT = "phosphor-discover-system-state@{0}.service"
53FMT = "../${TMPL}:${SYSTEMD_DEFAULT_TARGET}.wants/${INSTFMT}"
54SYSTEMD_LINK_${PN}-discover += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}"
Michael Tritzb6e965c2017-04-18 17:01:12 -050055
Patrick Williams9e206392017-01-19 21:20:46 -060056SRC_URI += "git://github.com/openbmc/phosphor-state-manager"
Patrick Williams113a5c82017-04-20 10:50:05 -050057SRCREV = "cc3fb5d9a720a9a5b2102683da716004cd938e39"
Patrick Williams9e206392017-01-19 21:20:46 -060058
59S = "${WORKDIR}/git"