blob: e5bc7dc1bb4712817147ef4b9ad30276a72dbd56 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Performance analysis tools for Linux"
2DESCRIPTION = "Performance counters for Linux are a new kernel-based \
3subsystem that provide a framework for all things \
4performance analysis. It covers hardware level \
5(CPU/PMU, Performance Monitoring Unit) features \
6and software features (software counters, tracepoints) \
7as well."
Joel Stanleye252c312017-12-14 15:11:12 +10308HOMEPAGE = "https://perf.wiki.kernel.org/index.php/Main_Page"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
10LICENSE = "GPLv2"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
12PR = "r9"
13
Joel Stanleye252c312017-12-14 15:11:12 +103014PACKAGECONFIG ??= "scripting tui libunwind"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015PACKAGECONFIG[dwarf] = ",NO_DWARF=1"
Brad Bishop79641f22019-09-10 07:20:22 -040016PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python3"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017# gui support was added with kernel 3.6.35
18# since 3.10 libnewt was replaced by slang
19# to cover a wide range of kernel we add both dependencies
Joel Stanleye252c312017-12-14 15:11:12 +103020PACKAGECONFIG[tui] = ",NO_NEWT=1,libnewt slang"
21PACKAGECONFIG[libunwind] = ",NO_LIBUNWIND=1 NO_LIBDW_DWARF_UNWIND=1,libunwind"
22PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1"
23PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap"
24PACKAGECONFIG[jvmti] = ",NO_JVMTI=1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040025# libaudit support would need scripting to be enabled
26PACKAGECONFIG[audit] = ",NO_LIBAUDIT=1,audit"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027PACKAGECONFIG[manpages] = ",,xmlto-native asciidoc-native"
Brad Bishop64c979e2019-11-04 13:55:29 -050028PACKAGECONFIG[cap] = ",,libcap"
Andrew Geisslerb7d28612020-07-24 16:15:54 -050029# Arm CoreSight
30PACKAGECONFIG[coresight] = "CORESIGHT=1,,opencsd"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031
32# libunwind is not yet ported for some architectures
33PACKAGECONFIG_remove_arc = "libunwind"
34PACKAGECONFIG_remove_riscv64 = "libunwind"
Brad Bishop316dfdd2018-06-25 12:45:53 -040035
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036DEPENDS = " \
37 virtual/${MLPREFIX}libc \
38 ${MLPREFIX}elfutils \
39 ${MLPREFIX}binutils \
Brad Bishop316dfdd2018-06-25 12:45:53 -040040 bison-native flex-native xz \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050041"
42
43do_configure[depends] += "virtual/kernel:do_shared_workdir"
44
45PROVIDES = "virtual/perf"
46
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080047inherit linux-kernel-base kernel-arch manpages
Patrick Williamsc124f4f2015-09-15 14:41:29 -050048
49# needed for building the tools/perf Python bindings
Brad Bishop79641f22019-09-10 07:20:22 -040050inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'python3native', '', d)}
51inherit python3-dir
Patrick Williamsc124f4f2015-09-15 14:41:29 -050052export PYTHON_SITEPACKAGES_DIR
53
54#kernel 3.1+ supports WERROR to disable warnings as errors
55export WERROR = "0"
56
Andrew Geissler82c905d2020-04-13 13:39:40 -050057do_populate_lic[depends] += "virtual/kernel:do_shared_workdir"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050058
59# needed for building the tools/perf Perl binding
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080060include ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'perf-perl.inc', '', d)}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050061
62inherit kernelsrc
63
Brad Bishop316dfdd2018-06-25 12:45:53 -040064S = "${WORKDIR}/${BP}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050065SPDX_S = "${S}/tools/perf"
66
Patrick Williamsc124f4f2015-09-15 14:41:29 -050067# The LDFLAGS is required or some old kernels fails due missing
68# symbols and this is preferred than requiring patches to every old
69# supported kernel.
70LDFLAGS="-ldl -lutil"
71
72EXTRA_OEMAKE = '\
73 -C ${S}/tools/perf \
74 O=${B} \
75 CROSS_COMPILE=${TARGET_PREFIX} \
76 ARCH=${ARCH} \
77 CC="${CC}" \
Andrew Geissler82c905d2020-04-13 13:39:40 -050078 CCLD="${CC}" \
79 LDSHARED="${CC} -shared" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050080 AR="${AR}" \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060081 LD="${LD}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050082 EXTRA_CFLAGS="-ldw" \
Joel Stanleye252c312017-12-14 15:11:12 +103083 EXTRA_LDFLAGS="${PERF_EXTRA_LDFLAGS}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050084 perfexecdir=${libexecdir} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080085 NO_GTK2=1 \
Joel Stanleye252c312017-12-14 15:11:12 +103086 ${PACKAGECONFIG_CONFARGS} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080087 TMPDIR="${B}" \
Brad Bishop19323692019-04-05 15:28:33 -040088 LIBUNWIND_DIR=${STAGING_EXECPREFIXDIR} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050089'
90
91EXTRA_OEMAKE += "\
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050092 'DESTDIR=${D}' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050093 'prefix=${prefix}' \
94 'bindir=${bindir}' \
95 'sharedir=${datadir}' \
96 'sysconfdir=${sysconfdir}' \
97 'perfexecdir=${libexecdir}/perf-core' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050098 'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \
99 'sharedir=${@os.path.relpath(datadir, prefix)}' \
100 'mandir=${@os.path.relpath(mandir, prefix)}' \
101 'infodir=${@os.path.relpath(infodir, prefix)}' \
Brad Bishop79641f22019-09-10 07:20:22 -0400102 ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'PYTHON=python3 PYTHON_CONFIG=python3-config', '', d)} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500103"
104
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700105# During do_configure, we might run a 'make clean'. That often breaks
106# when done in parallel, so disable parallelism for do_configure. Note
107# that it has to be done this way rather than by passing -j1, since
108# perf's build system by default ignores any -j argument, but does
109# honour a JOBS variable.
110EXTRA_OEMAKE_append_task-configure = " JOBS=1"
111
Brad Bishop316dfdd2018-06-25 12:45:53 -0400112PERF_SRC ?= "Makefile \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400113 tools/arch \
114 tools/build \
115 tools/include \
116 tools/lib \
117 tools/Makefile \
118 tools/perf \
119 tools/scripts \
Brad Bishop64c979e2019-11-04 13:55:29 -0500120 scripts/ \
121 arch/${ARCH}/Makefile \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400122"
123
Joel Stanleye252c312017-12-14 15:11:12 +1030124PERF_EXTRA_LDFLAGS = ""
125
126# MIPS N32
127PERF_EXTRA_LDFLAGS_mipsarchn32eb = "-m elf32btsmipn32"
128PERF_EXTRA_LDFLAGS_mipsarchn32el = "-m elf32ltsmipn32"
129
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500130do_compile() {
131 # Linux kernel build system is expected to do the right thing
132 unset CFLAGS
133 oe_runmake all
134}
135
136do_install() {
137 # Linux kernel build system is expected to do the right thing
138 unset CFLAGS
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500139 oe_runmake install
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500140 # we are checking for this make target to be compatible with older perf versions
Joel Stanleye252c312017-12-14 15:11:12 +1030141 if ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'true', 'false', d)} && grep -q install-python_ext ${S}/tools/perf/Makefile*; then
Brad Bishop79641f22019-09-10 07:20:22 -0400142 oe_runmake DESTDIR=${D} install-python_ext
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500143 fi
144}
145
Brad Bishop316dfdd2018-06-25 12:45:53 -0400146do_configure[prefuncs] += "copy_perf_source_from_kernel"
147python copy_perf_source_from_kernel() {
148 sources = (d.getVar("PERF_SRC") or "").split()
149 src_dir = d.getVar("STAGING_KERNEL_DIR")
150 dest_dir = d.getVar("S")
151 bb.utils.mkdirhier(dest_dir)
Andrew Geissler82c905d2020-04-13 13:39:40 -0500152 bb.utils.prunedir(dest_dir)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400153 for s in sources:
154 src = oe.path.join(src_dir, s)
155 dest = oe.path.join(dest_dir, s)
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800156 if not os.path.exists(src):
157 bb.fatal("Path does not exist: %s. Maybe PERF_SRC does not match the kernel version." % src)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400158 if os.path.isdir(src):
159 oe.path.copyhardlinktree(src, dest)
160 else:
Brad Bishop64c979e2019-11-04 13:55:29 -0500161 src_path = os.path.dirname(s)
162 os.makedirs(os.path.join(dest_dir,src_path),exist_ok=True)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400163 bb.utils.copyfile(src, dest)
164}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500165
Brad Bishop316dfdd2018-06-25 12:45:53 -0400166do_configure_prepend () {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500167 # If building a multlib based perf, the incorrect library path will be
168 # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit
Andrew Geissler82c905d2020-04-13 13:39:40 -0500169 # build, with a 64 bit multilib, the arch won't match and the detection of a
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500170 # 64 bit build (and library) are not exected. To ensure that libraries are
171 # installed to the correct location, we can use the weak assignment in the
172 # config/Makefile.
173 #
174 # Also need to relocate .config-detected to $(OUTPUT)/config-detected
175 # for kernel sources that do not already do this
176 # as two builds (e.g. perf and lib32-perf from mutlilib can conflict
177 # with each other if its in the shared source directory
178 #
179 if [ -e "${S}/tools/perf/config/Makefile" ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600180 perfconfig="${S}/tools/perf/config/Makefile"
181 fi
182 if [ -e "${S}/tools/perf/Makefile.config" ]; then
183 perfconfig="${S}/tools/perf/Makefile.config"
184 fi
185 if [ -n "${perfconfig}" ]; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500186 # Match $(prefix)/$(lib) and $(prefix)/lib
187 sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \
188 -e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \
189 -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600190 ${perfconfig}
191 fi
192 # The man pages installation is "$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)"
193 # in ${S}/tools/perf/Documentation/Makefile, if the mandir set to '?=', it
194 # will use the relative path 'share/man', in the way it will resulting in
195 # incorrect installation for man pages.
196 if [ -e "${S}/tools/perf/Documentation/Makefile" ]; then
197 sed -i 's,^mandir?=,mandir:=,' ${S}/tools/perf/Documentation/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500198 fi
199 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
200 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
201 ${S}/tools/perf/Makefile.perf
202 sed -i -e "s,prefix='\$(DESTDIR_SQ)/usr'$,prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
203 ${S}/tools/perf/Makefile.perf
204 fi
205 sed -i -e "s,--root='/\$(DESTDIR_SQ)',--prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
Patrick Williamsd7e96312015-09-22 08:09:05 -0500206 ${S}/tools/perf/Makefile*
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500207
208 if [ -e "${S}/tools/build/Makefile.build" ]; then
209 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
210 ${S}/tools/build/Makefile.build
211 fi
212
213 # We need to ensure the --sysroot option in CC is preserved
214 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
215 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/perf/Makefile.perf
216 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600217 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500218 fi
219 if [ -e "${S}/tools/lib/api/Makefile" ]; then
220 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/api/Makefile
221 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/api/Makefile
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600222 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/lib/api/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500223 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500224 if [ -e "${S}/tools/lib/subcmd/Makefile" ]; then
225 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/subcmd/Makefile
226 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/subcmd/Makefile
227 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500228 if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then
229 sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile
230 fi
231 if [ -e "${S}/tools/build/Makefile.feature" ]; then
232 sed -i 's,CFLAGS=,CC="\$(CC)" CFLAGS=,' ${S}/tools/build/Makefile.feature
233 fi
234
235 # 3.17-rc1+ has a include issue for arm/powerpc. Temporarily sed in the appropriate include
236 if [ -e "${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c" ]; then
237 sed -i 's,#include "util/callchain.h",#include "util/callchain.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c
238 fi
239 if [ -e "${S}/tools/perf/arch/arm/util/unwind-libunwind.c" ] && [ -e "${S}/tools/perf/arch/arm/tests/dwarf-unwind.c" ]; then
240 sed -i 's,#include "tests/tests.h",#include "tests/tests.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/tests/dwarf-unwind.c
241 sed -i 's,#include "perf_regs.h",#include "perf_regs.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/util/unwind-libunwind.c
242 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500243
244 # use /usr/bin/env instead of version specific python
Andrew Geissler82c905d2020-04-13 13:39:40 -0500245 for s in `find ${S}/tools/perf/ -name '*.py'` `find ${S}/scripts/ -name 'bpf_helpers_doc.py'`; do
246 sed -i -e "s,#!.*python.*,#!${USRBINPATH}/env python3," ${s}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500247 done
Brad Bishop19323692019-04-05 15:28:33 -0400248
249 # unistd.h can be out of sync between libc-headers and the captured version in the perf source
250 # so we copy it from the sysroot unistd.h to the perf unistd.h
Brad Bishopc342db32019-05-15 21:57:59 -0400251 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h
Brad Bishop79641f22019-09-10 07:20:22 -0400252 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/include/uapi/asm-generic/unistd.h
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500253}
254
255python do_package_prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500256 d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500257}
258
259PACKAGE_ARCH = "${MACHINE_ARCH}"
260
261
262PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
263
264RDEPENDS_${PN} += "elfutils bash"
265RDEPENDS_${PN}-archive =+ "bash"
Brad Bishop79641f22019-09-10 07:20:22 -0400266RDEPENDS_${PN}-python =+ "bash python3 python3-modules ${@bb.utils.contains('PACKAGECONFIG', 'audit', 'audit-python3', '', d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500267RDEPENDS_${PN}-perl =+ "bash perl perl-modules"
Brad Bishop79641f22019-09-10 07:20:22 -0400268RDEPENDS_${PN}-tests =+ "python3"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500269
Joel Stanleye252c312017-12-14 15:11:12 +1030270RSUGGESTS_SCRIPTING = "${@bb.utils.contains('PACKAGECONFIG', 'scripting', '${PN}-perl ${PN}-python', '',d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500271RSUGGESTS_${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}"
272
Brad Bishop19323692019-04-05 15:28:33 -0400273FILES_SOLIBSDEV = ""
274FILES_${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent ${libdir}/libperf-jvmti.so"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500275FILES_${PN}-archive = "${libdir}/perf/perf-core/perf-archive"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500276FILES_${PN}-tests = "${libdir}/perf/perf-core/tests ${libexecdir}/perf-core/tests"
Brad Bishop316dfdd2018-06-25 12:45:53 -0400277FILES_${PN}-python = " \
278 ${PYTHON_SITEPACKAGES_DIR} \
279 ${libexecdir}/perf-core/scripts/python \
280 "
281FILES_${PN}-perl = "${libexecdir}/perf-core/scripts/perl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500282
283
284INHIBIT_PACKAGE_DEBUG_SPLIT="1"
Brad Bishopc342db32019-05-15 21:57:59 -0400285DEBUG_OPTIMIZATION_append = " -Wno-error=maybe-uninitialized"