blob: 2307dc6279e45dc747d606652432c4b55b76501c [file] [log] [blame]
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +05301SUMMARY = "Phosphor Watchdog application"
2DESCRIPTION = "Application that implements software watchdog"
3HOMEPAGE = "http://github.com/openbmc/phosphor-watchdog"
4PR = "r1"
Patrick Venturea1a628b2018-10-01 20:48:41 -07005PV = "1.0+git${SRCPV}"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +05306LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Patrick Venturea1a628b2018-10-01 20:48:41 -07008
William A. Kennington III7d98c922019-03-28 03:38:35 -07009inherit meson pkgconfig
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053010inherit obmc-phosphor-dbus-service
11
Patrick Williams12fc9392021-08-06 09:16:53 -050012RPROVIDES:${PN} += "virtual/obmc-watchdog"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053013PROVIDES += "virtual/obmc-watchdog"
14
William A. Kennington IIIf33e9a12018-09-14 00:25:00 -070015DEPENDS += "cli11"
William A. Kennington IIIf37d0962019-03-27 20:21:26 -070016DEPENDS += "sdbusplus"
William A. Kennington III83d610a2018-09-13 23:32:19 -070017DEPENDS += "sdeventplus"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053018DEPENDS += "phosphor-dbus-interfaces"
19DEPENDS += "phosphor-logging"
Brad Bishop44f3cce2019-03-22 23:41:42 -040020DEPENDS += "systemd"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053021
Patrick Williamsbb99d222022-01-24 15:55:09 -060022SRC_URI += "git://github.com/openbmc/phosphor-watchdog;branch=master;protocol=https"
Andrew Geissler234fca52022-01-14 21:40:12 +000023SRCREV = "6f80f80e02f220d3d13a0a6271fa1afd54dc706d"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053024S = "${WORKDIR}/git"
25
William A. Kennington III7d98c922019-03-28 03:38:35 -070026EXTRA_OEMESON = " \
27 -Dtests=disabled \
28 "
29
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053030# Copies config file having arguments for host watchdog
Patrick Williamse83c2202021-09-01 16:17:33 -050031SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/watchdog/poweron"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053032
33# Install the override to set up a Conflicts relation
Patrick Williamse83c2202021-09-01 16:17:33 -050034SYSTEMD_OVERRIDE:${PN} += "poweron.conf:phosphor-watchdog@poweron.service.d/poweron.conf"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053035
36# For now, watching PowerOn is the only usecase
37OBMC_HOST_WATCHDOG_INSTANCES = "poweron"
38
39# This is really a DBUS service but the service name is
40# an argument, so making it this way.
41WATCHDOG_TMPL = "phosphor-watchdog@.service"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053042ENABLE_WATCHDOG_TMPL = "obmc-enable-host-watchdog@.service"
Patrick Williams12fc9392021-08-06 09:16:53 -050043SYSTEMD_SERVICE:${PN} += "${WATCHDOG_TMPL}"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053044
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053045# To Enable Host Watchdog early during poweron
Patrick Williams12fc9392021-08-06 09:16:53 -050046SYSTEMD_SERVICE:${PN} += "${ENABLE_WATCHDOG_TMPL}"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053047
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053048WATCHDOG_TGTFMT = "phosphor-watchdog@{0}.service"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053049ENABLE_WATCHDOG_TGTFMT = "obmc-enable-host-watchdog@{0}.service"
50
Andrew Geissler5c76e0c2018-03-27 13:56:26 -070051WATCHDOG_FMT = "../${WATCHDOG_TMPL}:obmc-host-startmin@{1}.target.wants/${WATCHDOG_TGTFMT}"
52ENABLE_WATCHDOG_FMT = "../${ENABLE_WATCHDOG_TMPL}:obmc-host-startmin@{0}.target.wants/${ENABLE_WATCHDOG_TGTFMT}"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053053
Patrick Williamse83c2202021-09-01 16:17:33 -050054SYSTEMD_LINK:${PN} += "${@compose_list(d, 'WATCHDOG_FMT', 'OBMC_HOST_WATCHDOG_INSTANCES', 'OBMC_HOST_INSTANCES')}"
55SYSTEMD_LINK:${PN} += "${@compose_list(d, 'ENABLE_WATCHDOG_FMT', 'OBMC_HOST_INSTANCES')}"