blob: 894ee52f96f171f8695f496203c0d151f35b35b4 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "USB CEC Adaptor communication Library"
2HOMEPAGE = "http://libcec.pulse-eight.com/"
3
4LICENSE = "GPLv2+"
Andrew Geissler82c905d2020-04-13 13:39:40 -05005LIC_FILES_CHKSUM = "file://COPYING;md5=b3a719e97f49e4841e90573f9b1a98ac"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05006
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007DEPENDS = "p8platform udev ncurses swig-native python3"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11 libxrandr', '', d)}"
10DEPENDS_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', ' userland', d)}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050012SRCREV = "29d82c80bcc62be2878a9ac080de7eb286c4beb9"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013SRC_URI = "git://github.com/Pulse-Eight/libcec.git;branch=release \
Brad Bishope42b3e32020-01-15 22:08:42 -050014 file://0001-CheckPlatformSupport.cmake-Do-not-hardcode-lib-path.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 file://0001-Enhance-reproducibility.patch \
Brad Bishope42b3e32020-01-15 22:08:42 -050016 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017
18S = "${WORKDIR}/git"
19
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020inherit cmake pkgconfig
21
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022# Put client tools into a separate package
23PACKAGE_BEFORE_PN += "${PN}-tools"
24FILES_${PN}-tools = "${bindir}"
Brad Bishop90ca7472019-08-20 09:15:15 -040025RDEPENDS_${PN}-tools = "python3-${BPN} python3-core"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080026
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027# Create the wrapper for python3
28PACKAGES += "python3-${BPN}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029FILES_python3-${BPN} = "${libdir}/python3* ${bindir}/py*"
30RDEPENDS_${PN} = "python3-core"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050031
32# cec-client and xbmc need the .so present to work :(
33FILES_${PN} += "${libdir}/*.so"
34INSANE_SKIP_${PN} = "dev-so"
35
36# Adapter shows up as a CDC-ACM device
37RRECOMMENDS_${PN} = "kernel-module-cdc-acm"