blob: 28565eb8caa0f2533071ed269c7fc02103bcb0ec [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Firmware testsuite"
2DESCRIPTION = "The tool fwts comprises of over fifty tests that are designed to exercise and test different aspects of a machine's firmware. Many of these tests need super user access to read BIOS data and ACPI tables, so the tool requires running with super user privileges (e.g. with sudo)."
3HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
4
5LICENSE = "GPLv2+"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05008SRC_URI = "http://fwts.ubuntu.com/release/fwts-V${PV}.tar.gz;subdir=${BP} \
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009 file://0001-Include-poll.h-instead-of-deprecated-sys-poll.h.patch \
10 file://0002-Define-__SWORD_TYPE-if-not-defined-by-libc.patch \
11 file://0003-Undefine-PAGE_SIZE.patch \
12 file://0001-Add-correct-printf-qualifier-for-off_t.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013 file://0003-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014 file://0001-Remove-Werror-from-build.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015 "
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050016SRC_URI[sha256sum] = "4a8e0211b388efbcfcb6530297e9a924d0afa2d6db58e9db2f031129eda6d66f"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050019
Brad Bishop26bdd442019-08-16 17:08:17 -040020DEPENDS = "libpcre json-c glib-2.0 dtc bison-native libbsd"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021DEPENDS_append_libc-musl = " libexecinfo"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050022
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050023inherit autotools-brokensep bash-completion pkgconfig
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024
25CFLAGS += "-I${STAGING_INCDIR}/json-c -Wno-error=unknown-pragmas"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026LDFLAGS_append_libc-musl = " -lexecinfo"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050027
28FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
29FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
30FILES_${PN}-staticdev += "${libdir}/fwts/lib*a"
31FILES_${PN}-dbg += "${libdir}/fwts/.debug"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032