blob: e9628033c685cb903c897213094de956ca448f4a [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001inherit siteinfo python3native
Brad Bishop316dfdd2018-06-25 12:45:53 -04002
3DEPENDS_append = " meson-native ninja-native"
4
5# As Meson enforces out-of-tree builds we can just use cleandirs
6B = "${WORKDIR}/build"
7do_configure[cleandirs] = "${B}"
8
9# Where the meson.build build configuration is
10MESON_SOURCEPATH = "${S}"
11
12def noprefix(var, d):
13 return d.getVar(var).replace(d.getVar('prefix') + '/', '', 1)
14
Andrew Geissler82c905d2020-04-13 13:39:40 -050015MESON_BUILDTYPE ?= "plain"
Brad Bishop316dfdd2018-06-25 12:45:53 -040016MESONOPTS = " --prefix ${prefix} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050017 --buildtype ${MESON_BUILDTYPE} \
Brad Bishop316dfdd2018-06-25 12:45:53 -040018 --bindir ${@noprefix('bindir', d)} \
19 --sbindir ${@noprefix('sbindir', d)} \
20 --datadir ${@noprefix('datadir', d)} \
21 --libdir ${@noprefix('libdir', d)} \
22 --libexecdir ${@noprefix('libexecdir', d)} \
23 --includedir ${@noprefix('includedir', d)} \
24 --mandir ${@noprefix('mandir', d)} \
25 --infodir ${@noprefix('infodir', d)} \
26 --sysconfdir ${sysconfdir} \
27 --localstatedir ${localstatedir} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050028 --sharedstatedir ${sharedstatedir} \
29 --wrap-mode nodownload"
Brad Bishop316dfdd2018-06-25 12:45:53 -040030
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031EXTRA_OEMESON_append = " ${PACKAGECONFIG_CONFARGS}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040032
33MESON_CROSS_FILE = ""
34MESON_CROSS_FILE_class-target = "--cross-file ${WORKDIR}/meson.cross"
35MESON_CROSS_FILE_class-nativesdk = "--cross-file ${WORKDIR}/meson.cross"
36
37def meson_array(var, d):
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038 items = d.getVar(var).split()
39 return repr(items[0] if len(items) == 1 else items)
40
41# Map our ARCH values to what Meson expects:
42# http://mesonbuild.com/Reference-tables.html#cpu-families
43def meson_cpu_family(var, d):
44 import re
45 arch = d.getVar(var)
46 if arch == 'powerpc':
47 return 'ppc'
Andrew Geissler82c905d2020-04-13 13:39:40 -050048 elif arch == 'powerpc64' or arch == 'powerpc64le':
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080049 return 'ppc64'
Brad Bishop19323692019-04-05 15:28:33 -040050 elif arch == 'armeb':
51 return 'arm'
Brad Bishop15ae2502019-06-18 21:44:24 -040052 elif arch == 'aarch64_be':
53 return 'aarch64'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080054 elif arch == 'mipsel':
55 return 'mips'
Brad Bishop19323692019-04-05 15:28:33 -040056 elif arch == 'mips64el':
57 return 'mips64'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080058 elif re.match(r"i[3-6]86", arch):
59 return "x86"
Andrew Geissler82c905d2020-04-13 13:39:40 -050060 elif arch == "microblazeel":
Brad Bishopa34c0302019-09-23 22:34:48 -040061 return "microblaze"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080062 else:
63 return arch
64
Andrew Geissler82c905d2020-04-13 13:39:40 -050065# Map our OS values to what Meson expects:
66# https://mesonbuild.com/Reference-tables.html#operating-system-names
67def meson_operating_system(var, d):
68 os = d.getVar(var)
69 if "mingw" in os:
70 return "windows"
71 else:
72 return os
73
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080074def meson_endian(prefix, d):
75 arch, os = d.getVar(prefix + "_ARCH"), d.getVar(prefix + "_OS")
76 sitedata = siteinfo_data_for_machine(arch, os, d)
77 if "endian-little" in sitedata:
78 return "little"
79 elif "endian-big" in sitedata:
80 return "big"
81 else:
82 bb.fatal("Cannot determine endianism for %s-%s" % (arch, os))
Brad Bishop316dfdd2018-06-25 12:45:53 -040083
84addtask write_config before do_configure
Brad Bishop96ff1982019-08-19 13:50:42 -040085do_write_config[vardeps] += "CC CXX LD AR NM STRIP READELF CFLAGS CXXFLAGS LDFLAGS"
Brad Bishop316dfdd2018-06-25 12:45:53 -040086do_write_config() {
87 # This needs to be Py to split the args into single-element lists
88 cat >${WORKDIR}/meson.cross <<EOF
89[binaries]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080090c = ${@meson_array('CC', d)}
91cpp = ${@meson_array('CXX', d)}
92ar = ${@meson_array('AR', d)}
93nm = ${@meson_array('NM', d)}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080094strip = ${@meson_array('STRIP', d)}
95readelf = ${@meson_array('READELF', d)}
Brad Bishop316dfdd2018-06-25 12:45:53 -040096pkgconfig = 'pkg-config'
Brad Bishop08902b02019-08-20 09:16:51 -040097llvm-config = 'llvm-config${LLVMVERSION}'
Brad Bishop316dfdd2018-06-25 12:45:53 -040098
99[properties]
100needs_exe_wrapper = true
Brad Bishop96ff1982019-08-19 13:50:42 -0400101c_args = ${@meson_array('CFLAGS', d)}
102c_link_args = ${@meson_array('LDFLAGS', d)}
103cpp_args = ${@meson_array('CXXFLAGS', d)}
104cpp_link_args = ${@meson_array('LDFLAGS', d)}
Brad Bishop316dfdd2018-06-25 12:45:53 -0400105gtkdoc_exe_wrapper = '${B}/gtkdoc-qemuwrapper'
106
107[host_machine]
Andrew Geissler82c905d2020-04-13 13:39:40 -0500108system = '${@meson_operating_system('HOST_OS', d)}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800109cpu_family = '${@meson_cpu_family('HOST_ARCH', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -0400110cpu = '${HOST_ARCH}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800111endian = '${@meson_endian('HOST', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -0400112
113[target_machine]
Andrew Geissler82c905d2020-04-13 13:39:40 -0500114system = '${@meson_operating_system('TARGET_OS', d)}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800115cpu_family = '${@meson_cpu_family('TARGET_ARCH', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -0400116cpu = '${TARGET_ARCH}'
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800117endian = '${@meson_endian('TARGET', d)}'
Brad Bishop316dfdd2018-06-25 12:45:53 -0400118EOF
119}
120
121CONFIGURE_FILES = "meson.build"
122
123meson_do_configure() {
Andrew Geissler82c905d2020-04-13 13:39:40 -0500124 # Meson requires this to be 'bfd, 'lld' or 'gold' from 0.53 onwards
125 # https://github.com/mesonbuild/meson/commit/ef9aeb188ea2bc7353e59916c18901cde90fa2b3
126 unset LD
127
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800128 # Work around "Meson fails if /tmp is mounted with noexec #2972"
129 mkdir -p "${B}/meson-private/tmp"
130 export TMPDIR="${B}/meson-private/tmp"
131 bbnote Executing meson ${EXTRA_OEMESON}...
Brad Bishop316dfdd2018-06-25 12:45:53 -0400132 if ! meson ${MESONOPTS} "${MESON_SOURCEPATH}" "${B}" ${MESON_CROSS_FILE} ${EXTRA_OEMESON}; then
Brad Bishop316dfdd2018-06-25 12:45:53 -0400133 bbfatal_log meson failed
134 fi
135}
136
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800137override_native_tools() {
Brad Bishop316dfdd2018-06-25 12:45:53 -0400138 # Set these so that meson uses the native tools for its build sanity tests,
139 # which require executables to be runnable. The cross file will still
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800140 # override these for the target build.
Brad Bishop316dfdd2018-06-25 12:45:53 -0400141 export CC="${BUILD_CC}"
142 export CXX="${BUILD_CXX}"
143 export LD="${BUILD_LD}"
144 export AR="${BUILD_AR}"
Brad Bishop96ff1982019-08-19 13:50:42 -0400145 export STRIP="${BUILD_STRIP}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800146 # These contain *target* flags but will be used as *native* flags. The
147 # correct native flags will be passed via -Dc_args and so on, unset them so
148 # they don't interfere with tools invoked by Meson (such as g-ir-scanner)
149 unset CPPFLAGS CFLAGS CXXFLAGS LDFLAGS
150}
151
152meson_do_configure_prepend_class-target() {
153 override_native_tools
Brad Bishop316dfdd2018-06-25 12:45:53 -0400154}
155
156meson_do_configure_prepend_class-nativesdk() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800157 override_native_tools
Brad Bishop316dfdd2018-06-25 12:45:53 -0400158}
159
160meson_do_configure_prepend_class-native() {
161 export PKG_CONFIG="pkg-config-native"
162}
163
Andrew Geissler82c905d2020-04-13 13:39:40 -0500164python meson_do_qa_configure() {
165 import re
166 warn_re = re.compile(r"^WARNING: Cross property (.+) is using default value (.+)$", re.MULTILINE)
Andrew Geisslerc182c622020-05-15 14:13:32 -0500167 with open(d.expand("${B}/meson-logs/meson-log.txt")) as logfile:
168 log = logfile.read()
Andrew Geissler82c905d2020-04-13 13:39:40 -0500169 for (prop, value) in warn_re.findall(log):
170 bb.warn("Meson cross property %s used without explicit assignment, defaulting to %s" % (prop, value))
171}
172do_configure[postfuncs] += "meson_do_qa_configure"
173
Brad Bishop316dfdd2018-06-25 12:45:53 -0400174do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+"
175meson_do_compile() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800176 ninja -v ${PARALLEL_MAKE}
Brad Bishop316dfdd2018-06-25 12:45:53 -0400177}
178
179meson_do_install() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800180 DESTDIR='${D}' ninja -v ${PARALLEL_MAKEINST} install
Brad Bishop316dfdd2018-06-25 12:45:53 -0400181}
182
183EXPORT_FUNCTIONS do_configure do_compile do_install