blob: 411f51ac39482ebda10ca534d59f9ad1042dbfc3 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "XCB: The X protocol C binding library"
2DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \
3for Xlib featuring a small footprint, latency hiding, direct access to \
4the protocol, improved threading support, and extensibility."
5HOMEPAGE = "http://xcb.freedesktop.org"
6BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
7SECTION = "x11/libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7"
11
Andrew Geisslerc5535c92023-01-27 16:10:19 -060012SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.xz \
13 file://0001-use-_Alignof-to-avoid-UB-in-ALIGNOF.patch"
Brad Bishop19323692019-04-05 15:28:33 -040014
Andrew Geisslerd5838332022-05-27 11:33:10 -050015SRC_URI[sha256sum] = "cc38744f817cf6814c847e2df37fcb8997357d72fa4bcbc228ae0fe47219a059"
Brad Bishop19323692019-04-05 15:28:33 -040016
17BBCLASSEXTEND = "native nativesdk"
18
19DEPENDS = "xcb-proto xorgproto libxau libpthread-stubs libxdmcp"
20
Andrew Geissler3b8a17c2021-04-15 15:55:55 -050021PACKAGES_DYNAMIC = "^${PN}-.*"
Brad Bishop19323692019-04-05 15:28:33 -040022
Patrick Williams213cb262021-08-07 19:21:33 -050023FILES:${PN} = "${libdir}/libxcb.so.*"
Brad Bishop19323692019-04-05 15:28:33 -040024
Brad Bishop6dbb3162019-11-25 09:41:34 -050025inherit autotools pkgconfig features_check
Brad Bishop19323692019-04-05 15:28:33 -040026
27# The libxau and others requires x11 in DISTRO_FEATURES
28REQUIRED_DISTRO_FEATURES = "x11"
Brad Bishop19323692019-04-05 15:28:33 -040029
30export PYTHON = "python3"
31
Patrick Williams213cb262021-08-07 19:21:33 -050032do_install:append () {
Andrew Geissler6ce62a22020-11-30 19:58:47 -060033 chown root.root ${D}${datadir}/doc/${BPN}/tutorial -R
34}
35
Patrick Williams213cb262021-08-07 19:21:33 -050036python populate_packages:prepend () {
Andrew Geissler3b8a17c2021-04-15 15:55:55 -050037 do_split_packages(d, '${libdir}', r'^libxcb-(.*)\.so\..*$', '${PN}-%s', 'XCB library module for %s', allow_links=True)
Brad Bishop19323692019-04-05 15:28:33 -040038}