blob: 3dac696801b81de94b5660a6709bcdf2eb93950c [file] [log] [blame]
Brad Bishop37653df2017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
Patrick Venture5bce7d72018-10-21 08:22:43 -07006PV = "1.0+git${SRCPV}"
Brad Bishop75f03872018-11-03 09:41:57 -07007LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05009
10inherit autotools pkgconfig
Matt Spinlereca58902020-03-06 09:24:33 -060011inherit python3native
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050012inherit obmc-phosphor-dbus-service
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050013inherit phosphor-logging
Marri Devender Raobf369d02017-06-06 08:39:39 -050014inherit phosphor-dbus-yaml
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050015
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050016DEPENDS += "autoconf-archive-native"
17DEPENDS += "systemd"
Matt Spinler017f9422020-03-13 15:57:29 -050018DEPENDS += "${PYTHON_PN}-mako-native"
19DEPENDS += "${PYTHON_PN}-pyyaml-native"
20DEPENDS += "${PYTHON_PN}-native"
Patrick Williams4b32c9a2020-03-31 16:43:15 -050021DEPENDS += "${PYTHON_PN}-sdbus++-native"
22DEPENDS += "sdbusplus"
Patrick Williamsadd93832020-06-10 06:52:05 -050023DEPENDS += "phosphor-dbus-interfaces"
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050024DEPENDS += "virtual/phosphor-logging-callouts"
Brad Bishop17c08bf2018-10-18 17:07:53 -040025DEPENDS += "libcereal"
Matt Spinlerf319ea62019-07-23 16:04:04 -050026DEPENDS += "sdeventplus"
Patrick Williamsadd93832020-06-10 06:52:05 -050027DEPENDS_append_class-target = " packagegroup-obmc-yaml-providers"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050028
Michael Tritz026fbaf2017-03-13 14:54:24 -050029PACKAGE_BEFORE_PN = "${PN}-test"
30FILES_${PN}-test = "${bindir}/*-test"
31
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050032PACKAGE_BEFORE_PN += "${PN}-elog"
33FILES_${PN}-elog += "${elog_dir}"
34
Deepak Kodihalli64464772018-08-24 08:05:14 -050035# Package configuration
36LOGGING_PACKAGES = " \
37 ${PN}-base \
Deepak Kodihalli04aa22f2018-08-28 11:39:41 -050038 phosphor-rsyslog-config \
Deepak Kodihalli64464772018-08-24 08:05:14 -050039"
40
41ALLOW_EMPTY_${PN} = "1"
42PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
43SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
44DBUS_PACKAGES = "${LOGGING_PACKAGES}"
45
Deepak Kodihalli64464772018-08-24 08:05:14 -050046FILES_${PN}-base += " \
Patrick Venturecb51ccb2019-04-04 14:49:25 -070047 ${bindir}/phosphor-log-manager \
Deepak Kodihalli64464772018-08-24 08:05:14 -050048 ${libdir}/libphosphor_logging.so.* \
49"
50DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service"
51
Deepak Kodihalli04aa22f2018-08-28 11:39:41 -050052DBUS_SERVICE_phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"
53FILES_phosphor-rsyslog-config += " \
Patrick Venturecb51ccb2019-04-04 14:49:25 -070054 ${bindir}/phosphor-rsyslog-conf \
Deepak Kodihalli04aa22f2018-08-28 11:39:41 -050055"
56
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050057SRC_URI += "git://github.com/openbmc/phosphor-logging"
Andrew Geisslerc6351062020-07-22 13:31:27 +000058SRCREV = "c03123bc0ae30597e3e69086513431706e604129"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050059
60S = "${WORKDIR}/git"
61
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050062# Do not DEPEND on the specified packages for native build
63# as they will not be available in host machine
Brad Bishop096e4b42018-01-27 00:27:21 -050064DEPENDS_remove_class-native = " \
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050065 virtual/phosphor-logging-callouts \
Patrick Williams4b32c9a2020-03-31 16:43:15 -050066 sdbusplus \
Brad Bishop096e4b42018-01-27 00:27:21 -050067 systemd \
Brad Bishop17c08bf2018-10-18 17:07:53 -040068 libcereal \
Matt Spinlerf319ea62019-07-23 16:04:04 -050069 sdeventplus \
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050070 "
71
72# Do not DEPEND on the specified packages for native SDK build
73# as they will not be available in host machine
74DEPENDS_remove_class-nativesdk = " \
75 virtual/phosphor-logging-callouts \
Patrick Williamsa5647132020-04-08 10:51:39 -050076 sdbusplus \
Brad Bishop17c08bf2018-10-18 17:07:53 -040077 libcereal \
Brad Bishop096e4b42018-01-27 00:27:21 -050078 systemd \
79 phosphor-dbus-interfaces \
Matt Spinlerf319ea62019-07-23 16:04:04 -050080 sdeventplus \
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050081 "
82
83PACKAGECONFIG ??= "metadata-processing install_scripts"
84
Deepak Kodihalli430a5062017-03-28 07:47:51 -050085PACKAGECONFIG[metadata-processing] = " \
86 --enable-metadata-processing, \
87 --disable-metadata-processing, , \
88 "
89
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050090# Provide a means to enable/disable install_scripts feature
91PACKAGECONFIG[install_scripts] = " \
92 --enable-install_scripts, \
93 --disable-install_scripts, ,\
94 "
95
Matt Spinlerf8510922019-08-08 13:21:24 -050096PACKAGECONFIG[openpower-pels] = " \
97 --enable-openpower-pel-extension, \
Matt Spinler949e4dc2019-09-26 15:17:15 -050098 --disable-openpower-pel-extension, \
Matt Spinler11ba5162019-12-18 14:27:07 -060099 nlohmann-json nlohmann-fifo cli11 pldm, \
Harisuddin Mohamed Isacdfe38f2020-06-05 16:47:37 +0800100 python3, \
Matt Spinlerf8510922019-08-08 13:21:24 -0500101 "
102
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -0500103# Enable install_scripts during native and native SDK build
104PACKAGECONFIG_add_class-native = "install_scripts"
105PACKAGECONFIG_add_class-nativesdk = "install_scripts"
106
107# Disable install_scripts during target build
108PACKAGECONFIG_remove_class-target = "install_scripts"
109
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -0500110EXTRA_OECONF = " \
Patrick Williamsadd93832020-06-10 06:52:05 -0500111 YAML_DIR=${STAGING_DIR_TARGET}${yaml_dir} \
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -0500112 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
113 "
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -0500114
115BBCLASSEXTEND += "native nativesdk"