blob: f8f5a4a3dfd3c6d6879ab45e23457addb7bff560 [file] [log] [blame]
Brad Bishop37653df2017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
Patrick Venture5bce7d72018-10-21 08:22:43 -07006PV = "1.0+git${SRCPV}"
Brad Bishop75f03872018-11-03 09:41:57 -07007LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05009
10inherit autotools pkgconfig
11inherit pythonnative
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050012inherit obmc-phosphor-dbus-service
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050013inherit phosphor-logging
Marri Devender Raobf369d02017-06-06 08:39:39 -050014inherit phosphor-dbus-yaml
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050015
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050016DEPENDS += "autoconf-archive-native"
17DEPENDS += "systemd"
18DEPENDS += "python-mako-native"
19DEPENDS += "python-pyyaml-native"
Patrick Williams845123d2016-12-09 08:56:38 -060020DEPENDS += "sdbusplus sdbusplus-native"
Deepak Kodihalli0ac54522017-03-23 03:52:28 -050021DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050022DEPENDS += "virtual/phosphor-logging-callouts"
Marri Devender Rao3b1e30e2017-05-14 09:01:35 -050023DEPENDS += "phosphor-logging-error-logs-native"
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050024DEPENDS += "phosphor-logging-native"
Brad Bishop17c08bf2018-10-18 17:07:53 -040025DEPENDS += "libcereal"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050026
Michael Tritz026fbaf2017-03-13 14:54:24 -050027PACKAGE_BEFORE_PN = "${PN}-test"
28FILES_${PN}-test = "${bindir}/*-test"
29
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050030PACKAGE_BEFORE_PN += "${PN}-elog"
31FILES_${PN}-elog += "${elog_dir}"
32
Deepak Kodihalli64464772018-08-24 08:05:14 -050033# Package configuration
34LOGGING_PACKAGES = " \
35 ${PN}-base \
Deepak Kodihalli04aa22f2018-08-28 11:39:41 -050036 phosphor-rsyslog-config \
Deepak Kodihalli64464772018-08-24 08:05:14 -050037"
38
39ALLOW_EMPTY_${PN} = "1"
40PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
41SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
42DBUS_PACKAGES = "${LOGGING_PACKAGES}"
43
Deepak Kodihalli64464772018-08-24 08:05:14 -050044FILES_${PN}-base += " \
Patrick Venturecb51ccb2019-04-04 14:49:25 -070045 ${bindir}/phosphor-log-manager \
Deepak Kodihalli64464772018-08-24 08:05:14 -050046 ${libdir}/libphosphor_logging.so.* \
47"
48DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service"
49
Deepak Kodihalli04aa22f2018-08-28 11:39:41 -050050DBUS_SERVICE_phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"
51FILES_phosphor-rsyslog-config += " \
Patrick Venturecb51ccb2019-04-04 14:49:25 -070052 ${bindir}/phosphor-rsyslog-conf \
Deepak Kodihalli04aa22f2018-08-28 11:39:41 -050053"
54
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050055SRC_URI += "git://github.com/openbmc/phosphor-logging"
Patrick Venturecb51ccb2019-04-04 14:49:25 -070056SRCREV = "e731044c79968eb867368ef9064c34c98c50872f"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050057
58S = "${WORKDIR}/git"
59
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050060# Do not DEPEND on the specified packages for native build
61# as they will not be available in host machine
Brad Bishop096e4b42018-01-27 00:27:21 -050062DEPENDS_remove_class-native = " \
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050063 virtual/phosphor-logging-callouts \
Brad Bishop096e4b42018-01-27 00:27:21 -050064 sdbus++ \
65 systemd \
Brad Bishop17c08bf2018-10-18 17:07:53 -040066 libcereal \
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050067 "
68
69# Do not DEPEND on the specified packages for native SDK build
70# as they will not be available in host machine
71DEPENDS_remove_class-nativesdk = " \
72 virtual/phosphor-logging-callouts \
73 sdbus++-native \
Brad Bishop17c08bf2018-10-18 17:07:53 -040074 libcereal \
Brad Bishop096e4b42018-01-27 00:27:21 -050075 systemd \
76 phosphor-dbus-interfaces \
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050077 "
78
79PACKAGECONFIG ??= "metadata-processing install_scripts"
80
Deepak Kodihalli430a5062017-03-28 07:47:51 -050081PACKAGECONFIG[metadata-processing] = " \
82 --enable-metadata-processing, \
83 --disable-metadata-processing, , \
84 "
85
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050086# Provide a means to enable/disable install_scripts feature
87PACKAGECONFIG[install_scripts] = " \
88 --enable-install_scripts, \
89 --disable-install_scripts, ,\
90 "
91
92# Enable install_scripts during native and native SDK build
93PACKAGECONFIG_add_class-native = "install_scripts"
94PACKAGECONFIG_add_class-nativesdk = "install_scripts"
95
96# Disable install_scripts during target build
97PACKAGECONFIG_remove_class-target = "install_scripts"
98
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050099EXTRA_OECONF = " \
100 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
101 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
102 "
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -0500103
104BBCLASSEXTEND += "native nativesdk"