blob: 43de9d4d767a889d1e986bc4fc17f1589d67372c [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Copyright (C) 2013 Intel Corporation
2#
3# Released under the MIT license (see COPYING.MIT)
4
Brad Bishopf86d0552018-12-04 14:18:15 -08005inherit metadata_scm
Andrew Geisslerc9f78652020-09-18 14:11:35 -05006inherit image-artifact-names
7
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008# testimage.bbclass enables testing of qemu images using python unittests.
9# Most of the tests are commands run on target image over ssh.
10# To use it add testimage to global inherit and call your target image with -c testimage
11# You can try it out like this:
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012# - first add IMAGE_CLASSES += "testimage" in local.conf
13# - build a qemu core-image-sato
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014# - then bitbake core-image-sato -c testimage. That will run a standard suite of tests.
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015#
16# The tests can be run automatically each time an image is built if you set
17# TESTIMAGE_AUTO = "1"
18
19TESTIMAGE_AUTO ??= "0"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020
21# You can set (or append to) TEST_SUITES in local.conf to select the tests
22# which you want to run for your target.
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023# The test names are the module names in meta/lib/oeqa/runtime/cases.
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024# Each name in TEST_SUITES represents a required test for the image. (no skipping allowed)
25# Appending "auto" means that it will try to run all tests that are suitable for the image (each test decides that on it's own).
26# Note that order in TEST_SUITES is relevant: tests are run in an order such that
27# tests mentioned in @skipUnlessPassed run before the tests that depend on them,
28# but without such dependencies, tests run in the order in which they are listed
29# in TEST_SUITES.
30#
31# A layer can add its own tests in lib/oeqa/runtime, provided it extends BBPATH as normal in its layer.conf.
32
33# TEST_LOG_DIR contains a command ssh log and may contain infromation about what command is running, output and return codes and for qemu a boot log till login.
34# Booting is handled by this class, and it's not a test in itself.
35# TEST_QEMUBOOT_TIMEOUT can be used to set the maximum time in seconds the launch code will wait for the login prompt.
Andrew Geissler82c905d2020-04-13 13:39:40 -050036# TEST_OVERALL_TIMEOUT can be used to set the maximum time in seconds the tests will be allowed to run (defaults to no limit).
Brad Bishop977dc1a2019-02-06 16:01:43 -050037# TEST_QEMUPARAMS can be used to pass extra parameters to qemu, e.g. "-m 1024" for setting the amount of ram to 1 GB.
Brad Bishop19323692019-04-05 15:28:33 -040038# TEST_RUNQEMUPARAMS can be used to pass extra parameters to runqemu, e.g. "gl" to enable OpenGL acceleration.
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039
Andrew Geissler82c905d2020-04-13 13:39:40 -050040# TESTIMAGE_BOOT_PATTERNS can be used to override certain patterns used to communicate with the target when booting,
41# if a pattern is not specifically present on this variable a default will be used when booting the target.
42# TESTIMAGE_BOOT_PATTERNS[<flag>] overrides the pattern used for that specific flag, where flag comes from a list of accepted flags
43# e.g. normally the system boots and waits for a login prompt (login:), after that it sends the command: "root\n" to log as the root user
44# if we wanted to log in as the hypothetical "webserver" user for example we could set the following:
45# TESTIMAGE_BOOT_PATTERNS = "send_login_user search_login_succeeded"
46# TESTIMAGE_BOOT_PATTERNS[send_login_user] = "webserver\n"
47# TESTIMAGE_BOOT_PATTERNS[search_login_succeeded] = "webserver@[a-zA-Z0-9\-]+:~#"
48# The accepted flags are the following: search_reached_prompt, send_login_user, search_login_succeeded, search_cmd_finished.
49# They are prefixed with either search/send, to differentiate if the pattern is meant to be sent or searched to/from the target terminal
50
Patrick Williamsc124f4f2015-09-15 14:41:29 -050051TEST_LOG_DIR ?= "${WORKDIR}/testimage"
52
53TEST_EXPORT_DIR ?= "${TMPDIR}/testimage/${PN}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060054TEST_INSTALL_TMP_DIR ?= "${WORKDIR}/testimage/install_tmp"
55TEST_NEEDED_PACKAGES_DIR ?= "${WORKDIR}/testimage/packages"
56TEST_EXTRACTED_DIR ?= "${TEST_NEEDED_PACKAGES_DIR}/extracted"
57TEST_PACKAGED_DIR ?= "${TEST_NEEDED_PACKAGES_DIR}/packaged"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050058
Brad Bishop977dc1a2019-02-06 16:01:43 -050059BASICTESTSUITE = "\
60 ping date df ssh scp python perl gi ptest parselogs \
61 logrotate connman systemd oe_syslog pam stap ldd xorg \
62 kernelmodule gcc buildcpio buildlzip buildgalculator \
Andrew Geissler82c905d2020-04-13 13:39:40 -050063 dnf rpm opkg apt weston"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050064
Brad Bishop977dc1a2019-02-06 16:01:43 -050065DEFAULT_TEST_SUITES = "${BASICTESTSUITE}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050066
67# aarch64 has no graphics
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050068DEFAULT_TEST_SUITES_remove_aarch64 = "xorg"
Brad Bishop316dfdd2018-06-25 12:45:53 -040069# musl doesn't support systemtap
70DEFAULT_TEST_SUITES_remove_libc-musl = "stap"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050071
Patrick Williamsc0f7c042017-02-23 20:41:17 -060072# qemumips is quite slow and has reached the timeout limit several times on the YP build cluster,
73# mitigate this by removing build tests for qemumips machines.
Brad Bishopd7bf8c12018-02-25 22:55:05 -050074MIPSREMOVE ??= "buildcpio buildlzip buildgalculator"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060075DEFAULT_TEST_SUITES_remove_qemumips = "${MIPSREMOVE}"
76DEFAULT_TEST_SUITES_remove_qemumips64 = "${MIPSREMOVE}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050077
78TEST_SUITES ?= "${DEFAULT_TEST_SUITES}"
79
80TEST_QEMUBOOT_TIMEOUT ?= "1000"
Andrew Geissler82c905d2020-04-13 13:39:40 -050081TEST_OVERALL_TIMEOUT ?= ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050082TEST_TARGET ?= "qemu"
Brad Bishop977dc1a2019-02-06 16:01:43 -050083TEST_QEMUPARAMS ?= ""
Brad Bishop19323692019-04-05 15:28:33 -040084TEST_RUNQEMUPARAMS ?= ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050085
Andrew Geissler82c905d2020-04-13 13:39:40 -050086TESTIMAGE_BOOT_PATTERNS ?= ""
87
Patrick Williamsc124f4f2015-09-15 14:41:29 -050088TESTIMAGEDEPENDS = ""
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080089TESTIMAGEDEPENDS_append_qemuall = " qemu-native:do_populate_sysroot qemu-helper-native:do_populate_sysroot qemu-helper-native:do_addto_recipe_sysroot"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060090TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'cpio-native:do_populate_sysroot', '', d)}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050091TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'dnf-native:do_populate_sysroot', '', d)}"
Brad Bishop977dc1a2019-02-06 16:01:43 -050092TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'rpm', 'createrepo-c-native:do_populate_sysroot', '', d)}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080093TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'ipk', 'opkg-utils-native:do_populate_sysroot package-index:do_package_index', '', d)}"
94TESTIMAGEDEPENDS += "${@bb.utils.contains('IMAGE_PKGTYPE', 'deb', 'apt-native:do_populate_sysroot package-index:do_package_index', '', d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050095
96TESTIMAGELOCK = "${TMPDIR}/testimage.lock"
97TESTIMAGELOCK_qemuall = ""
98
Brad Bishop977dc1a2019-02-06 16:01:43 -050099TESTIMAGE_DUMP_DIR ?= "${LOG_DIR}/runtime-hostdump/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500100
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500101TESTIMAGE_UPDATE_VARS ?= "DL_DIR WORKDIR DEPLOY_DIR"
102
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500103testimage_dump_target () {
104 top -bn1
105 ps
106 free
107 df
108 # The next command will export the default gateway IP
109 export DEFAULT_GATEWAY=$(ip route | awk '/default/ { print $3}')
110 ping -c3 $DEFAULT_GATEWAY
111 dmesg
112 netstat -an
113 ip address
114 # Next command will dump logs from /var/log/
115 find /var/log/ -type f 2>/dev/null -exec echo "====================" \; -exec echo {} \; -exec echo "====================" \; -exec cat {} \; -exec echo "" \;
116}
117
118testimage_dump_host () {
119 top -bn1
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500120 iostat -x -z -N -d -p ALL 20 2
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500121 ps -ef
122 free
123 df
124 memstat
125 dmesg
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500126 ip -s link
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500127 netstat -an
128}
129
Andrew Geisslerc926e172021-05-07 16:11:35 -0500130testimage_dump_monitor () {
131 query-status
132 query-block
133}
134
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500135python do_testimage() {
136 testimage_main(d)
137}
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600138
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500139addtask testimage
140do_testimage[nostamp] = "1"
141do_testimage[depends] += "${TESTIMAGEDEPENDS}"
142do_testimage[lockfiles] += "${TESTIMAGELOCK}"
143
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500144def testimage_sanity(d):
145 if (d.getVar('TEST_TARGET') == 'simpleremote'
146 and (not d.getVar('TEST_TARGET_IP')
147 or not d.getVar('TEST_SERVER_IP'))):
148 bb.fatal('When TEST_TARGET is set to "simpleremote" '
149 'TEST_TARGET_IP and TEST_SERVER_IP are needed too.')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500150
Brad Bishopf86d0552018-12-04 14:18:15 -0800151def get_testimage_configuration(d, test_type, machine):
152 import platform
153 from oeqa.utils.metadata import get_layers
154 configuration = {'TEST_TYPE': test_type,
155 'MACHINE': machine,
156 'DISTRO': d.getVar("DISTRO"),
157 'IMAGE_BASENAME': d.getVar("IMAGE_BASENAME"),
158 'IMAGE_PKGTYPE': d.getVar("IMAGE_PKGTYPE"),
159 'STARTTIME': d.getVar("DATETIME"),
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800160 'HOST_DISTRO': oe.lsb.distro_identifier().replace(' ', '-'),
Brad Bishopf86d0552018-12-04 14:18:15 -0800161 'LAYERS': get_layers(d.getVar("BBLAYERS"))}
162 return configuration
163get_testimage_configuration[vardepsexclude] = "DATETIME"
164
165def get_testimage_json_result_dir(d):
166 json_result_dir = os.path.join(d.getVar("LOG_DIR"), 'oeqa')
167 custom_json_result_dir = d.getVar("OEQA_JSON_RESULT_DIR")
168 if custom_json_result_dir:
169 json_result_dir = custom_json_result_dir
170 return json_result_dir
171
172def get_testimage_result_id(configuration):
173 return '%s_%s_%s_%s' % (configuration['TEST_TYPE'], configuration['IMAGE_BASENAME'], configuration['MACHINE'], configuration['STARTTIME'])
174
Andrew Geissler82c905d2020-04-13 13:39:40 -0500175def get_testimage_boot_patterns(d):
176 from collections import defaultdict
177 boot_patterns = defaultdict(str)
178 # Only accept certain values
179 accepted_patterns = ['search_reached_prompt', 'send_login_user', 'search_login_succeeded', 'search_cmd_finished']
180 # Not all patterns need to be overriden, e.g. perhaps we only want to change the user
181 boot_patterns_flags = d.getVarFlags('TESTIMAGE_BOOT_PATTERNS') or {}
182 if boot_patterns_flags:
183 patterns_set = [p for p in boot_patterns_flags.items() if p[0] in d.getVar('TESTIMAGE_BOOT_PATTERNS').split()]
184 for flag, flagval in patterns_set:
185 if flag not in accepted_patterns:
186 bb.fatal('Testimage: The only accepted boot patterns are: search_reached_prompt,send_login_user, \
187 search_login_succeeded,search_cmd_finished\n Make sure your TESTIMAGE_BOOT_PATTERNS=%s \
188 contains an accepted flag.' % d.getVar('TESTIMAGE_BOOT_PATTERNS'))
189 return
190 # We know boot prompt is searched through in binary format, others might be expressions
191 if flag == 'search_reached_prompt':
192 boot_patterns[flag] = flagval.encode()
193 else:
194 boot_patterns[flag] = flagval.encode().decode('unicode-escape')
195 return boot_patterns
196
197
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500198def testimage_main(d):
199 import os
200 import json
201 import signal
202 import logging
203
204 from bb.utils import export_proxies
205 from oeqa.core.utils.misc import updateTestData
206 from oeqa.runtime.context import OERuntimeTestContext
207 from oeqa.runtime.context import OERuntimeTestContextExecutor
208 from oeqa.core.target.qemu import supported_fstypes
209 from oeqa.core.utils.test import getSuiteCases
210 from oeqa.utils import make_logger_bitbake_compatible
211
212 def sigterm_exception(signum, stackframe):
213 """
214 Catch SIGTERM from worker in order to stop qemu.
215 """
Andrew Geissler82c905d2020-04-13 13:39:40 -0500216 os.kill(os.getpid(), signal.SIGINT)
217
218 def handle_test_timeout(timeout):
219 bb.warn("Global test timeout reached (%s seconds), stopping the tests." %(timeout))
220 os.kill(os.getpid(), signal.SIGINT)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500221
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700222 testimage_sanity(d)
223
224 if (d.getVar('IMAGE_PKGTYPE') == 'rpm'
225 and ('dnf' in d.getVar('TEST_SUITES') or 'auto' in d.getVar('TEST_SUITES'))):
226 create_rpm_index(d)
227
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500228 logger = make_logger_bitbake_compatible(logging.getLogger("BitBake"))
229 pn = d.getVar("PN")
230
231 bb.utils.mkdirhier(d.getVar("TEST_LOG_DIR"))
232
233 image_name = ("%s/%s" % (d.getVar('DEPLOY_DIR_IMAGE'),
234 d.getVar('IMAGE_LINK_NAME')))
235
236 tdname = "%s.testdata.json" % image_name
237 try:
238 td = json.load(open(tdname, "r"))
239 except (FileNotFoundError) as err:
240 bb.fatal('File %s Not Found. Have you built the image with INHERIT+="testimage" in the conf/local.conf?' % tdname)
241
242 # Some variables need to be updates (mostly paths) with the
243 # ones of the current environment because some tests require them.
244 updateTestData(d, td, d.getVar('TESTIMAGE_UPDATE_VARS').split())
245
246 image_manifest = "%s.manifest" % image_name
247 image_packages = OERuntimeTestContextExecutor.readPackagesManifest(image_manifest)
248
249 extract_dir = d.getVar("TEST_EXTRACTED_DIR")
250
251 # Get machine
252 machine = d.getVar("MACHINE")
253
254 # Get rootfs
Brad Bishop977dc1a2019-02-06 16:01:43 -0500255 fstypes = d.getVar('IMAGE_FSTYPES').split()
256 if d.getVar("TEST_TARGET") == "qemu":
257 fstypes = [fs for fs in fstypes if fs in supported_fstypes]
258 if not fstypes:
Andrew Geissler82c905d2020-04-13 13:39:40 -0500259 bb.fatal('Unsupported image type built. Add a compatible image to '
Brad Bishop977dc1a2019-02-06 16:01:43 -0500260 'IMAGE_FSTYPES. Supported types: %s' %
261 ', '.join(supported_fstypes))
Brad Bishop15ae2502019-06-18 21:44:24 -0400262 qfstype = fstypes[0]
263 qdeffstype = d.getVar("QB_DEFAULT_FSTYPE")
264 if qdeffstype:
265 qfstype = qdeffstype
266 rootfs = '%s.%s' % (image_name, qfstype)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500267
268 # Get tmpdir (not really used, just for compatibility)
269 tmpdir = d.getVar("TMPDIR")
270
271 # Get deploy_dir_image (not really used, just for compatibility)
272 dir_image = d.getVar("DEPLOY_DIR_IMAGE")
273
274 # Get bootlog
275 bootlog = os.path.join(d.getVar("TEST_LOG_DIR"),
276 'qemu_boot_log.%s' % d.getVar('DATETIME'))
277
278 # Get display
279 display = d.getVar("BB_ORIGENV").getVar("DISPLAY")
280
281 # Get kernel
282 kernel_name = ('%s-%s.bin' % (d.getVar("KERNEL_IMAGETYPE"), machine))
283 kernel = os.path.join(d.getVar("DEPLOY_DIR_IMAGE"), kernel_name)
284
285 # Get boottime
286 boottime = int(d.getVar("TEST_QEMUBOOT_TIMEOUT"))
287
288 # Get use_kvm
Brad Bishop977dc1a2019-02-06 16:01:43 -0500289 kvm = oe.types.qemu_use_kvm(d.getVar('QEMU_USE_KVM'), d.getVar('TARGET_ARCH'))
290
Andrew Geissler82c905d2020-04-13 13:39:40 -0500291 # Get OVMF
292 ovmf = d.getVar("QEMU_USE_OVMF")
293
Brad Bishop977dc1a2019-02-06 16:01:43 -0500294 slirp = False
295 if d.getVar("QEMU_USE_SLIRP"):
296 slirp = True
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500297
Andrew Geissler82c905d2020-04-13 13:39:40 -0500298 # TODO: We use the current implementation of qemu runner because of
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500299 # time constrains, qemu runner really needs a refactor too.
300 target_kwargs = { 'machine' : machine,
301 'rootfs' : rootfs,
302 'tmpdir' : tmpdir,
303 'dir_image' : dir_image,
304 'display' : display,
305 'kernel' : kernel,
306 'boottime' : boottime,
307 'bootlog' : bootlog,
308 'kvm' : kvm,
Brad Bishop977dc1a2019-02-06 16:01:43 -0500309 'slirp' : slirp,
310 'dump_dir' : d.getVar("TESTIMAGE_DUMP_DIR"),
Andrew Geissler82c905d2020-04-13 13:39:40 -0500311 'serial_ports': len(d.getVar("SERIAL_CONSOLES").split()),
312 'ovmf' : ovmf,
Andrew Geissler3b8a17c2021-04-15 15:55:55 -0500313 'tmpfsdir' : d.getVar("RUNQEMU_TMPFS_DIR"),
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500314 }
315
Andrew Geissler82c905d2020-04-13 13:39:40 -0500316 if d.getVar("TESTIMAGE_BOOT_PATTERNS"):
317 target_kwargs['boot_patterns'] = get_testimage_boot_patterns(d)
318
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500319 # TODO: Currently BBPATH is needed for custom loading of targets.
320 # It would be better to find these modules using instrospection.
321 target_kwargs['target_modules_path'] = d.getVar('BBPATH')
322
Brad Bishop64c979e2019-11-04 13:55:29 -0500323 # hardware controlled targets might need further access
324 target_kwargs['powercontrol_cmd'] = d.getVar("TEST_POWERCONTROL_CMD") or None
325 target_kwargs['powercontrol_extra_args'] = d.getVar("TEST_POWERCONTROL_EXTRA_ARGS") or ""
326 target_kwargs['serialcontrol_cmd'] = d.getVar("TEST_SERIALCONTROL_CMD") or None
327 target_kwargs['serialcontrol_extra_args'] = d.getVar("TEST_SERIALCONTROL_EXTRA_ARGS") or ""
Andrew Geisslerc926e172021-05-07 16:11:35 -0500328 target_kwargs['testimage_dump_monitor'] = d.getVar("testimage_dump_monitor") or ""
Andrew Geisslerc3d88e42020-10-02 09:45:00 -0500329 target_kwargs['testimage_dump_target'] = d.getVar("testimage_dump_target") or ""
Brad Bishop64c979e2019-11-04 13:55:29 -0500330
331 def export_ssh_agent(d):
332 import os
333
334 variables = ['SSH_AGENT_PID', 'SSH_AUTH_SOCK']
335 for v in variables:
336 if v not in os.environ.keys():
337 val = d.getVar(v)
338 if val is not None:
339 os.environ[v] = val
340
341 export_ssh_agent(d)
342
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500343 # runtime use network for download projects for build
344 export_proxies(d)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500345
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500346 # we need the host dumper in test context
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500347 host_dumper = OERuntimeTestContextExecutor.getHostDumper(
348 d.getVar("testimage_dump_host"),
349 d.getVar("TESTIMAGE_DUMP_DIR"))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500350
351 # the robot dance
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500352 target = OERuntimeTestContextExecutor.getTarget(
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500353 d.getVar("TEST_TARGET"), logger, d.getVar("TEST_TARGET_IP"),
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500354 d.getVar("TEST_SERVER_IP"), **target_kwargs)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500355
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500356 # test context
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500357 tc = OERuntimeTestContext(td, logger, target, host_dumper,
358 image_packages, extract_dir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500359
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500360 # Load tests before starting the target
361 test_paths = get_runtime_paths(d)
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500362 test_modules = d.getVar('TEST_SUITES').split()
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700363 if not test_modules:
364 bb.fatal('Empty test suite, please verify TEST_SUITES variable')
365
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500366 tc.loadTests(test_paths, modules=test_modules)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500367
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700368 suitecases = getSuiteCases(tc.suites)
369 if not suitecases:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500370 bb.fatal('Empty test suite, please verify TEST_SUITES variable')
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700371 else:
372 bb.debug(2, 'test suites:\n\t%s' % '\n\t'.join([str(c) for c in suitecases]))
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500373
374 package_extraction(d, tc.suites)
375
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500376 results = None
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600377 complete = False
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500378 orig_sigterm_handler = signal.signal(signal.SIGTERM, sigterm_exception)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600379 try:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500380 # We need to check if runqemu ends unexpectedly
381 # or if the worker send us a SIGTERM
Brad Bishop19323692019-04-05 15:28:33 -0400382 tc.target.start(params=d.getVar("TEST_QEMUPARAMS"), runqemuparams=d.getVar("TEST_RUNQEMUPARAMS"))
Andrew Geissler82c905d2020-04-13 13:39:40 -0500383 import threading
384 try:
385 threading.Timer(int(d.getVar("TEST_OVERALL_TIMEOUT")), handle_test_timeout, (int(d.getVar("TEST_OVERALL_TIMEOUT")),)).start()
386 except ValueError:
387 pass
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500388 results = tc.runTests()
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600389 complete = True
Andrew Geissler82c905d2020-04-13 13:39:40 -0500390 except (KeyboardInterrupt, BlockingIOError) as err:
391 if isinstance(err, KeyboardInterrupt):
392 bb.error('testimage interrupted, shutting down...')
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600393 else:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500394 bb.error('runqemu failed, shutting down...')
395 if results:
396 results.stop()
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600397 results = tc.results
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600398 finally:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500399 signal.signal(signal.SIGTERM, orig_sigterm_handler)
400 tc.target.stop()
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600401
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500402 # Show results (if we have them)
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600403 if results:
404 configuration = get_testimage_configuration(d, 'runtime', machine)
405 results.logDetails(get_testimage_json_result_dir(d),
406 configuration,
407 get_testimage_result_id(configuration),
408 dump_streams=d.getVar('TESTREPORT_FULLLOGS'))
409 results.logSummary(pn)
410 if not results or not complete:
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500411 bb.fatal('%s - FAILED - tests were interrupted during execution' % pn, forcelog=True)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500412 if not results.wasSuccessful():
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500413 bb.fatal('%s - FAILED - check the task log and the ssh log' % pn, forcelog=True)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600414
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500415def get_runtime_paths(d):
416 """
417 Returns a list of paths where runtime test must reside.
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500418
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500419 Runtime tests are expected in <LAYER_DIR>/lib/oeqa/runtime/cases/
420 """
421 paths = []
422
423 for layer in d.getVar('BBLAYERS').split():
424 path = os.path.join(layer, 'lib/oeqa/runtime/cases')
425 if os.path.isdir(path):
426 paths.append(path)
427 return paths
428
429def create_index(arg):
430 import subprocess
431
432 index_cmd = arg
433 try:
434 bb.note("Executing '%s' ..." % index_cmd)
435 result = subprocess.check_output(index_cmd,
436 stderr=subprocess.STDOUT,
437 shell=True)
438 result = result.decode('utf-8')
439 except subprocess.CalledProcessError as e:
440 return("Index creation command '%s' failed with return code "
441 '%d:\n%s' % (e.cmd, e.returncode, e.output.decode("utf-8")))
442 if result:
443 bb.note(result)
444 return None
445
446def create_rpm_index(d):
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800447 import glob
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500448 # Index RPMs
449 rpm_createrepo = bb.utils.which(os.getenv('PATH'), "createrepo_c")
450 index_cmds = []
451 archs = (d.getVar('ALL_MULTILIB_PACKAGE_ARCHS') or '').replace('-', '_')
452
453 for arch in archs.split():
454 rpm_dir = os.path.join(d.getVar('DEPLOY_DIR_RPM'), arch)
455 idx_path = os.path.join(d.getVar('WORKDIR'), 'oe-testimage-repo', arch)
456
457 if not os.path.isdir(rpm_dir):
458 continue
459
460 lockfilename = os.path.join(d.getVar('DEPLOY_DIR_RPM'), 'rpm.lock')
461 lf = bb.utils.lockfile(lockfilename, False)
462 oe.path.copyhardlinktree(rpm_dir, idx_path)
463 # Full indexes overload a 256MB image so reduce the number of rpms
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800464 # in the feed by filtering to specific packages needed by the tests.
465 package_list = glob.glob(idx_path + "*/*.rpm")
466
467 for pkg in package_list:
468 if not os.path.basename(pkg).startswith(("rpm", "run-postinsts", "busybox", "bash", "update-alternatives", "libc6", "curl", "musl")):
469 bb.utils.remove(pkg)
470
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500471 bb.utils.unlockfile(lf)
472 cmd = '%s --update -q %s' % (rpm_createrepo, idx_path)
473
474 # Create repodata
475 result = create_index(cmd)
476 if result:
477 bb.fatal('%s' % ('\n'.join(result)))
478
479def package_extraction(d, test_suites):
480 from oeqa.utils.package_manager import find_packages_to_extract
481 from oeqa.utils.package_manager import extract_packages
482
483 bb.utils.remove(d.getVar("TEST_NEEDED_PACKAGES_DIR"), recurse=True)
484 packages = find_packages_to_extract(test_suites)
485 if packages:
486 bb.utils.mkdirhier(d.getVar("TEST_INSTALL_TMP_DIR"))
487 bb.utils.mkdirhier(d.getVar("TEST_PACKAGED_DIR"))
488 bb.utils.mkdirhier(d.getVar("TEST_EXTRACTED_DIR"))
489 extract_packages(d, packages)
490
491testimage_main[vardepsexclude] += "BB_ORIGENV DATETIME"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500492
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800493python () {
494 if oe.types.boolean(d.getVar("TESTIMAGE_AUTO") or "False"):
495 bb.build.addtask("testimage", "do_build", "do_image_complete", d)
496}
497
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500498inherit testsdk