blob: 8497916d482bd76b033f70529f91c923cb6bc369 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001# The WICVARS variable is used to define list of bitbake variables used in wic code
2# variables from this list is written to <image>.env file
3WICVARS ?= "\
Andrew Geissler5199d832021-09-24 16:47:35 -05004 APPEND \
5 ASSUME_PROVIDED \
6 BBLAYERS \
7 DEPLOY_DIR_IMAGE \
8 FAKEROOTCMD \
9 HOSTTOOLS_DIR \
10 IMAGE_BASENAME \
11 IMAGE_BOOT_FILES \
12 IMAGE_EFI_BOOT_FILES \
13 IMAGE_LINK_NAME \
14 IMAGE_ROOTFS \
15 IMGDEPLOYDIR \
16 INITRAMFS_FSTYPES \
17 INITRAMFS_IMAGE \
18 INITRAMFS_IMAGE_BUNDLE \
19 INITRAMFS_LINK_NAME \
20 INITRD \
21 INITRD_LIVE \
22 ISODIR \
23 KERNEL_IMAGETYPE \
24 MACHINE \
25 PSEUDO_IGNORE_PATHS \
26 RECIPE_SYSROOT_NATIVE \
27 ROOTFS_SIZE \
28 STAGING_DATADIR \
29 STAGING_DIR \
Patrick Williams93c203f2021-10-06 16:15:23 -050030 STAGING_DIR_HOST \
Andrew Geissler5199d832021-09-24 16:47:35 -050031 STAGING_LIBDIR \
32 TARGET_SYS \
33"
Brad Bishop96ff1982019-08-19 13:50:42 -040034
35inherit ${@bb.utils.contains('INITRAMFS_IMAGE_BUNDLE', '1', 'kernel-artifact-names', '', d)}
Brad Bishop6e60e8b2018-02-01 10:27:11 -050036
37WKS_FILE ??= "${IMAGE_BASENAME}.${MACHINE}.wks"
38WKS_FILES ?= "${WKS_FILE} ${IMAGE_BASENAME}.wks"
39WKS_SEARCH_PATH ?= "${THISDIR}:${@':'.join('%s/wic' % p for p in '${BBPATH}'.split(':'))}:${@':'.join('%s/scripts/lib/wic/canned-wks' % l for l in '${BBPATH}:${COREBASE}'.split(':'))}"
40WKS_FULL_PATH = "${@wks_search(d.getVar('WKS_FILES').split(), d.getVar('WKS_SEARCH_PATH')) or ''}"
41
42def wks_search(files, search_path):
43 for f in files:
44 if os.path.isabs(f):
45 if os.path.exists(f):
46 return f
47 else:
48 searched = bb.utils.which(search_path, f)
49 if searched:
50 return searched
51
52WIC_CREATE_EXTRA_ARGS ?= ""
53
Patrick Williams213cb262021-08-07 19:21:33 -050054IMAGE_CMD:wic () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050055 out="${IMGDEPLOYDIR}/${IMAGE_NAME}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050056 build_wic="${WORKDIR}/build-wic"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060057 tmp_wic="${WORKDIR}/tmp-wic"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050058 wks="${WKS_FULL_PATH}"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060059 if [ -e "$tmp_wic" ]; then
60 # Ensure we don't have any junk leftover from a previously interrupted
61 # do_image_wic execution
62 rm -rf "$tmp_wic"
63 fi
Brad Bishop6e60e8b2018-02-01 10:27:11 -050064 if [ -z "$wks" ]; then
65 bbfatal "No kickstart files from WKS_FILES were found: ${WKS_FILES}. Please set WKS_FILE or WKS_FILES appropriately."
66 fi
Andrew Geisslerd1e89492021-02-12 15:35:20 -060067 BUILDDIR="${TOPDIR}" PSEUDO_UNLOAD=1 wic create "$wks" --vars "${STAGING_DIR}/${MACHINE}/imgdata/" -e "${IMAGE_BASENAME}" -o "$build_wic/" -w "$tmp_wic" ${WIC_CREATE_EXTRA_ARGS}
Andrew Geissler82c905d2020-04-13 13:39:40 -050068 mv "$build_wic/$(basename "${wks%.wks}")"*.direct "$out${IMAGE_NAME_SUFFIX}.wic"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050069}
Patrick Williams213cb262021-08-07 19:21:33 -050070IMAGE_CMD:wic[vardepsexclude] = "WKS_FULL_PATH WKS_FILES TOPDIR"
Andrew Geissler82c905d2020-04-13 13:39:40 -050071do_image_wic[cleandirs] = "${WORKDIR}/build-wic"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050072
Andrew Geisslerf0343792020-11-18 10:42:21 -060073PSEUDO_IGNORE_PATHS .= ",${WORKDIR}/build-wic"
74
Brad Bishop6e60e8b2018-02-01 10:27:11 -050075# Rebuild when the wks file or vars in WICVARS change
76USING_WIC = "${@bb.utils.contains_any('IMAGE_FSTYPES', 'wic ' + ' '.join('wic.%s' % c for c in '${CONVERSIONTYPES}'.split()), '1', '', d)}"
77WKS_FILE_CHECKSUM = "${@'${WKS_FULL_PATH}:%s' % os.path.exists('${WKS_FULL_PATH}') if '${USING_WIC}' else ''}"
78do_image_wic[file-checksums] += "${WKS_FILE_CHECKSUM}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050079do_image_wic[depends] += "${@' '.join('%s-native:do_populate_sysroot' % r for r in ('parted', 'gptfdisk', 'dosfstools', 'mtools'))}"
80
81# We ensure all artfacts are deployed (e.g virtual/bootloader)
82do_image_wic[recrdeptask] += "do_deploy"
Andrew Geissler82c905d2020-04-13 13:39:40 -050083do_image_wic[deptask] += "do_image_complete"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050084
Brad Bishop08902b02019-08-20 09:16:51 -040085WKS_FILE_DEPENDS_DEFAULT = '${@bb.utils.contains_any("BUILD_ARCH", [ 'x86_64', 'i686' ], "syslinux-native", "",d)}'
Patrick Williams03907ee2022-05-01 06:28:52 -050086WKS_FILE_DEPENDS_DEFAULT += "bmap-tools-native cdrtools-native btrfs-tools-native squashfs-tools-native e2fsprogs-native erofs-utils-native"
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050087# Unified kernel images need objcopy
88WKS_FILE_DEPENDS_DEFAULT += "virtual/${MLPREFIX}${TARGET_PREFIX}binutils"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050089WKS_FILE_DEPENDS_BOOTLOADERS = ""
Patrick Williams93c203f2021-10-06 16:15:23 -050090WKS_FILE_DEPENDS_BOOTLOADERS:x86 = "syslinux grub-efi systemd-boot os-release"
91WKS_FILE_DEPENDS_BOOTLOADERS:x86-64 = "syslinux grub-efi systemd-boot os-release"
Patrick Williams213cb262021-08-07 19:21:33 -050092WKS_FILE_DEPENDS_BOOTLOADERS:x86-x32 = "syslinux grub-efi"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050093
94WKS_FILE_DEPENDS ??= "${WKS_FILE_DEPENDS_DEFAULT} ${WKS_FILE_DEPENDS_BOOTLOADERS}"
95
Brad Bishop6e60e8b2018-02-01 10:27:11 -050096DEPENDS += "${@ '${WKS_FILE_DEPENDS}' if d.getVar('USING_WIC') else '' }"
97
98python do_write_wks_template () {
99 """Write out expanded template contents to WKS_FULL_PATH."""
100 import re
101
102 template_body = d.getVar('_WKS_TEMPLATE')
103
104 # Remove any remnant variable references left behind by the expansion
105 # due to undefined variables
106 expand_var_regexp = re.compile(r"\${[^{}@\n\t :]+}")
107 while True:
108 new_body = re.sub(expand_var_regexp, '', template_body)
109 if new_body == template_body:
110 break
111 else:
112 template_body = new_body
113
114 wks_file = d.getVar('WKS_FULL_PATH')
115 with open(wks_file, 'w') as f:
116 f.write(template_body)
Brad Bishop08902b02019-08-20 09:16:51 -0400117 f.close()
118 # Copy the finalized wks file to the deploy directory for later use
119 depdir = d.getVar('IMGDEPLOYDIR')
120 basename = d.getVar('IMAGE_BASENAME')
121 bb.utils.copyfile(wks_file, "%s/%s" % (depdir, basename + '-' + os.path.basename(wks_file)))
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500122}
123
Andrew Geissler82c905d2020-04-13 13:39:40 -0500124do_flush_pseudodb() {
125 ${FAKEROOTENV} ${FAKEROOTCMD} -S
126}
127
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500128python () {
129 if d.getVar('USING_WIC'):
130 wks_file_u = d.getVar('WKS_FULL_PATH', False)
131 wks_file = d.expand(wks_file_u)
132 base, ext = os.path.splitext(wks_file)
133 if ext == '.in' and os.path.exists(wks_file):
134 wks_out_file = os.path.join(d.getVar('WORKDIR'), os.path.basename(base))
135 d.setVar('WKS_FULL_PATH', wks_out_file)
136 d.setVar('WKS_TEMPLATE_PATH', wks_file_u)
137 d.setVar('WKS_FILE_CHECKSUM', '${WKS_TEMPLATE_PATH}:True')
138
139 # We need to re-parse each time the file changes, and bitbake
140 # needs to be told about that explicitly.
141 bb.parse.mark_dependency(d, wks_file)
142
143 try:
144 with open(wks_file, 'r') as f:
145 body = f.read()
146 except (IOError, OSError) as exc:
147 pass
148 else:
149 # Previously, I used expandWithRefs to get the dependency list
150 # and add it to WICVARS, but there's no point re-parsing the
151 # file in process_wks_template as well, so just put it in
152 # a variable and let the metadata deal with the deps.
153 d.setVar('_WKS_TEMPLATE', body)
Brad Bishop08902b02019-08-20 09:16:51 -0400154 bb.build.addtask('do_write_wks_template', 'do_image_wic', 'do_image', d)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400155 bb.build.addtask('do_image_wic', 'do_image_complete', None, d)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500156}
157
158#
159# Write environment variables used by wic
160# to tmp/sysroots/<machine>/imgdata/<image>.env
161#
162python do_rootfs_wicenv () {
163 wicvars = d.getVar('WICVARS')
164 if not wicvars:
165 return
166
167 stdir = d.getVar('STAGING_DIR')
168 outdir = os.path.join(stdir, d.getVar('MACHINE'), 'imgdata')
169 bb.utils.mkdirhier(outdir)
170 basename = d.getVar('IMAGE_BASENAME')
171 with open(os.path.join(outdir, basename) + '.env', 'w') as envf:
172 for var in wicvars.split():
173 value = d.getVar(var)
174 if value:
175 envf.write('%s="%s"\n' % (var, value.strip()))
Brad Bishop08902b02019-08-20 09:16:51 -0400176 envf.close()
177 # Copy .env file to deploy directory for later use with stand alone wic
178 depdir = d.getVar('IMGDEPLOYDIR')
179 bb.utils.copyfile(os.path.join(outdir, basename) + '.env', os.path.join(depdir, basename) + '.env')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500180}
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500181addtask do_flush_pseudodb after do_rootfs before do_image do_image_qa
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500182addtask do_rootfs_wicenv after do_image before do_image_wic
183do_rootfs_wicenv[vardeps] += "${WICVARS}"
184do_rootfs_wicenv[prefuncs] = 'set_image_size'