blob: 52af132e08a9c73b77168743abe38fff55b68a9c [file] [log] [blame]
Cyril Burb73580e2017-01-12 18:13:30 +11001SUMMARY = "Phosphor OpenBMC MBOX Daemon"
2DESCRIPTION = "Phosphor OpenBMC MBOX Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
6
7inherit autotools pkgconfig
8inherit obmc-phosphor-systemd
9
10DEPENDS += "autoconf-archive-native"
Andrew Jeffery5ade8402017-04-21 10:18:24 +093011DEPENDS += "systemd"
Andrew Jeffery2c567ba2017-04-18 16:30:10 +093012RDEPENDS_${PN} += "libsystemd"
Cyril Burb73580e2017-01-12 18:13:30 +110013
14S = "${WORKDIR}/git"
15
Adriana Kobylak54c65d62017-06-10 09:47:58 -050016SRC_URI += "git://github.com/openbmc/phosphor-mboxd.git"
Cyril Burb73580e2017-01-12 18:13:30 +110017
18SRC_URI += "file://99-aspeed-mbox.rules"
Andrew Jeffery2a0cb542017-01-25 13:17:13 +103019SRC_URI += "file://99-aspeed-lpc-ctrl.rules"
Cyril Burb73580e2017-01-12 18:13:30 +110020SRC_URI += "file://aspeed-lpc-ctrl-h.patch"
21
Patrick Williams7a186d92017-06-27 15:20:04 -050022SRCREV="99551ef1fec6851af8903acb22b55d741ea2ad17"
Andrew Jeffery2c567ba2017-04-18 16:30:10 +093023
24PROVIDES += "mboxctl"
Cyril Burb73580e2017-01-12 18:13:30 +110025
26MBOXD_FLASH_SIZE ??= "32M"
27SYSTEMD_SUBSTITUTIONS += "FLASH_SIZE:${MBOXD_FLASH_SIZE}:${PN}.service"
28
29# Hacks because ${STAGING_KERNEL_DIR} points to the kernel source tree, not the
30# installed, pre-processed headers. Requires the aspeed-lpc-ctrl-h patch above.
Saqib Khanc8afc6a2017-03-09 10:28:09 -060031CFLAGS_append = " -I include"
Cyril Burb73580e2017-01-12 18:13:30 +110032
33do_install_append() {
34 install -d ${D}/lib/udev/rules.d
35 install -m 0644 ${WORKDIR}/99-aspeed-mbox.rules ${D}/lib/udev/rules.d
Andrew Jeffery2a0cb542017-01-25 13:17:13 +103036 install -m 0644 ${WORKDIR}/99-aspeed-lpc-ctrl.rules ${D}/lib/udev/rules.d
Cyril Burb73580e2017-01-12 18:13:30 +110037}
Matt Spinler9f77d282017-01-20 15:32:07 -060038
39TMPL = "mboxd-reload@.service"
Josh D. Kingb9ee5362017-04-06 14:43:46 -050040TGTFMT = "obmc-chassis-poweroff@{0}.target"
Matt Spinler9f77d282017-01-20 15:32:07 -060041INSTFMT = "mboxd-reload@{0}.service"
42FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
43
44SYSTEMD_SERVICE_${PN} += "mboxd.service"
45SYSTEMD_SERVICE_${PN} += "mboxd-reload@.service"
46SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
Deepak Kodihallidd05b962017-06-29 09:56:24 -050047
48EXTRA_OECONF = " \
49 enable_virtual_pnor=no \
50 "