blob: aa7d422f7ba85a9f84cbdb12790ddd6cca0940cf [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Firmware testsuite"
2DESCRIPTION = "The tool fwts comprises of over fifty tests that are designed to exercise and test different aspects of a machine's firmware. Many of these tests need super user access to read BIOS data and ACPI tables, so the tool requires running with super user privileges (e.g. with sudo)."
3HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
4
5LICENSE = "GPLv2+"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05008SRC_URI = "http://fwts.ubuntu.com/release/fwts-V${PV}.tar.gz;subdir=${BP} \
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009 file://0001-Add-correct-printf-qualifier-for-off_t.patch \
Andrew Geisslere34f8962021-04-15 15:53:51 -050010 file://0002-Include-poll.h-instead-of-deprecated-sys-poll.h.patch \
11 file://0003-Remove-Werror-from-build.patch \
12 file://0004-Define-__SWORD_TYPE-if-not-defined-by-libc.patch \
13 file://0005-Undefine-PAGE_SIZE.patch \
14 file://0006-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015 "
Andrew Geisslere34f8962021-04-15 15:53:51 -050016SRC_URI[sha256sum] = "c22dcba2572e4237bf2fe9ab579e195cf051d3a99b2c07ab58f757cae02d24fb"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050017
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050019
Andrew Geisslere34f8962021-04-15 15:53:51 -050020DEPENDS = "libpcre glib-2.0 dtc bison-native libbsd"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021DEPENDS_append_libc-musl = " libexecinfo"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050022
Andrew Geisslere34f8962021-04-15 15:53:51 -050023# Use brokensep for now (https://github.com/ColinIanKing/fwts/issues/2)
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050024inherit autotools-brokensep bash-completion pkgconfig
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026LDFLAGS_append_libc-musl = " -lexecinfo"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050027
28FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
29FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
30FILES_${PN}-staticdev += "${libdir}/fwts/lib*a"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050031
Andrew Geisslere34f8962021-04-15 15:53:51 -050032RDEPENDS_${PN} += "dtc"