Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Utility for modifying GPT disk partitioning" |
| 2 | DESCRIPTION = "GPT fdisk is a disk partitioning tool loosely modeled on Linux fdisk, but used for modifying GUID Partition Table (GPT) disks. The related FixParts utility fixes some common problems on Master Boot Record (MBR) disks." |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 3 | HOMEPAGE = "https://sourceforge.net/projects/gptfdisk/" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 4 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 5 | LICENSE = "GPL-2.0-only" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" |
| 7 | |
| 8 | DEPENDS = "util-linux" |
| 9 | |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 10 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BP}.tar.gz \ |
| 11 | file://0001-gptcurses-correctly-include-curses.h.patch \ |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 12 | file://0001-Updated-guid.cc-to-deal-with-minor-change-in-libuuid.patch \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 13 | file://0001-Fix-failure-crash-of-sgdisk-when-compiled-with-lates.patch \ |
| 14 | file://0001-Use-64bit-time_t-on-linux-as-well.patch \ |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 15 | file://popt-1.19-follow-up.patch \ |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 16 | " |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 17 | SRC_URI[sha256sum] = "dafead2693faeb8e8b97832b23407f6ed5b3219bc1784f482dd855774e2d50c2" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | |
| 19 | UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/gptfdisk/files/gptfdisk/" |
| 20 | UPSTREAM_CHECK_REGEX = "/gptfdisk/(?P<pver>(\d+[\.\-_]*)+)/" |
| 21 | |
| 22 | EXTRA_OEMAKE = "'CC=${CC}' 'CXX=${CXX}' gdisk fixparts ${PACKAGECONFIG_CONFARGS}" |
| 23 | |
| 24 | PACKAGECONFIG ??= "ncurses popt" |
| 25 | PACKAGECONFIG[ncurses] = "cgdisk,,ncurses" |
| 26 | PACKAGECONFIG[popt] = "sgdisk,,popt" |
| 27 | |
| 28 | do_install() { |
| 29 | install -d ${D}${sbindir} |
| 30 | for f in cgdisk sgdisk; do |
| 31 | if [ -x $f ]; then |
| 32 | install -m 0755 $f ${D}${sbindir} |
| 33 | fi |
| 34 | done |
| 35 | install -m 0755 gdisk ${D}${sbindir} |
| 36 | install -m 0755 fixparts ${D}${sbindir} |
| 37 | } |
| 38 | |
| 39 | BBCLASSEXTEND = "native nativesdk" |