blob: 118c1c2b0eb8dfeebc78f844b21f3b7dc2a0a15b [file] [log] [blame]
Brad Bishopfd327fb2017-01-17 09:21:15 -05001SUMMARY = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
2DESCRIPTION = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
Brad Bishop07ffcce2017-01-17 09:18:39 -05003PR = "r1"
4
5inherit autotools pkgconfig
6inherit obmc-phosphor-license
Tom Josephdf686502017-02-01 19:47:27 +05307inherit obmc-phosphor-ipmiprovider-symlink
Tom Josephb59a41a2017-10-17 22:52:49 +05308inherit pythonnative
9
10require ${PN}.inc
Brad Bishop07ffcce2017-01-17 09:18:39 -050011
Brad Bishop80e7f902017-01-17 10:07:14 -050012DEPENDS += "phosphor-ipmi-host"
Brad Bishop07ffcce2017-01-17 09:18:39 -050013DEPENDS += "autoconf-archive-native"
Patrick Williamscafbae62017-08-17 10:42:32 -050014DEPENDS += "sdbusplus sdbusplus-native"
15DEPENDS += "phosphor-logging"
16DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
17DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
Tom Josephb59a41a2017-10-17 22:52:49 +053018DEPENDS += "sdbus++-native"
Patrick Williamscafbae62017-08-17 10:42:32 -050019
20RDEPENDS_${PN} += " \
21 sdbusplus \
22 phosphor-logging \
23 openpower-dbus-interfaces \
24 phosphor-dbus-interfaces \
25 "
Brad Bishop07ffcce2017-01-17 09:18:39 -050026
27TARGET_CFLAGS += "-fpic"
28
Tom Josephdf686502017-02-01 19:47:27 +053029HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so"
30
Brad Bishop07ffcce2017-01-17 09:18:39 -050031S = "${WORKDIR}/git"
32
Tom Josephdf686502017-02-01 19:47:27 +053033FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Brad Bishop07ffcce2017-01-17 09:18:39 -050034FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Tom Josephdf686502017-02-01 19:47:27 +053035FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"