blob: 6211efa7149adb8e1cd0587dbabf19967e1c5576 [file] [log] [blame]
Brad Bishopfd327fb2017-01-17 09:21:15 -05001SUMMARY = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
2DESCRIPTION = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
Brad Bishop07ffcce2017-01-17 09:18:39 -05003PR = "r1"
4
5inherit autotools pkgconfig
6inherit obmc-phosphor-license
Tom Josephdf686502017-02-01 19:47:27 +05307inherit obmc-phosphor-ipmiprovider-symlink
8inherit obmc-phosphor-utils
Tom Josephb59a41a2017-10-17 22:52:49 +05309inherit pythonnative
10
11require ${PN}.inc
Brad Bishop07ffcce2017-01-17 09:18:39 -050012
Brad Bishop80e7f902017-01-17 10:07:14 -050013DEPENDS += "phosphor-ipmi-host"
Brad Bishop07ffcce2017-01-17 09:18:39 -050014DEPENDS += "autoconf-archive-native"
Patrick Williamscafbae62017-08-17 10:42:32 -050015DEPENDS += "sdbusplus sdbusplus-native"
16DEPENDS += "phosphor-logging"
17DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
18DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
Tom Josephb59a41a2017-10-17 22:52:49 +053019DEPENDS += "sdbus++-native"
Patrick Williamscafbae62017-08-17 10:42:32 -050020
21RDEPENDS_${PN} += " \
22 sdbusplus \
23 phosphor-logging \
24 openpower-dbus-interfaces \
25 phosphor-dbus-interfaces \
26 "
Brad Bishop07ffcce2017-01-17 09:18:39 -050027
28TARGET_CFLAGS += "-fpic"
29
Tom Josephdf686502017-02-01 19:47:27 +053030HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so"
31
Brad Bishop07ffcce2017-01-17 09:18:39 -050032S = "${WORKDIR}/git"
33
Tom Josephdf686502017-02-01 19:47:27 +053034FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Brad Bishop07ffcce2017-01-17 09:18:39 -050035FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Tom Josephdf686502017-02-01 19:47:27 +053036FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"