blob: 711b7e6a359659d25dafe3e11699671ae32112be [file] [log] [blame]
Brad Bishopfd327fb2017-01-17 09:21:15 -05001SUMMARY = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
2DESCRIPTION = "Phosphor IPMI plugin for OpenPOWER OEM Commands"
Brad Bishop07ffcce2017-01-17 09:18:39 -05003PR = "r1"
Patrick Venture53f5e992018-10-02 19:54:00 -07004PV = "1.0+git${SRCPV}"
Patrick Venture530b4942018-11-03 09:01:23 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Brad Bishop07ffcce2017-01-17 09:18:39 -05007
8inherit autotools pkgconfig
Tom Josephdf686502017-02-01 19:47:27 +05309inherit obmc-phosphor-ipmiprovider-symlink
Tom Josephb59a41a2017-10-17 22:52:49 +053010inherit pythonnative
11
12require ${PN}.inc
Brad Bishop07ffcce2017-01-17 09:18:39 -050013
Brad Bishop80e7f902017-01-17 10:07:14 -050014DEPENDS += "phosphor-ipmi-host"
Brad Bishop07ffcce2017-01-17 09:18:39 -050015DEPENDS += "autoconf-archive-native"
Patrick Williamscafbae62017-08-17 10:42:32 -050016DEPENDS += "sdbusplus sdbusplus-native"
17DEPENDS += "phosphor-logging"
18DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
19DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
Tom Josephb59a41a2017-10-17 22:52:49 +053020DEPENDS += "sdbus++-native"
Tom Joseph55b87c22019-01-28 21:41:27 -060021DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
Patrick Williamscafbae62017-08-17 10:42:32 -050022
Brad Bishop07ffcce2017-01-17 09:18:39 -050023TARGET_CFLAGS += "-fpic"
24
Tom Josephdf686502017-02-01 19:47:27 +053025HOSTIPMI_PROVIDER_LIBRARY += "liboemhandler.so"
26
Tom Joseph55b87c22019-01-28 21:41:27 -060027EXTRA_OECONF = " \
28 INVSENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${datadir}/phosphor-ipmi-host/sensor/invsensor.yaml \
29 "
30
Brad Bishop07ffcce2017-01-17 09:18:39 -050031S = "${WORKDIR}/git"
32
Tom Josephdf686502017-02-01 19:47:27 +053033FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Brad Bishop07ffcce2017-01-17 09:18:39 -050034FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Tom Josephdf686502017-02-01 19:47:27 +053035FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"