blob: e080ff6357b0986437aced9bccea6a87785f22d6 [file] [log] [blame]
Brad Bishop667938f2017-01-12 21:44:51 -05001SUMMARY = "OpenBMC - Applications"
Brad Bishop93fb5352015-09-09 03:59:20 +00002PR = "r1"
3
4inherit packagegroup
Brad Bishop93fb5352015-09-09 03:59:20 +00005
Brad Bishop93fb5352015-09-09 03:59:20 +00006PROVIDES = "${PACKAGES}"
7PACKAGES = " \
Brad Bishop46631702017-03-01 16:16:06 -05008 ${PN}-bmc-state-mgmt \
Brad Bishop7463d6d2020-08-10 20:45:15 -04009 ${PN}-bmcweb \
Brad Bishop46631702017-03-01 16:16:06 -050010 ${PN}-chassis-state-mgmt \
Brad Bishop94bf53d2020-08-11 08:20:31 -040011 ${PN}-console \
Brad Bishop7463d6d2020-08-10 20:45:15 -040012 ${PN}-dbus-monitor \
Brad Bishop6165ec32016-09-06 22:44:21 -040013 ${PN}-extras \
Brad Bishop113fe562020-08-10 20:20:47 -040014 ${PN}-devtools \
Brad Bishop11909e02017-05-01 11:54:34 -040015 ${PN}-fan-control \
Brad Bishop4525a9d2020-08-18 19:30:11 -040016 ${PN}-fru-ipmi \
Vijay Khemka67a3c572020-09-08 11:56:19 -070017 ${PN}-health-monitor \
Brad Bishop46631702017-03-01 16:16:06 -050018 ${PN}-host-state-mgmt \
Brad Bishop7463d6d2020-08-10 20:45:15 -040019 ${PN}-ikvm \
Brad Bishop45f8b572017-02-01 21:04:14 -050020 ${PN}-inventory \
21 ${PN}-leds \
Brad Bishop09486912018-03-23 13:07:46 -040022 ${PN}-logging \
Adriana Kobylaka4c5db02018-10-16 11:02:54 -050023 ${PN}-remote-logging \
Brad Bishop94bf53d2020-08-11 08:20:31 -040024 ${PN}-rng \
Brad Bishop45f8b572017-02-01 21:04:14 -050025 ${PN}-sensors \
Gunnar Millsc868f922017-02-15 16:01:45 -060026 ${PN}-software \
Andrew Geisslera94faf42017-05-08 15:58:01 -050027 ${PN}-host-check-mgmt \
Jayanth Othayoth9963d172017-05-08 09:25:05 -050028 ${PN}-debug-collector \
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -050029 ${PN}-settings \
Ratan Guptab6de45c2017-07-06 21:09:14 +053030 ${PN}-network \
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +053031 ${PN}-user-mgmt \
Brad Bishop7463d6d2020-08-10 20:45:15 -040032 ${PN}-user-mgmt-ldap \
Brad Bishop93fb5352015-09-09 03:59:20 +000033 "
34
Brad Bishop46631702017-03-01 16:16:06 -050035SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
36RDEPENDS_${PN}-bmc-state-mgmt = " \
37 ${VIRTUAL-RUNTIME_obmc-bmc-state-manager} \
Andrew Geisslere36b7272019-08-14 10:01:10 -050038 phosphor-state-manager-systemd-target-monitor \
Brad Bishop46631702017-03-01 16:16:06 -050039 "
40
Brad Bishop7463d6d2020-08-10 20:45:15 -040041SUMMARY_${PN}-bmcweb = "bmcweb support"
42RDEPENDS_${PN}-bmcweb = " \
43 bmcweb \
44 phosphor-bmcweb-cert-config \
45 "
46
Brad Bishop46631702017-03-01 16:16:06 -050047SUMMARY_${PN}-chassis-state-mgmt = "Chassis state management"
48RDEPENDS_${PN}-chassis-state-mgmt = " \
49 ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
Anthony Wilson3492fb92019-03-30 08:11:32 -070050 obmc-phosphor-power \
Brad Bishop46631702017-03-01 16:16:06 -050051 "
52
Brad Bishop94bf53d2020-08-11 08:20:31 -040053SUMMARY_${PN}-console = "Serial over LAN support"
54RDEPENDS_${PN}-console = " \
55 obmc-console \
56 "
57
Brad Bishop7463d6d2020-08-10 20:45:15 -040058# Deprecated - add new packages to an existing packagegroup or create a new one.
Brad Bishop6165ec32016-09-06 22:44:21 -040059SUMMARY_${PN}-extras = "Extra features"
Brad Bishop7463d6d2020-08-10 20:45:15 -040060RDEPENDS_${PN}-extras = ""
Brad Bishop70436da2015-09-16 14:49:27 -040061
Brad Bishop113fe562020-08-10 20:20:47 -040062SUMMARY_${PN}-devtools = "Development tools"
63RDEPENDS_${PN}-devtools = " \
64 bash \
Brad Bishop94bf53d2020-08-11 08:20:31 -040065 ffdc \
Brad Bishop113fe562020-08-10 20:20:47 -040066 i2c-tools \
James Feist76d4c462019-05-30 11:58:40 -070067 libgpiod-tools \
Brad Bishop113fe562020-08-10 20:20:47 -040068 lrzsz \
69 rsync \
Adriana Kobylak0bce5322017-11-09 10:39:02 -060070 "
71
Brad Bishop7463d6d2020-08-10 20:45:15 -040072SUMMARY_${PN}-dbus-monitor = "Support for dbus monitoring"
73RDEPENDS_${PN}-dbus-monitor = " \
74 phosphor-dbus-monitor \
75 "
76
Brad Bishop11909e02017-05-01 11:54:34 -040077# Use the fan control package group for applications
78# implementing fan control or system fan policy only.
79# Applications that create inventory or sensors should
80# be added those respective package groups instead.
81SUMMARY_${PN}-fan-control = "Fan control"
82RDEPENDS_${PN}-fan-control = " \
Matt Spinlerbd9fdd92017-04-19 08:23:50 -050083 ${VIRTUAL-RUNTIME_obmc-fan-control} \
Matt Spinler39652c82017-05-01 14:29:20 -050084 phosphor-fan-monitor \
Brad Bishop11909e02017-05-01 11:54:34 -040085 "
86
Brad Bishop4525a9d2020-08-18 19:30:11 -040087SUMMARY_${PN}-fru-ipmi = "Support for EEPROMS with IPMI FRU"
88RDEPENDS_${PN}-fru-ipmi = " \
89 fru-device \
90 "
91
Vijay Khemka67a3c572020-09-08 11:56:19 -070092SUMMARY_${PN}-health-monitor = "Support for health monitoring"
93RDEPENDS_${PN}-health-monitor = " \
94 phosphor-health-monitor \
95 "
96
Brad Bishop46631702017-03-01 16:16:06 -050097SUMMARY_${PN}-host-state-mgmt = "Host state management"
98RDEPENDS_${PN}-host-state-mgmt = " \
99 ${VIRTUAL-RUNTIME_obmc-host-state-manager} \
Michael Tritz1f792e02017-03-31 12:04:32 -0500100 ${VIRTUAL-RUNTIME_obmc-discover-system-state} \
Brad Bishop46631702017-03-01 16:16:06 -0500101 "
102
Brad Bishop7463d6d2020-08-10 20:45:15 -0400103SUMMARY_${PN}-ikvm = "KVM over IP support"
104RDEPENDS_${PN}-ikvm = " \
105 obmc-ikvm \
106 "
107
Brad Bishop45f8b572017-02-01 21:04:14 -0500108SUMMARY_${PN}-inventory = "Inventory applications"
109RDEPENDS_${PN}-inventory = " \
110 ${VIRTUAL-RUNTIME_obmc-inventory-manager} \
Matthew Barth91460422017-02-24 13:14:43 -0600111 ${VIRTUAL-RUNTIME_obmc-fan-presence} \
Brad Bishop45f8b572017-02-01 21:04:14 -0500112 "
113
114SUMMARY_${PN}-leds = "LED applications"
115RDEPENDS_${PN}-leds = " \
Brad Bishopc1d30c52017-02-27 11:59:49 -0500116 ${VIRTUAL-RUNTIME_obmc-leds-manager} \
117 ${VIRTUAL-RUNTIME_obmc-leds-sysfs} \
Dhruvaraj Subhashchandrane1266ad2017-04-27 05:29:56 -0500118 ${VIRTUAL-RUNTIME_obmc-led-monitor} \
Brad Bishop45f8b572017-02-01 21:04:14 -0500119 "
120
Brad Bishop09486912018-03-23 13:07:46 -0400121SUMMARY_${PN}-logging = "Logging applications"
122RDEPENDS_${PN}-logging = " \
123 phosphor-logging \
Adriana Kobylaka4c5db02018-10-16 11:02:54 -0500124 "
125
126SUMMARY_${PN}-remote-logging = "Remote logging applications"
127RDEPENDS_${PN}-remote-logging = " \
Deepak Kodihallia549e752018-08-21 06:40:53 -0500128 rsyslog \
Deepak Kodihallif99f3c82018-08-28 11:39:41 -0500129 phosphor-rsyslog-config \
Brad Bishop09486912018-03-23 13:07:46 -0400130 "
131
Brad Bishop94bf53d2020-08-11 08:20:31 -0400132SUMMARY_${PN}-rng = "Random Number Generator support"
133RDEPENDS_${PN}-rng = " \
134 rng-tools \
135 "
136
Brad Bishop45f8b572017-02-01 21:04:14 -0500137SUMMARY_${PN}-sensors = "Sensor applications"
138RDEPENDS_${PN}-sensors = " \
139 ${VIRTUAL-RUNTIME_obmc-sensors-hwmon} \
140 "
Gunnar Millsc868f922017-02-15 16:01:45 -0600141
Lei YU005193d2019-05-06 14:35:27 +0800142${PN}-software-extras = ""
Brad Bishop811eeec2018-03-09 00:04:00 -0500143
Eddie James1a623ef2018-02-09 11:59:18 -0600144${PN}-software-extras_df-obmc-ubi-fs = " \
Adriana Kobylak3aeee112018-06-04 13:06:52 -0500145 phosphor-software-manager-updater-ubi \
Eddie James1a623ef2018-02-09 11:59:18 -0600146 "
Brad Bishop811eeec2018-03-09 00:04:00 -0500147
Adriana Kobylak7df4aa02020-06-04 14:03:03 -0500148${PN}-software-extras_df-phosphor-mmc = " \
149 phosphor-software-manager-updater-mmc \
150 "
151
Gunnar Millsc868f922017-02-15 16:01:45 -0600152SUMMARY_${PN}-software = "Software applications"
153RDEPENDS_${PN}-software = " \
Deepak Kodihalli60d1de52017-04-13 23:23:42 -0500154 ${VIRTUAL-RUNTIME_obmc-bmc-download-mgr} \
Gunnar Mills30131f72017-05-15 15:40:58 -0500155 ${VIRTUAL-RUNTIME_obmc-bmc-updater} \
Andrew Geissler1f957522018-02-09 12:50:57 -0800156 ${VIRTUAL-RUNTIME_obmc-bmc-version} \
Brad Bishop811eeec2018-03-09 00:04:00 -0500157 ${${PN}-software-extras} \
Andrew Geissler1f957522018-02-09 12:50:57 -0800158 "
159
Jayanth Othayoth9963d172017-05-08 09:25:05 -0500160SUMMARY_${PN}-debug-collector = "BMC debug collector"
161RDEPENDS_${PN}-debug-collector = " \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -0500162 ${VIRTUAL-RUNTIME_obmc-dump-manager} \
163 ${VIRTUAL-RUNTIME_obmc-dump-monitor} \
Jayanth Othayothd2592492017-07-29 22:28:44 -0500164 phosphor-debug-collector-dreport \
Marri Devender Rao33603922017-10-11 02:22:46 -0500165 phosphor-debug-collector-scripts \
Vishwanatha Subbanna14609cb2017-05-12 23:31:55 +0530166 "
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -0500167
168SUMMARY_${PN}-settings = "Settings applications"
169RDEPENDS_${PN}-settings = " \
Brad Bishopa71cf482020-03-19 16:14:54 -0400170 phosphor-settings-manager \
Deepak Kodihalli3e3c88c2017-05-17 06:42:51 -0500171 "
Ratan Guptab6de45c2017-07-06 21:09:14 +0530172
173SUMMARY_${PN}-network = "BMC Network Manager"
174RDEPENDS_${PN}-network = " \
175 ${VIRTUAL-RUNTIME_obmc-network-manager} \
176 "
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +0530177
178SUMMARY_${PN}-user-mgmt = "User management applications"
179RDEPENDS_${PN}-user-mgmt = " \
180 ${VIRTUAL-RUNTIME_obmc-user-mgmt} \
181 "
Brad Bishop94bf53d2020-08-11 08:20:31 -0400182RRECOMMENDS_${PN}-user-mgmt = " \
183 pam-plugin-access \
184 "
Brad Bishop7463d6d2020-08-10 20:45:15 -0400185
186SUMMARY_${PN}-user-mgmt-ldap = "LDAP users and groups support"
187RDEPENDS_${PN}-user-mgmt-ldap = " \
188 ${PN}-user-mgmt \
189 nss-pam-ldapd \
190 phosphor-ldap \
191 phosphor-nslcd-cert-config \
192 phosphor-nslcd-authority-cert-config \
193 "