blob: 9527b39e075d310d692e952da8af4427fe9b662c [file] [log] [blame]
vishwabmc1bf499d2015-10-09 15:51:50 +05301SUMMARY = "Phosphor OpenBMC IPMI daemon"
2DESCRIPTION = "Phosphor OpenBMC IPMI router and plugin libraries"
vishwabmc1bf499d2015-10-09 15:51:50 +05303PR = "r1"
Patrick Venturef30b8842018-10-21 08:27:22 -07004PV = "1.0+git${SRCPV}"
Patrick Venture64329372018-11-03 09:42:59 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
vishwabmc1bf499d2015-10-09 15:51:50 +05307
Brad Bishop7ee71462016-08-19 09:02:54 -05008RRECOMMENDS_${PN} += "packagegroup-obmc-ipmid-providers-libs"
Chris Austen213cd2a2015-10-24 19:34:11 -05009
Matthew Barth302592f2016-08-16 16:51:35 -050010inherit autotools pkgconfig
Patrick Ventured3dd0942017-12-22 14:36:07 -080011inherit obmc-phosphor-ipmiprovider-symlink
Patrick Williamsf7714062015-10-15 15:20:20 -050012inherit obmc-phosphor-sdbus-service
Patrick Ventured3dd0942017-12-22 14:36:07 -080013inherit obmc-phosphor-systemd
Ratan Guptab92d0ec2017-03-06 17:05:11 +053014inherit phosphor-ipmi-host
15inherit pythonnative
vishwabmc1bf499d2015-10-09 15:51:50 +053016
Brad Bishop7f2ade02018-01-26 22:11:36 -050017def ipmi_whitelists(d):
18 whitelists = d.getVar(
19 'VIRTUAL-RUNTIME_phosphor-ipmi-providers', True) or ''
20 whitelists = whitelists.split()
21 whitelists = [ '{}-whitelist-native'.format(x) for x in whitelists ]
22 return ' '.join(whitelists)
23
Patrick Ventured3dd0942017-12-22 14:36:07 -080024DEPENDS += "autoconf-archive-native"
David Cobbley1dc78fb2017-11-21 16:17:40 -080025DEPENDS += "nlohmann-json"
Patrick Ventured3dd0942017-12-22 14:36:07 -080026DEPENDS += "obmc-targets"
Brad Bishop7f2ade02018-01-26 22:11:36 -050027DEPENDS += "${@ipmi_whitelists(d)}"
Patrick Ventured3dd0942017-12-22 14:36:07 -080028DEPENDS += "phosphor-dbus-interfaces"
Adriana Kobylak17885c22017-02-17 08:21:42 -060029DEPENDS += "phosphor-logging"
Brad Bishop1122eb02016-10-05 20:10:23 -040030DEPENDS += "phosphor-mapper"
Ratan Gupta8dc22a92017-03-20 18:20:47 +053031DEPENDS += "sdbusplus"
Patrick Ventured3dd0942017-12-22 14:36:07 -080032DEPENDS += "sdbus++-native"
Tom Josephc32034f2019-02-04 03:54:06 -060033DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
Marri Devender Rao5a0088c2017-07-26 02:11:32 -050034DEPENDS += "virtual/phosphor-ipmi-fru-merge-config"
Patrick Ventured3dd0942017-12-22 14:36:07 -080035DEPENDS += "virtual/phosphor-ipmi-sensor-inventory"
Jaghathiswari Rankappagounder Natarajan47f26212019-02-07 12:19:57 -080036DEPENDS += "virtual/phosphor-ipmi-entity-config"
Andrew Geisslera561ec92018-09-25 19:50:20 +000037DEPENDS += "boost"
Patrick Venture12a94a82018-11-07 17:48:53 -080038DEPENDS += "sdeventplus"
Ratan Guptab92d0ec2017-03-06 17:05:11 +053039
Andrew Jeffery381e1e92018-04-06 14:13:14 +093040VIRTUAL-RUNTIME_ipmi-config ?= "phosphor-ipmi-config"
41
Adriana Kobylak17885c22017-02-17 08:21:42 -060042RDEPENDS_${PN}-dev += "phosphor-logging"
Brad Bishop1122eb02016-10-05 20:10:23 -040043RDEPENDS_${PN}-dev += "phosphor-mapper-dev"
Milton D. Miller II611e3ff2016-03-04 15:29:29 -060044RDEPENDS_${PN} += "clear-once"
Patrick Ventured3dd0942017-12-22 14:36:07 -080045RDEPENDS_${PN} += "network"
Vishwanatha Subbanna78bc5422016-11-10 21:52:46 +053046RDEPENDS_${PN} += "phosphor-time-manager"
Andrew Jeffery381e1e92018-04-06 14:13:14 +093047RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_ipmi-config}"
Vishwanatha Subbanna55c545a2017-06-12 13:09:10 +053048RDEPENDS_${PN} += "virtual/obmc-watchdog"
Ratan Gupta8dc22a92017-03-20 18:20:47 +053049
Richard Marian Thomaiyarfe5b8d22018-08-20 20:14:16 +053050inherit useradd
51
52USERADD_PACKAGES = "${PN}"
53# add ipmi group
54GROUPADD_PARAM_${PN} = "ipmi"
Richard Marian Thomaiyar41882fb2018-12-14 09:04:40 +053055# Add root user to ipmi group
56GROUPMEMS_PARAM_${PN} = "-g ipmi -a root"
Richard Marian Thomaiyarfe5b8d22018-08-20 20:14:16 +053057
Vishwanatha Subbanna35318402017-03-31 14:41:11 +053058SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service phosphor-ipmi-host.service"
59
Andrew Geissler78e04542018-02-05 12:02:35 -080060RRECOMMENDS_${PN} += "${VIRTUAL-RUNTIME_obmc-settings-mgmt}"
61
vishwabmc1bf499d2015-10-09 15:51:50 +053062
Marri Devender Rao52a9f2d2017-06-08 00:47:54 -050063require ${PN}.inc
Chris Austen213cd2a2015-10-24 19:34:11 -050064
Tom Josephf07ae012017-02-20 12:01:43 +053065# Setup IPMI Whitelist Conf files
66WHITELIST_CONF = " \
Patrick Williamsf11f0152017-02-24 13:04:06 -060067 ${STAGING_DATADIR_NATIVE}/phosphor-ipmi-host/*.conf \
Tom Josephf07ae012017-02-20 12:01:43 +053068 ${S}/host-ipmid-whitelist.conf \
69 "
70EXTRA_OECONF = " \
71 WHITELIST_CONF="${WHITELIST_CONF}" \
Ratan Guptab92d0ec2017-03-06 17:05:11 +053072 SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor.yaml \
Tom Josephc32034f2019-02-04 03:54:06 -060073 INVSENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/invsensor.yaml \
Marri Devender Rao5a0088c2017-07-26 02:11:32 -050074 FRU_YAML_GEN=${STAGING_DIR_NATIVE}${config_datadir}/fru_config.yaml \
Patrick Ventureafdf9842018-01-18 18:01:29 -080075 CHANNEL_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/channel.yaml \
Jaghathiswari Rankappagounder Natarajan47f26212019-02-07 12:19:57 -080076 ENTITY_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/entity.yaml \
Marri Devender Rao9f32d172018-01-18 11:21:19 -060077 POWER_READING_SENSOR=${datadir}/ipmi-providers/power_reading.json\
Tom Josephf07ae012017-02-20 12:01:43 +053078 "
79
vishwabmc1bf499d2015-10-09 15:51:50 +053080S = "${WORKDIR}/git"
81
Andrew Jeffery381e1e92018-04-06 14:13:14 +093082SRC_URI += "file://merge_yamls.py "
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -050083
Vernon Mauery595c7382018-07-30 15:49:09 -070084HOSTIPMI_PROVIDER_LIBRARY += "libipmi20.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053085HOSTIPMI_PROVIDER_LIBRARY += "libsysintfcmds.so"
William A. Kennington IIIc426a982018-12-19 14:53:22 -080086HOSTIPMI_PROVIDER_LIBRARY += "libusercmds.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053087
Vernon Mauery595c7382018-07-30 15:49:09 -070088NETIPMI_PROVIDER_LIBRARY += "libipmi20.so"
William A. Kennington IIIc426a982018-12-19 14:53:22 -080089NETIPMI_PROVIDER_LIBRARY += "libusercmds.so"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053090
Matthew Barth302592f2016-08-16 16:51:35 -050091FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
Patrick Ventured3dd0942017-12-22 14:36:07 -080092FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
Tom Joseph40b4e3f2017-02-01 19:47:27 +053093FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
94FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Brad Bishop3b524cf2016-09-06 13:03:39 -040095
Andrew Geisslerafc510f2017-01-04 11:11:50 -060096# Soft Power Off
Andrew Geisslerd40db752017-05-11 16:16:27 -050097# install the soft power off service in the host shutdown target
98SOFT_SVC = "xyz.openbmc_project.Ipmi.Internal.SoftPowerOff.service"
99SOFT_TGTFMT = "obmc-host-shutdown@{0}.target"
100SOFT_FMT = "../${SOFT_SVC}:${SOFT_TGTFMT}.requires/${SOFT_SVC}"
101SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'SOFT_FMT', 'OBMC_HOST_INSTANCES')}"
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500102
103#Collect all hardcoded sensor yamls from different recipes and
104#merge all of them with sensor.yaml.
105python do_merge_sensors () {
106 import subprocess
107
108 # TODO: Perform the merge in a temporary directory?
109 workdir = d.getVar('WORKDIR', True)
110 nativedir = d.getVar('STAGING_DIR_NATIVE', True)
111 sensorsdir = d.getVar('sensor_datadir', True)
112 sensorsdir = sensorsdir[1:]
113 sensorsdir = os.path.join(nativedir, sensorsdir)
114 cmd = []
115 cmd.append(os.path.join(workdir, 'merge_yamls.py'))
116 cmd.append(os.path.join(sensorsdir, 'sensor.yaml'))
117
118 if os.stat(os.path.join(sensorsdir, 'sensor.yaml')).st_size == 0:
119 return
120 fetch = bb.fetch2.Fetch([], d)
Kun Yie6bd58c2017-10-09 23:17:08 -0700121 override_urls = [url for url in fetch.urls if url.endswith('.hardcoded.yaml')]
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500122 for url in override_urls:
123 bb.debug(2, 'Overriding with source: ' + url)
124 local_base = os.path.basename(fetch.localpath(url))
125 filename = os.path.join(workdir, local_base)
126 cmd.append(filename)
127
128 # Invoke the script and don't catch any resulting exception.
129 subprocess.check_call(cmd)
130}
Andrew Jeffery381e1e92018-04-06 14:13:14 +0930131
Dhruvaraj Subhashchandran16d57052017-08-04 16:09:15 -0500132# python-pyyaml-native is installed by do_configure, so put this task after
133addtask merge_sensors after do_configure before do_compile