blob: e5b0a4d01bb71bd97c516f06adaa0728391ead5f [file] [log] [blame]
Brad Bishopea02e472017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylak172fe102016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
6
7inherit autotools pkgconfig
8inherit pythonnative
9inherit obmc-phosphor-license
10inherit obmc-phosphor-dbus-service
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050011inherit phosphor-logging
Marri Devender Rao56eae0a2017-06-06 08:39:39 -050012inherit phosphor-dbus-yaml
Adriana Kobylak172fe102016-10-19 14:58:25 -050013
Adriana Kobylak172fe102016-10-19 14:58:25 -050014DEPENDS += "autoconf-archive-native"
15DEPENDS += "systemd"
16DEPENDS += "python-mako-native"
17DEPENDS += "python-pyyaml-native"
Patrick Williams57b17812016-12-09 08:56:38 -060018DEPENDS += "sdbusplus sdbusplus-native"
Deepak Kodihallic8d92052017-03-23 03:52:28 -050019DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050020DEPENDS += "virtual/phosphor-logging-callouts"
Marri Devender Raof2ea35d2017-05-14 09:01:35 -050021DEPENDS += "phosphor-logging-error-logs-native"
Marri Devender Rao6675eac2017-09-27 10:56:40 -050022DEPENDS += "phosphor-logging-native"
Deepak Kodihalli45160502017-06-13 12:52:19 -050023DEPENDS += "cereal"
Adriana Kobylak172fe102016-10-19 14:58:25 -050024
Michael Tritzccc0d0f2017-03-13 14:54:24 -050025PACKAGE_BEFORE_PN = "${PN}-test"
26FILES_${PN}-test = "${bindir}/*-test"
27
Marri Devender Rao6675eac2017-09-27 10:56:40 -050028PACKAGE_BEFORE_PN += "${PN}-elog"
29FILES_${PN}-elog += "${elog_dir}"
30
Deepak Kodihalli38af2c02018-08-24 08:05:14 -050031# Package configuration
32LOGGING_PACKAGES = " \
33 ${PN}-base \
34"
35
36ALLOW_EMPTY_${PN} = "1"
37PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
38SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
39DBUS_PACKAGES = "${LOGGING_PACKAGES}"
40
41RDEPENDS_${PN}-base += "sdbusplus phosphor-dbus-interfaces"
42FILES_${PN}-base += " \
43 ${sbindir}/phosphor-log-manager \
44 ${libdir}/libphosphor_logging.so.* \
45"
46DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service"
47
Adriana Kobylak172fe102016-10-19 14:58:25 -050048SRC_URI += "git://github.com/openbmc/phosphor-logging"
Brad Bishopea6a3d12018-08-30 13:52:43 -040049SRCREV = "9fab279fb38ab6b391503ce89aceb917ec35efa9"
Adriana Kobylak172fe102016-10-19 14:58:25 -050050
51S = "${WORKDIR}/git"
52
Marri Devender Rao6675eac2017-09-27 10:56:40 -050053# Do not DEPEND on the specified packages for native build
54# as they will not be available in host machine
Brad Bishopefeb13a2018-01-27 00:27:21 -050055DEPENDS_remove_class-native = " \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050056 virtual/phosphor-logging-callouts \
Brad Bishopefeb13a2018-01-27 00:27:21 -050057 sdbus++ \
58 systemd \
59 cereal \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050060 "
61
62# Do not DEPEND on the specified packages for native SDK build
63# as they will not be available in host machine
64DEPENDS_remove_class-nativesdk = " \
65 virtual/phosphor-logging-callouts \
66 sdbus++-native \
Brad Bishopefeb13a2018-01-27 00:27:21 -050067 cereal \
68 systemd \
69 phosphor-dbus-interfaces \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050070 "
71
72PACKAGECONFIG ??= "metadata-processing install_scripts"
73
Deepak Kodihalli2551ece2017-03-28 07:47:51 -050074PACKAGECONFIG[metadata-processing] = " \
75 --enable-metadata-processing, \
76 --disable-metadata-processing, , \
77 "
78
Marri Devender Rao6675eac2017-09-27 10:56:40 -050079# Provide a means to enable/disable install_scripts feature
80PACKAGECONFIG[install_scripts] = " \
81 --enable-install_scripts, \
82 --disable-install_scripts, ,\
83 "
84
85# Enable install_scripts during native and native SDK build
86PACKAGECONFIG_add_class-native = "install_scripts"
87PACKAGECONFIG_add_class-nativesdk = "install_scripts"
88
89# Disable install_scripts during target build
90PACKAGECONFIG_remove_class-target = "install_scripts"
91
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050092EXTRA_OECONF = " \
93 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
94 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
95 "
Marri Devender Rao6675eac2017-09-27 10:56:40 -050096
97BBCLASSEXTEND += "native nativesdk"