blob: 8a6b5057528cda27f1e810b4bdf85375a537e09e [file] [log] [blame]
Brad Bishopea02e472017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylak172fe102016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
6
7inherit autotools pkgconfig
8inherit pythonnative
9inherit obmc-phosphor-license
10inherit obmc-phosphor-dbus-service
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050011inherit phosphor-logging
Marri Devender Rao56eae0a2017-06-06 08:39:39 -050012inherit phosphor-dbus-yaml
Adriana Kobylak172fe102016-10-19 14:58:25 -050013
14DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
15
16DEPENDS += "autoconf-archive-native"
17DEPENDS += "systemd"
18DEPENDS += "python-mako-native"
19DEPENDS += "python-pyyaml-native"
Patrick Williams57b17812016-12-09 08:56:38 -060020DEPENDS += "sdbusplus sdbusplus-native"
Deepak Kodihallic8d92052017-03-23 03:52:28 -050021DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050022DEPENDS += "virtual/phosphor-logging-callouts"
Marri Devender Raof2ea35d2017-05-14 09:01:35 -050023DEPENDS += "phosphor-logging-error-logs-native"
Marri Devender Rao6675eac2017-09-27 10:56:40 -050024DEPENDS += "phosphor-logging-native"
Deepak Kodihalli45160502017-06-13 12:52:19 -050025DEPENDS += "cereal"
Adriana Kobylak78784092017-02-09 15:06:41 -060026RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
Adriana Kobylak172fe102016-10-19 14:58:25 -050027
Michael Tritzccc0d0f2017-03-13 14:54:24 -050028PACKAGE_BEFORE_PN = "${PN}-test"
29FILES_${PN}-test = "${bindir}/*-test"
30
Marri Devender Rao6675eac2017-09-27 10:56:40 -050031PACKAGE_BEFORE_PN += "${PN}-elog"
32FILES_${PN}-elog += "${elog_dir}"
33
Adriana Kobylak172fe102016-10-19 14:58:25 -050034SRC_URI += "git://github.com/openbmc/phosphor-logging"
Brad Bishopea6a3d12018-08-30 13:52:43 -040035SRCREV = "9fab279fb38ab6b391503ce89aceb917ec35efa9"
Adriana Kobylak172fe102016-10-19 14:58:25 -050036
37S = "${WORKDIR}/git"
38
Marri Devender Rao6675eac2017-09-27 10:56:40 -050039# Do not DEPEND on the specified packages for native build
40# as they will not be available in host machine
Brad Bishopefeb13a2018-01-27 00:27:21 -050041DEPENDS_remove_class-native = " \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050042 virtual/phosphor-logging-callouts \
Brad Bishopefeb13a2018-01-27 00:27:21 -050043 sdbus++ \
44 systemd \
45 cereal \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050046 "
47
48# Do not DEPEND on the specified packages for native SDK build
49# as they will not be available in host machine
50DEPENDS_remove_class-nativesdk = " \
51 virtual/phosphor-logging-callouts \
52 sdbus++-native \
Brad Bishopefeb13a2018-01-27 00:27:21 -050053 cereal \
54 systemd \
55 phosphor-dbus-interfaces \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050056 "
57
58PACKAGECONFIG ??= "metadata-processing install_scripts"
59
Deepak Kodihalli2551ece2017-03-28 07:47:51 -050060PACKAGECONFIG[metadata-processing] = " \
61 --enable-metadata-processing, \
62 --disable-metadata-processing, , \
63 "
64
Marri Devender Rao6675eac2017-09-27 10:56:40 -050065# Provide a means to enable/disable install_scripts feature
66PACKAGECONFIG[install_scripts] = " \
67 --enable-install_scripts, \
68 --disable-install_scripts, ,\
69 "
70
71# Enable install_scripts during native and native SDK build
72PACKAGECONFIG_add_class-native = "install_scripts"
73PACKAGECONFIG_add_class-nativesdk = "install_scripts"
74
75# Disable install_scripts during target build
76PACKAGECONFIG_remove_class-target = "install_scripts"
77
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050078EXTRA_OECONF = " \
79 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
80 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
81 "
Marri Devender Rao6675eac2017-09-27 10:56:40 -050082
83BBCLASSEXTEND += "native nativesdk"