blob: 0b6723c89859869e7267740e4ebaaf785eb0ea15 [file] [log] [blame]
Gunnar Mills35591d42017-01-27 13:13:24 -06001SUMMARY = "Phosphor Software Management"
2DESCRIPTION = "Phosphor Software Manager provides a set of system software \
3management daemons. It is suitable for use on a wide variety of OpenBMC \
4platforms."
Gunnar Mills35591d42017-01-27 13:13:24 -06005PR = "r1"
Matt Spinler3578d902018-06-21 14:23:47 -05006
7require ${PN}.inc
Gunnar Mills35591d42017-01-27 13:13:24 -06008
9SOFTWARE_MGR_PACKAGES = " \
10 ${PN}-version \
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050011 ${PN}-download-mgr \
Gunnar Mills30131f72017-05-15 15:40:58 -050012 ${PN}-updater \
Adriana Kobylak3aeee112018-06-04 13:06:52 -050013 ${PN}-updater-ubi \
Adriana Kobylakaabb95d2018-04-20 14:52:40 -050014 ${PN}-sync \
Gunnar Mills35591d42017-01-27 13:13:24 -060015"
Brad Bishop36a2dfb2018-04-11 11:42:17 -040016PACKAGE_BEFORE_PN += "${SOFTWARE_MGR_PACKAGES}"
17ALLOW_EMPTY_${PN} = "1"
Brad Bishop4c43bb52017-03-01 15:37:17 -050018
Gunnar Mills35591d42017-01-27 13:13:24 -060019DBUS_PACKAGES = "${SOFTWARE_MGR_PACKAGES}"
20
21# Set SYSTEMD_PACKAGES to empty because we do not want ${PN} and DBUS_PACKAGES
22# handles the rest.
23SYSTEMD_PACKAGES = ""
24
Adriana Kobylaka3641d72018-03-29 15:16:09 -050025PACKAGECONFIG[verify_signature] = "--enable-verify_signature,--disable-verify_signature"
Adriana Kobylakaabb95d2018-04-20 14:52:40 -050026PACKAGECONFIG[sync_bmc_files] = "--enable-sync_bmc_files,--disable-sync_bmc_files"
Lei YUdae52f32018-05-23 10:53:24 +080027PACKAGECONFIG[ubifs_layout] = "--enable-ubifs_layout"
Adriana Kobylaka3641d72018-03-29 15:16:09 -050028
Gunnar Mills35591d42017-01-27 13:13:24 -060029inherit autotools pkgconfig
30inherit obmc-phosphor-dbus-service
Gunnar Millse0178ae2017-05-24 13:12:22 -050031inherit pythonnative
Adriana Kobylak3aeee112018-06-04 13:06:52 -050032inherit ${@bb.utils.contains('DISTRO_FEATURES', 'obmc-ubi-fs', 'phosphor-software-manager-ubi-fs', '', d)}
Gunnar Mills35591d42017-01-27 13:13:24 -060033
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050034DEPENDS += " \
35 autoconf-archive-native \
36 sdbusplus \
37 phosphor-dbus-interfaces \
38 phosphor-logging \
Saqib Khan5ef4efb2017-11-15 05:31:12 -060039 sdbus++-native \
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050040"
Gunnar Mills35591d42017-01-27 13:13:24 -060041
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050042RDEPENDS_${PN}-version += " \
43 phosphor-logging \
44 phosphor-dbus-interfaces \
45 sdbusplus \
46"
47RDEPENDS_${PN}-download-mgr += " \
48 phosphor-logging \
49 phosphor-dbus-interfaces \
50 sdbusplus \
51"
Gunnar Mills30131f72017-05-15 15:40:58 -050052RDEPENDS_${PN}-updater += " \
Lei YUb2c944f2018-07-23 13:26:15 +080053 bash \
Gunnar Mills30131f72017-05-15 15:40:58 -050054 phosphor-logging \
55 phosphor-dbus-interfaces \
56 sdbusplus \
Patrick Williams2182d312017-08-09 17:36:04 -050057 virtual-obmc-image-manager \
Lei YUad84f762018-05-11 17:26:35 +080058"
Lei YUf43eb6e2018-08-21 16:18:28 +080059EXTRA_OECONF += " \
Lei YUbf3edf12018-08-21 16:22:20 +080060 ACTIVE_BMC_MAX_ALLOWED=1 \
Lei YUf43eb6e2018-08-21 16:18:28 +080061 MEDIA_DIR=/run/media \
62"
Patrick Williams2182d312017-08-09 17:36:04 -050063
64RPROVIDES_${PN}-version += " \
65 virtual-obmc-image-manager \
Gunnar Mills30131f72017-05-15 15:40:58 -050066"
Gunnar Mills35591d42017-01-27 13:13:24 -060067
Brad Bishop33e5a8b2018-06-08 10:20:52 -040068FILES_${PN}-version += "${sbindir}/phosphor-version-software-manager ${exec_prefix}/lib/tmpfiles.d/software.conf"
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050069FILES_${PN}-download-mgr += "${sbindir}/phosphor-download-manager"
Lei YUb2c944f2018-07-23 13:26:15 +080070FILES_${PN}-updater += " \
71 ${sbindir}/phosphor-image-updater \
72 ${sbindir}/obmc-flash-bmc \
73 "
Adriana Kobylaka420efc2018-05-22 12:33:45 -050074FILES_${PN}-sync += " \
75 ${sbindir}/phosphor-sync-software-manager \
76 ${sysconfdir}/synclist \
77 "
Gunnar Mills4a993b52017-05-11 08:27:12 -050078DBUS_SERVICE_${PN}-version += "xyz.openbmc_project.Software.Version.service"
Deepak Kodihalli60d1de52017-04-13 23:23:42 -050079DBUS_SERVICE_${PN}-download-mgr += "xyz.openbmc_project.Software.Download.service"
Gunnar Mills30131f72017-05-15 15:40:58 -050080DBUS_SERVICE_${PN}-updater += "xyz.openbmc_project.Software.BMC.Updater.service"
Adriana Kobylakaabb95d2018-04-20 14:52:40 -050081DBUS_SERVICE_${PN}-sync += "xyz.openbmc_project.Software.Sync.service"
Gunnar Mills35591d42017-01-27 13:13:24 -060082
Lei YUb2c944f2018-07-23 13:26:15 +080083SYSTEMD_SERVICE_${PN}-updater += " \
84 obmc-flash-bmc-setenv@.service \
85"
86
Brad Bishop33e5a8b2018-06-08 10:20:52 -040087SRC_URI += "file://software.conf"
Lei YUb2c944f2018-07-23 13:26:15 +080088SRC_URI += "file://obmc-flash-bmc"
Brad Bishop33e5a8b2018-06-08 10:20:52 -040089
Adriana Kobylaka290eff2017-06-27 09:39:57 -050090do_install_append() {
Lei YUb2c944f2018-07-23 13:26:15 +080091 install -d ${D}${sbindir}
92 install -m 0755 ${WORKDIR}/obmc-flash-bmc ${D}${sbindir}/obmc-flash-bmc
93
Brad Bishop33e5a8b2018-06-08 10:20:52 -040094 # /tmp/images is the software image upload directory.
95 # It should not be deleted since it is watched by the Image Manager
96 # for new images.
97
98 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true', 'false', d)}; then
99 install -d ${D}${exec_prefix}/lib/tmpfiles.d
100 install -m 644 ${WORKDIR}/software.conf ${D}${exec_prefix}/lib/tmpfiles.d/
101 fi
Adriana Kobylaka290eff2017-06-27 09:39:57 -0500102}
103
Gunnar Mills35591d42017-01-27 13:13:24 -0600104S = "${WORKDIR}/git"