Brad Bishop | ea02e47 | 2017-05-12 13:02:56 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC event and error logging" |
| 2 | DESCRIPTION = "An error and event log daemon application, and \ |
| 3 | supporting tools for OpenBMC." |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 4 | HOMEPAGE = "https://github.com/openbmc/phosphor-logging" |
| 5 | PR = "r1" |
| 6 | |
| 7 | inherit autotools pkgconfig |
| 8 | inherit pythonnative |
| 9 | inherit obmc-phosphor-license |
| 10 | inherit obmc-phosphor-dbus-service |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 11 | inherit phosphor-logging |
Marri Devender Rao | 56eae0a | 2017-06-06 08:39:39 -0500 | [diff] [blame] | 12 | inherit phosphor-dbus-yaml |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 13 | |
| 14 | DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service" |
| 15 | |
| 16 | DEPENDS += "autoconf-archive-native" |
| 17 | DEPENDS += "systemd" |
| 18 | DEPENDS += "python-mako-native" |
| 19 | DEPENDS += "python-pyyaml-native" |
Patrick Williams | 57b1781 | 2016-12-09 08:56:38 -0600 | [diff] [blame] | 20 | DEPENDS += "sdbusplus sdbusplus-native" |
Deepak Kodihalli | c8d9205 | 2017-03-23 03:52:28 -0500 | [diff] [blame] | 21 | DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native" |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 22 | DEPENDS += "virtual/phosphor-logging-callouts" |
Marri Devender Rao | f2ea35d | 2017-05-14 09:01:35 -0500 | [diff] [blame] | 23 | DEPENDS += "phosphor-logging-error-logs-native" |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 24 | DEPENDS += "phosphor-logging-native" |
Deepak Kodihalli | 4516050 | 2017-06-13 12:52:19 -0500 | [diff] [blame] | 25 | DEPENDS += "cereal" |
Adriana Kobylak | 7878409 | 2017-02-09 15:06:41 -0600 | [diff] [blame] | 26 | RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 27 | |
Michael Tritz | ccc0d0f | 2017-03-13 14:54:24 -0500 | [diff] [blame] | 28 | PACKAGE_BEFORE_PN = "${PN}-test" |
| 29 | FILES_${PN}-test = "${bindir}/*-test" |
| 30 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 31 | PACKAGE_BEFORE_PN += "${PN}-elog" |
| 32 | FILES_${PN}-elog += "${elog_dir}" |
| 33 | |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 34 | SRC_URI += "git://github.com/openbmc/phosphor-logging" |
Andrew Geissler | dc8af82 | 2018-05-24 00:10:05 -0500 | [diff] [blame] | 35 | SRCREV = "4a029f2f401a6738c6daa31ad3098eb7f0915c7c" |
Adriana Kobylak | 172fe10 | 2016-10-19 14:58:25 -0500 | [diff] [blame] | 36 | |
| 37 | S = "${WORKDIR}/git" |
| 38 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 39 | # Do not DEPEND on the specified packages for native build |
| 40 | # as they will not be available in host machine |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 41 | DEPENDS_remove_class-native = " \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 42 | virtual/phosphor-logging-callouts \ |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 43 | sdbus++ \ |
| 44 | systemd \ |
| 45 | cereal \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 46 | " |
| 47 | |
| 48 | # Do not DEPEND on the specified packages for native SDK build |
| 49 | # as they will not be available in host machine |
| 50 | DEPENDS_remove_class-nativesdk = " \ |
| 51 | virtual/phosphor-logging-callouts \ |
| 52 | sdbus++-native \ |
Brad Bishop | efeb13a | 2018-01-27 00:27:21 -0500 | [diff] [blame] | 53 | cereal \ |
| 54 | systemd \ |
| 55 | phosphor-dbus-interfaces \ |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 56 | " |
| 57 | |
| 58 | PACKAGECONFIG ??= "metadata-processing install_scripts" |
| 59 | |
Deepak Kodihalli | 2551ece | 2017-03-28 07:47:51 -0500 | [diff] [blame] | 60 | PACKAGECONFIG[metadata-processing] = " \ |
| 61 | --enable-metadata-processing, \ |
| 62 | --disable-metadata-processing, , \ |
| 63 | " |
| 64 | |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 65 | # Provide a means to enable/disable install_scripts feature |
| 66 | PACKAGECONFIG[install_scripts] = " \ |
| 67 | --enable-install_scripts, \ |
| 68 | --disable-install_scripts, ,\ |
| 69 | " |
| 70 | |
| 71 | # Enable install_scripts during native and native SDK build |
| 72 | PACKAGECONFIG_add_class-native = "install_scripts" |
| 73 | PACKAGECONFIG_add_class-nativesdk = "install_scripts" |
| 74 | |
| 75 | # Disable install_scripts during target build |
| 76 | PACKAGECONFIG_remove_class-target = "install_scripts" |
| 77 | |
Deepak Kodihalli | 44b1c52 | 2017-03-16 06:32:12 -0500 | [diff] [blame] | 78 | EXTRA_OECONF = " \ |
| 79 | YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \ |
| 80 | CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \ |
| 81 | " |
Marri Devender Rao | 6675eac | 2017-09-27 10:56:40 -0500 | [diff] [blame] | 82 | |
| 83 | BBCLASSEXTEND += "native nativesdk" |