Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 1 | SUMMARY = "Phosphor PID Fan Control" |
| 2 | DESCRIPTION = "Fan Control" |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 3 | HOMEPAGE = "github.com/openbmc/phosphor-pid-control" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 4 | PR = "r1" |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 8 | |
Patrick Venture | eb6d9cb | 2019-07-03 10:32:22 -0700 | [diff] [blame] | 9 | inherit autotools pkgconfig |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 10 | |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 11 | inherit obmc-phosphor-ipmiprovider-symlink |
Vijay Khemka | d1c8ba8 | 2019-06-20 14:37:11 -0700 | [diff] [blame] | 12 | inherit systemd |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 13 | |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 14 | S = "${WORKDIR}/git" |
| 15 | SRC_URI = "git://github.com/openbmc/phosphor-pid-control" |
Andrew Geissler | bfaaf3c | 2020-10-09 16:21:10 +0000 | [diff] [blame] | 16 | SRCREV = "ca791156e2594ce7d25b42793a0a1b60d922fefd" |
Patrick Venture | c311dec | 2018-09-29 09:19:22 -0700 | [diff] [blame] | 17 | |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 18 | # Each platform will need a service file that starts |
| 19 | # at an appropriate time per system. For instance, if |
| 20 | # your system relies on passive dbus for fans or other |
| 21 | # sensors then it may be prudent to wait for all of them. |
| 22 | |
| 23 | DEPENDS += "autoconf-archive-native" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 24 | DEPENDS += "sdbusplus" |
Brad Bishop | 26873c9 | 2019-03-22 23:41:42 -0400 | [diff] [blame] | 25 | DEPENDS += "phosphor-dbus-interfaces" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 26 | DEPENDS += "phosphor-logging" |
| 27 | DEPENDS += "libevdev" |
Patrick Venture | 9b40f49 | 2019-02-12 08:59:31 -0800 | [diff] [blame] | 28 | DEPENDS += "nlohmann-json" |
Patrick Venture | d074256 | 2019-03-11 08:45:12 -0700 | [diff] [blame] | 29 | DEPENDS += "cli11" |
Andrew Geissler | 7c617d0 | 2019-04-15 14:22:02 +0000 | [diff] [blame] | 30 | DEPENDS += "boost" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 31 | |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 32 | # We depend on this to be built first so we can build our providers. |
| 33 | DEPENDS += "phosphor-ipmi-host" |
| 34 | |
Vijay Khemka | d1c8ba8 | 2019-06-20 14:37:11 -0700 | [diff] [blame] | 35 | SERVICE_FILE = "phosphor-pid-control.service" |
| 36 | SYSTEMD_PACKAGES = "${PN}" |
| 37 | SYSTEMD_SERVICE_${PN} = "${SERVICE_FILE}" |
| 38 | |
| 39 | EXTRA_OECONF = " \ |
| 40 | SYSTEMD_TARGET="multi-user.target" \ |
| 41 | " |
| 42 | |
Andrew Geissler | f0bbd18 | 2019-03-29 16:11:53 +0000 | [diff] [blame] | 43 | FILES_${PN} = "${bindir}/swampd ${bindir}/setsensor" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 44 | |
Patrick Venture | 13a1e6b | 2018-07-27 07:27:01 -0700 | [diff] [blame] | 45 | # The following installs the OEM IPMI handler for the fan controls. |
| 46 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 47 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 48 | FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 49 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
Patrick Venture | 028d240 | 2018-03-09 15:37:45 -0800 | [diff] [blame] | 50 | |
Patrick Venture | 13a1e6b | 2018-07-27 07:27:01 -0700 | [diff] [blame] | 51 | HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so" |
Brandon Kim | db34efb | 2020-08-13 14:51:02 -0700 | [diff] [blame] | 52 | |
| 53 | config_datadir="${datadir}/swampd/" |
| 54 | # config_path is the location swampd expects to find a json configuration. |
| 55 | # the file is expected to be named config.json |
| 56 | config_path="${config_datadir}config.json" |