blob: 7d11bffe0ac3357ca97813e98e05193fc9131203 [file] [log] [blame]
Jeremy Kerr49208ee2016-03-17 17:35:27 +08001SUMMARY = "OpenBMC console daemon"
2DESCRIPTION = "Daemon to handle UART console connections"
3HOMEPAGE = "http://github.com/openbmc/obmc-console"
4PR = "r1"
Patrick Venturee7a76eb2018-11-03 09:41:57 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
Jeremy Kerr49208ee2016-03-17 17:35:27 +08007
Jeremy Kerr49208ee2016-03-17 17:35:27 +08008inherit obmc-phosphor-systemd
Cheng C Yang5e9d3392019-01-30 14:31:56 +08009inherit autotools pkgconfig
Ratan Gupta653779c2016-10-01 14:57:15 -050010inherit obmc-phosphor-discovery-service
Jeremy Kerr49208ee2016-03-17 17:35:27 +080011
12TARGET_CFLAGS += "-fpic -O2"
13
Cheng C Yang5e9d3392019-01-30 14:31:56 +080014DEPENDS += "autoconf-archive-native \
15 systemd \
16 "
Matthew Barth3cc6f402016-09-26 16:26:27 -050017
Jeremy Kerr49208ee2016-03-17 17:35:27 +080018SRC_URI += "git://github.com/openbmc/obmc-console"
Brad Bishopb9a91af2019-06-19 16:42:18 -040019SRC_URI += "file://${BPN}.conf"
Jeremy Kerred9fafd2016-04-12 13:10:12 +080020
Andrew Geissler0a858bc2019-07-27 01:31:00 +000021SRCREV = "c5ce2cbd12e395749c3b4abedf0d81f49b402b70"
Brad Bishopbd6ae762018-04-12 11:11:49 -040022PV = "1.0+git${SRCPV}"
Jeremy Kerr49208ee2016-03-17 17:35:27 +080023
asmithakarun2d6aedf2019-06-24 05:28:05 -050024REGISTERED_SERVICES_${PN} += "obmc_console:tcp:2200:"
Vishwanatha Subbanna5f3a19b2016-10-01 11:34:42 -050025OBMC_CONSOLE_HOST_TTY ?= "ttyVUART0"
26SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh@.service"
Yi Li75ff3b92016-10-21 12:08:47 +080027SYSTEMD_SUBSTITUTIONS += "OBMC_CONSOLE_HOST_TTY:${OBMC_CONSOLE_HOST_TTY}:${PN}-ssh.socket"
Ratan Gupta653779c2016-10-01 14:57:15 -050028
Brad Bishop530eb732016-08-30 14:14:24 -040029SYSTEMD_SERVICE_${PN} = " \
Vishwanatha Subbanna5f3a19b2016-10-01 11:34:42 -050030 ${PN}@.service \
31 ${PN}@${OBMC_CONSOLE_HOST_TTY}.service \
Brad Bishop530eb732016-08-30 14:14:24 -040032 ${PN}-ssh.socket \
33 ${PN}-ssh@.service \
34 "
Jeremy Kerr49208ee2016-03-17 17:35:27 +080035do_install_append() {
36 install -m 0755 -d ${D}${sysconfdir}
37 install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
Jeremy Kerr49208ee2016-03-17 17:35:27 +080038}
39
40S = "${WORKDIR}/git"