blob: b4615ba7681af0bbdecfa08f1ef5fde5edd995f7 [file] [log] [blame]
Brad Bishopea02e472017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylak172fe102016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
6
7inherit autotools pkgconfig
8inherit pythonnative
9inherit obmc-phosphor-license
10inherit obmc-phosphor-dbus-service
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050011inherit phosphor-logging
Marri Devender Rao56eae0a2017-06-06 08:39:39 -050012inherit phosphor-dbus-yaml
Adriana Kobylak172fe102016-10-19 14:58:25 -050013
Adriana Kobylak172fe102016-10-19 14:58:25 -050014DEPENDS += "autoconf-archive-native"
15DEPENDS += "systemd"
16DEPENDS += "python-mako-native"
17DEPENDS += "python-pyyaml-native"
Patrick Williams57b17812016-12-09 08:56:38 -060018DEPENDS += "sdbusplus sdbusplus-native"
Deepak Kodihallic8d92052017-03-23 03:52:28 -050019DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050020DEPENDS += "virtual/phosphor-logging-callouts"
Marri Devender Raof2ea35d2017-05-14 09:01:35 -050021DEPENDS += "phosphor-logging-error-logs-native"
Marri Devender Rao6675eac2017-09-27 10:56:40 -050022DEPENDS += "phosphor-logging-native"
Deepak Kodihalli45160502017-06-13 12:52:19 -050023DEPENDS += "cereal"
Adriana Kobylak172fe102016-10-19 14:58:25 -050024
Michael Tritzccc0d0f2017-03-13 14:54:24 -050025PACKAGE_BEFORE_PN = "${PN}-test"
26FILES_${PN}-test = "${bindir}/*-test"
27
Marri Devender Rao6675eac2017-09-27 10:56:40 -050028PACKAGE_BEFORE_PN += "${PN}-elog"
29FILES_${PN}-elog += "${elog_dir}"
30
Deepak Kodihalli38af2c02018-08-24 08:05:14 -050031# Package configuration
32LOGGING_PACKAGES = " \
33 ${PN}-base \
Deepak Kodihallif99f3c82018-08-28 11:39:41 -050034 phosphor-rsyslog-config \
Deepak Kodihalli38af2c02018-08-24 08:05:14 -050035"
36
37ALLOW_EMPTY_${PN} = "1"
38PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
39SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
40DBUS_PACKAGES = "${LOGGING_PACKAGES}"
41
42RDEPENDS_${PN}-base += "sdbusplus phosphor-dbus-interfaces"
43FILES_${PN}-base += " \
44 ${sbindir}/phosphor-log-manager \
45 ${libdir}/libphosphor_logging.so.* \
46"
47DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service"
48
Deepak Kodihallif99f3c82018-08-28 11:39:41 -050049RDEPENDS_phosphor-rsyslog-config += "sdbusplus phosphor-dbus-interfaces"
50DBUS_SERVICE_phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"
51FILES_phosphor-rsyslog-config += " \
52 ${sbindir}/phosphor-rsyslog-conf \
53"
54
Adriana Kobylak172fe102016-10-19 14:58:25 -050055SRC_URI += "git://github.com/openbmc/phosphor-logging"
Andrew Geissler39ae4342018-08-31 13:10:21 +000056SRCREV = "5ac1bde129258d906246f5d4ad78e036f03a6e80"
Adriana Kobylak172fe102016-10-19 14:58:25 -050057
58S = "${WORKDIR}/git"
59
Marri Devender Rao6675eac2017-09-27 10:56:40 -050060# Do not DEPEND on the specified packages for native build
61# as they will not be available in host machine
Brad Bishopefeb13a2018-01-27 00:27:21 -050062DEPENDS_remove_class-native = " \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050063 virtual/phosphor-logging-callouts \
Brad Bishopefeb13a2018-01-27 00:27:21 -050064 sdbus++ \
65 systemd \
66 cereal \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050067 "
68
69# Do not DEPEND on the specified packages for native SDK build
70# as they will not be available in host machine
71DEPENDS_remove_class-nativesdk = " \
72 virtual/phosphor-logging-callouts \
73 sdbus++-native \
Brad Bishopefeb13a2018-01-27 00:27:21 -050074 cereal \
75 systemd \
76 phosphor-dbus-interfaces \
Marri Devender Rao6675eac2017-09-27 10:56:40 -050077 "
78
79PACKAGECONFIG ??= "metadata-processing install_scripts"
80
Deepak Kodihalli2551ece2017-03-28 07:47:51 -050081PACKAGECONFIG[metadata-processing] = " \
82 --enable-metadata-processing, \
83 --disable-metadata-processing, , \
84 "
85
Marri Devender Rao6675eac2017-09-27 10:56:40 -050086# Provide a means to enable/disable install_scripts feature
87PACKAGECONFIG[install_scripts] = " \
88 --enable-install_scripts, \
89 --disable-install_scripts, ,\
90 "
91
92# Enable install_scripts during native and native SDK build
93PACKAGECONFIG_add_class-native = "install_scripts"
94PACKAGECONFIG_add_class-nativesdk = "install_scripts"
95
96# Disable install_scripts during target build
97PACKAGECONFIG_remove_class-target = "install_scripts"
98
Deepak Kodihalli44b1c522017-03-16 06:32:12 -050099EXTRA_OECONF = " \
100 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
101 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
102 "
Marri Devender Rao6675eac2017-09-27 10:56:40 -0500103
104BBCLASSEXTEND += "native nativesdk"