blob: 2594a37f75794a7bfaba32c78c4b2b84e7c73d6c [file] [log] [blame]
Ed Tanous2c2a1c52018-01-29 10:56:52 -08001LICENSE = "Apache-2.0"
Andrew Geisslere11f5e22021-07-20 18:10:59 +00002LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
Ed Tanous07f48cc2021-02-22 10:49:30 -08003DEPENDS = " \
4 openssl \
5 zlib \
6 boost \
7 boost-url \
8 libpam \
9 sdbusplus \
10 gtest \
11 nlohmann-json \
12 libtinyxml2 \
Ed Tanousa443c542021-02-26 13:28:37 -080013 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest', '', d)} \
14 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gmock', '', d)} \
Ed Tanous07f48cc2021-02-22 10:49:30 -080015"
Andrew Geisslerb2f9dc92022-10-07 13:11:14 -050016SRCREV = "bb759e3aeaadfec9f3aac4485f253bcc8a523e4c"
Ed Tanous9936f862022-09-19 09:13:20 -070017PV = "1.0+git${SRCPV}"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080018
Ed Tanous9936f862022-09-19 09:13:20 -070019SRC_URI = "git://github.com/openbmc/bmcweb.git;branch=master;protocol=https;nobranch=1"
20SRC_URI += " \
21 file://run-ptest \
Ed Tanous07f48cc2021-02-22 10:49:30 -080022"
Adriana Kobylak7e0ff54f2018-12-13 11:01:05 -060023
Ed Tanous9936f862022-09-19 09:13:20 -070024S = "${WORKDIR}/git"
25SYSTEMD_SERVICE:${PN} += "bmcweb.service bmcweb.socket"
Ed Tanousa443c542021-02-26 13:28:37 -080026
Ed Tanous9936f862022-09-19 09:13:20 -070027inherit systemd
28inherit useradd
29inherit pkgconfig meson ptest
Ed Tanous2c2a1c52018-01-29 10:56:52 -080030
Ed Tanousa443c542021-02-26 13:28:37 -080031EXTRA_OEMESON = " \
32 --buildtype=minsize \
33 -Dtests=${@bb.utils.contains('PTEST_ENABLED', '1', 'enabled', 'disabled', d)} \
34 -Dyocto-deps=enabled \
35"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080036
Ed Tanous9936f862022-09-19 09:13:20 -070037do_install_ptest() {
38 install -d ${D}${PTEST_PATH}/test
39 cp -rf ${B}/*_test ${D}${PTEST_PATH}/test/
40}
Ed Tanous2c2a1c52018-01-29 10:56:52 -080041
Ed Tanous9936f862022-09-19 09:13:20 -070042RDEPENDS:${PN} += " \
43 jsnbd \
Patrick Williams0450a022022-10-07 21:23:47 -050044 phosphor-objmgr \
Ed Tanous9936f862022-09-19 09:13:20 -070045"
46
47FILES:${PN} += "${datadir}/** "
48
49USERADD_PACKAGES = "${PN}"
50# add a user called httpd for the server to assume
51USERADD_PARAM:${PN} = "-r -s /sbin/nologin bmcweb"
52
53GROUPADD_PARAM:${PN} = "web; redfish"
Manojkiran Edaf1f2e242020-09-02 21:48:12 +053054FULL_OPTIMIZATION = "-Os "