blob: 87369c47ddf408c96dda12c5099505c3efa4e504 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Target Communication Framework for the Eclipse IDE"
2HOMEPAGE = "http://wiki.eclipse.org/TCF"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "TCF is a vendor-neutral, lightweight, extensible network protocol mainly for communicating with embedded systems (targets)."
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004BUGTRACKER = "https://bugs.eclipse.org/bugs/"
5
6LICENSE = "EPL-1.0 | EDL-1.0"
7LIC_FILES_CHKSUM = "file://edl-v10.html;md5=522a390a83dc186513f0500543ad3679"
8
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009SRCREV = "a022ef2f1acfd9209a1bf792dda14ae4b0d1b60f"
10PV = "1.7.0+git${SRCPV}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050012UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013SRC_URI = "git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014 file://fix_ranlib.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050015 file://ldflags.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016 file://tcf-agent.init \
17 file://tcf-agent.service \
Andrew Geissler09036742021-06-25 14:25:14 -050018 file://0001-Fixed-copyright-messages.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050019 "
20
21DEPENDS = "util-linux openssl"
22RDEPENDS_${PN} = "bash"
23
24S = "${WORKDIR}/git/agent"
25
26inherit update-rc.d systemd
27
28SYSTEMD_SERVICE_${PN} = "tcf-agent.service"
29
30INITSCRIPT_NAME = "tcf-agent"
31INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ."
32
33# mangling needed for make
Andrew Geissler82c905d2020-04-13 13:39:40 -050034MAKE_ARCH = "`echo ${TARGET_ARCH} | sed s,i.86,i686, | sed s,aarch64.*,a64, | sed s,armeb,arm,`"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050035MAKE_OS = "`echo ${TARGET_OS} | sed s,^linux.*,GNU/Linux,`"
36
37EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'"
38
Brad Bishopd7bf8c12018-02-25 22:55:05 -050039LCL_STOP_SERVICES = "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040 -DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050041 -DSERVICE_StackTrace=0 -DSERVICE_Expressions=0"
42
43
44# These features don't compile for several cases.
45#
Brad Bishop19323692019-04-05 15:28:33 -040046CFLAGS_append_arc = " ${LCL_STOP_SERVICES}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050047CFLAGS_append_mips = " ${LCL_STOP_SERVICES}"
48CFLAGS_append_mips64 = " ${LCL_STOP_SERVICES}"
49CFLAGS_append_libc-musl = " ${LCL_STOP_SERVICES}"
50CFLAGS_append_powerpc64 = " ${LCL_STOP_SERVICES}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050051CFLAGS_append_powerpc64le = " ${LCL_STOP_SERVICES}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080052CFLAGS_append_riscv64 = " ${LCL_STOP_SERVICES}"
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060053CFLAGS_append_riscv32 = " ${LCL_STOP_SERVICES}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050054
55do_install() {
56 oe_runmake install INSTALLROOT=${D}
57 install -d ${D}${sysconfdir}/init.d/
58 install -m 0755 ${WORKDIR}/tcf-agent.init ${D}${sysconfdir}/init.d/tcf-agent
59 install -d ${D}${systemd_unitdir}/system
60 install -m 0644 ${WORKDIR}/tcf-agent.service ${D}${systemd_unitdir}/system
61 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/tcf-agent.service
62}
63