Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \ |
| 2 | server for multi-processor machines. It is a new implementation of the \ |
| 3 | JACK server core features that aims in removing some limitations of \ |
| 4 | the JACK1 design. The activation system has been changed for a data \ |
| 5 | flow model and lock-free programming techniques for graph access have \ |
| 6 | been used to have a more dynamic and robust system." |
| 7 | SECTION = "libs/multimedia" |
| 8 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 9 | LICENSE = "GPL-2.0-only & LGPL-2.1-only" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = " \ |
| 11 | file://common/jack/control.h;beginline=2;endline=21;md5=e6df0bf30cde8b3b825451459488195d \ |
| 12 | file://common/jack/jack.h;beginline=1;endline=19;md5=6b736ed6b810592b135480a5e853392e \ |
| 13 | " |
| 14 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 15 | DEPENDS = "libsamplerate0 libsndfile1 readline" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 16 | |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 17 | SRC_URI = "git://github.com/jackaudio/jack2.git;branch=master;protocol=https \ |
| 18 | file://0001-Remove-usage-of-U-mode-bit-for-opening-files-in-pyth.patch \ |
| 19 | " |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 20 | SRCREV = "6b3c96d8aeef8aeb4b20f3aa647e6d01b4000ff8" |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 21 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | inherit waf pkgconfig |
| 25 | |
| 26 | PACKAGECONFIG ??= "alsa" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 27 | PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | # --dbus only stops building jackd -> add --classic |
| 29 | PACKAGECONFIG[dbus] = "--dbus --classic,,dbus" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 30 | PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 31 | |
| 32 | # portaudio is for windows builds only |
| 33 | EXTRA_OECONF = "--portaudio=no" |
| 34 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 35 | do_install:append() { |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 36 | if ! ${@bb.utils.contains('PACKAGECONFIG', 'dbus', True, False, d)}; then |
| 37 | rm -f ${D}${bindir}/jack_control |
| 38 | fi |
| 39 | } |
| 40 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 41 | PACKAGES =+ "libjack jack-server jack-utils" |
| 42 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 43 | RDEPENDS:jack-dev:remove = "${PN} (= ${EXTENDPKGV})" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 44 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | FILES:libjack = "${libdir}/*.so.* ${libdir}/jack/*.so" |
| 46 | FILES:jack-server = " \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 47 | ${datadir}/dbus-1/services \ |
| 48 | ${bindir}/jackdbus \ |
| 49 | ${bindir}/jackd \ |
| 50 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 51 | FILES:jack-utils = "${bindir}/*" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 52 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 53 | FILES:${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/*" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 54 | |
| 55 | BBCLASSEXTEND = "native nativesdk" |