blob: 97b0edeed009880432d8b0cff1f6e9231da5f4bd [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \
2server for multi-processor machines. It is a new implementation of the \
3JACK server core features that aims in removing some limitations of \
4the JACK1 design. The activation system has been changed for a data \
5flow model and lock-free programming techniques for graph access have \
6been used to have a more dynamic and robust system."
7SECTION = "libs/multimedia"
8
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "GPL-2.0-only & LGPL-2.1-only"
Patrick Williamsddad1a12017-02-23 20:36:32 -060010LIC_FILES_CHKSUM = " \
11 file://common/jack/control.h;beginline=2;endline=21;md5=e6df0bf30cde8b3b825451459488195d \
12 file://common/jack/jack.h;beginline=1;endline=19;md5=6b736ed6b810592b135480a5e853392e \
13"
14
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015DEPENDS = "libsamplerate0 libsndfile1 readline"
Patrick Williamsddad1a12017-02-23 20:36:32 -060016
Andrew Geissler595f6302022-01-24 19:11:47 +000017SRC_URI = "git://github.com/jackaudio/jack2.git;branch=master;protocol=https \
Brad Bishop0e2770c2020-01-21 07:31:46 -050018 file://0001-example-clients-Use-c-compiler-for-jack_simdtests.patch \
19 "
Patrick Williams213cb262021-08-07 19:21:33 -050020SRCREV = "3e6ca6b734b69e2f5dfb85935068e15006fb5acf"
Brad Bishop996bc452019-12-02 13:05:15 -050021
Patrick Williamsddad1a12017-02-23 20:36:32 -060022S = "${WORKDIR}/git"
23
24inherit waf pkgconfig
25
26PACKAGECONFIG ??= "alsa"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib"
Brad Bishop19323692019-04-05 15:28:33 -040028# --dbus only stops building jackd -> add --classic
29PACKAGECONFIG[dbus] = "--dbus --classic,,dbus"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050030PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus"
Patrick Williamsddad1a12017-02-23 20:36:32 -060031
32# portaudio is for windows builds only
33EXTRA_OECONF = "--portaudio=no"
34
Patrick Williams213cb262021-08-07 19:21:33 -050035do_install:append() {
Brad Bishop996bc452019-12-02 13:05:15 -050036 if ! ${@bb.utils.contains('PACKAGECONFIG', 'dbus', True, False, d)}; then
37 rm -f ${D}${bindir}/jack_control
38 fi
39}
40
Patrick Williamsddad1a12017-02-23 20:36:32 -060041PACKAGES =+ "libjack jack-server jack-utils"
42
Patrick Williams213cb262021-08-07 19:21:33 -050043RDEPENDS:jack-dev:remove = "${PN} (= ${EXTENDPKGV})"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050044
Patrick Williams213cb262021-08-07 19:21:33 -050045FILES:libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
46FILES:jack-server = " \
Brad Bishop19323692019-04-05 15:28:33 -040047 ${datadir}/dbus-1/services \
48 ${bindir}/jackdbus \
49 ${bindir}/jackd \
50"
Patrick Williams213cb262021-08-07 19:21:33 -050051FILES:jack-utils = "${bindir}/*"
Brad Bishop19323692019-04-05 15:28:33 -040052
Patrick Williams213cb262021-08-07 19:21:33 -050053FILES:${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/*"