blob: 6da9d042decc19a4b6d99c68651b20ccf8b4accd [file] [log] [blame]
Vijay Khemka66070d32020-07-23 15:22:56 -07001SUMMARY = "BMC Health Monitoring"
2DESCRIPTION = "Daemon to collect and monitor bmc health statistics"
3HOMEPAGE = "https://github.com/openbmc/phosphor-health-monitor"
Vijay Khemka66070d32020-07-23 15:22:56 -07004LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
Vijay Khemka66070d32020-07-23 15:22:56 -07006DEPENDS += "sdbusplus"
7DEPENDS += "phosphor-dbus-interfaces"
8DEPENDS += "sdeventplus"
9DEPENDS += "phosphor-logging"
10DEPENDS += "nlohmann-json"
Andrew Geissler454ba152022-12-06 11:20:21 -060011SRCREV = "f7406df01dacb44a4796afb77f042b616acc0165"
Ed Tanous9936f862022-09-19 09:13:20 -070012PR = "r1"
Vijay Khemka66070d32020-07-23 15:22:56 -070013
Patrick Williamsbb99d222022-01-24 15:55:09 -060014SRC_URI = "git://github.com/openbmc/phosphor-health-monitor.git;protocol=https;branch=master"
Vijay Khemka66070d32020-07-23 15:22:56 -070015
Ed Tanous9936f862022-09-19 09:13:20 -070016S = "${WORKDIR}/git"
Patrick Williams12fc9392021-08-06 09:16:53 -050017SYSTEMD_SERVICE:${PN} = "phosphor-health-monitor.service"
Ed Tanous9936f862022-09-19 09:13:20 -070018
19inherit meson pkgconfig
20inherit systemd
Jayashree Dhanapal1ba4d1b2022-09-30 15:36:13 +053021
22do_install:append() {
23 if [ -e "${WORKDIR}/bmc_health_config.json" ]; then
24 install -d ${D}${sysconfdir}/healthMon
25 install -m 0644 ${WORKDIR}/bmc_health_config.json ${D}${sysconfdir}/healthMon
26 fi
27}