blob: 0c5e914726f36587da27728c48fd1be6e3e94b1e [file] [log] [blame]
Andrew Geissler16bb75a2023-06-09 14:34:42 -04001# Witherspoon system does not support warm reboots
2PACKAGECONFIG:append:witherspoon = " no-warm-reboot"
Andrew Geissler65393532021-01-28 13:17:12 -06003
Andrew Geissler3fb738c2023-01-10 14:33:43 -06004# IBM systems only want power restore when AC loss occurred
Andrew Geissler16bb75a2023-06-09 14:34:42 -04005PACKAGECONFIG:append = " only-run-apr-on-power-loss"
Andrew Geissler3fb738c2023-01-10 14:33:43 -06006
Andrew Geisslereabfa8b2023-06-08 14:05:36 -05007# IBM systems only allow boot operations when BMC is Ready
Andrew Geissler16bb75a2023-06-09 14:34:42 -04008PACKAGECONFIG:append = " only-allow-boot-when-bmc-ready"
Andrew Geisslereabfa8b2023-06-08 14:05:36 -05009
Andrew Geissler65393532021-01-28 13:17:12 -060010# The scheduled-host-transition package provides support to
11# schedule power on and off operations for the host at some
12# time in the future. IBM systems will utilize this feature
Andrew Geisslercc4d0852022-04-27 20:55:11 +000013RRECOMMENDS:${PN}-host:append = " ${PN}-scheduled-host-transition"
Andrew Geisslerb2644f82021-02-10 16:11:58 -060014
15# IBM systems track the state of the hypervisor so bring
16# in the needed package when the host state package is
17# included
Andrew Geisslercc4d0852022-04-27 20:55:11 +000018RRECOMMENDS:${PN}-host:append = " ${PN}-hypervisor"
Andrew Geissler192e2862022-02-08 14:23:21 -060019
Andrew Geisslerf0762072022-04-27 18:01:49 +000020# IBM p10 machines want the optional secure-check
21# feature enabled. This will verify all security
22# settings in manufacturing mode.
Andrew Geisslercc4d0852022-04-27 20:55:11 +000023RRECOMMENDS:${PN}-host:append:p10bmc = " ${PN}-secure-check"
Andrew Geisslerf0762072022-04-27 18:01:49 +000024
Andrew Geissler192e2862022-02-08 14:23:21 -060025# IBM systems want the chassis package to not allow a
26# system power on if chassis power is in a bad state
Andrew Geisslercc4d0852022-04-27 20:55:11 +000027RRECOMMENDS:${PN}-chassis:append = " ${PN}-chassis-check-power-status"
Andrew Geissler192e2862022-02-08 14:23:21 -060028
Andrew Geissler80a13f82022-03-02 22:30:35 +000029# Override critical services to monitor with IBM file
30FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
31FILES:${PN}-bmc:append = " ${sysconfdir}/phosphor-service-monitor-default.json"
32SRC_URI:append = " file://phosphor-service-monitor-default.json"
33do_install:append() {
34 install -d ${D}${sysconfdir}/phosphor-systemd-target-monitor
35 install -m 0644 ${WORKDIR}/phosphor-service-monitor-default.json \
36 ${D}${sysconfdir}/phosphor-systemd-target-monitor/
37}