blob: 9e45751648aa3c08ace91585e7f67dadcb586143 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "OpenGL driver testing framework"
2LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
4
5SRC_URI = "git://anongit.freedesktop.org/piglit \
Patrick Williamsc0f7c042017-02-23 20:41:17 -06006 file://0001-cmake-install-bash-completions-in-the-right-place.patch \
7 file://0001-tests-Use-FE_UPWARD-only-if-its-defined-in-fenv.h.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008 file://0001-cmake-use-proper-WAYLAND_INCLUDE_DIRS-variable.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -06009 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040010UPSTREAM_CHECK_COMMITS = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012# From 2018-08-13
13SRCREV = "57859e15dc8ba4034348b04d0b72f213b74d6347"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014# (when PV goes above 1.0 remove the trailing r)
15PV = "1.0+gitr${SRCPV}"
16
17S = "${WORKDIR}/git"
18
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019DEPENDS = "libpng virtual/libx11 libxkbcommon libxrender waffle virtual/libgl libglu python3-mako-native python3-numpy-native python3-six-native virtual/egl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050020
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021inherit cmake pkgconfig python3native distro_features_check bash-completion
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022# depends on virtual/libx11
23REQUIRED_DISTRO_FEATURES = "x11"
24
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025# depends on virtual/libgl
26REQUIRED_DISTRO_FEATURES += "opengl"
27
Patrick Williamsf1e5d692016-03-30 15:21:19 -050028# The built scripts go into the temporary directory according to tempfile
29# (typically /tmp) which can race if multiple builds happen on the same machine,
30# so tell it to use a directory in ${B} to avoid overwriting.
31export TEMP = "${B}/temp/"
32do_compile[dirs] =+ "${B}/temp/"
33
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034PACKAGECONFIG ??= ""
35PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
36
37do_configure_prepend() {
38 if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
39 sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
40 sed -i -e "/^#.*include.*<GL\/glut.h>$/d" ${S}/src/piglit/glut_wrap.h
41 fi
42}
43
Brad Bishop316dfdd2018-06-25 12:45:53 -040044OECMAKE_TARGET_INSTALL = "install/strip"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060045
46RDEPENDS_${PN} = "waffle python3 python3-mako python3-json \
Brad Bishop316dfdd2018-06-25 12:45:53 -040047 python3-misc \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060048 python3-unixadmin python3-xml python3-multiprocessing \
Brad Bishop316dfdd2018-06-25 12:45:53 -040049 python3-six python3-shell python3-io \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050050 python3-netserver mesa-demos bash \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050051 "
52
Patrick Williamsc0f7c042017-02-23 20:41:17 -060053INSANE_SKIP_${PN} += "dev-so already-stripped"