Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 1 | SUMMARY = "OpenPOWER processor control services installation" |
| 2 | PR = "r1" |
| 3 | |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | inherit allarch |
| 8 | |
Adriana Kobylak | 8c6707f | 2021-08-06 17:35:36 +0000 | [diff] [blame] | 9 | RDEPENDS:${PN} += "op-proc-control" |
| 10 | RDEPENDS:${PN} += "phosphor-state-manager-obmc-targets" |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 11 | |
Adriana Kobylak | 8c6707f | 2021-08-06 17:35:36 +0000 | [diff] [blame] | 12 | ALLOW_EMPTY:${PN} = "1" |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 13 | |
Adriana Kobylak | 8c6707f | 2021-08-06 17:35:36 +0000 | [diff] [blame] | 14 | pkg_postinst:${PN}() { |
Andrew Geissler | 55bd449 | 2020-03-31 13:43:46 -0500 | [diff] [blame] | 15 | mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 16 | mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires |
Dhruvaraj Subhashchandran | c8aa6a1 | 2020-03-09 13:04:32 -0500 | [diff] [blame] | 17 | mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires |
Andrew Geissler | b9b3a4a | 2023-05-12 14:10:34 -0500 | [diff] [blame] | 18 | mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants |
Dhruvaraj Subhashchandran | c8aa6a1 | 2020-03-09 13:04:32 -0500 | [diff] [blame] | 19 | mkdir -p $D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires |
Andrew Geissler | f95063e | 2020-04-14 15:08:43 -0500 | [diff] [blame] | 20 | mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires |
Andrew Geissler | c3f1beb | 2020-12-09 15:05:02 -0600 | [diff] [blame] | 21 | mkdir -p $D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 22 | |
Andrew Geissler | 55bd449 | 2020-03-31 13:43:46 -0500 | [diff] [blame] | 23 | LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service" |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 24 | TARGET="../op-stop-instructions@.service" |
| 25 | ln -s $TARGET $LINK |
| 26 | |
deepa | 94fa8dd | 2023-08-03 01:43:06 -0500 | [diff] [blame] | 27 | LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/op-clear-sys-dump-active@0.service" |
| 28 | TARGET="../op-clear-sys-dump-active@.service" |
| 29 | ln -s $TARGET $LINK |
| 30 | |
Andrew Geissler | c3f1beb | 2020-12-09 15:05:02 -0600 | [diff] [blame] | 31 | LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/op-stop-instructions@0.service" |
| 32 | TARGET="../op-stop-instructions@.service" |
| 33 | ln -s $TARGET $LINK |
| 34 | |
Andrew Geissler | f95063e | 2020-04-14 15:08:43 -0500 | [diff] [blame] | 35 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service" |
| 36 | TARGET="../op-cfam-reset.service" |
| 37 | ln -s $TARGET $LINK |
| 38 | |
Andrew Geissler | b9b3a4a | 2023-05-12 14:10:34 -0500 | [diff] [blame] | 39 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/xyz.openbmc_project.Control.Host.NMI.service" |
| 40 | TARGET="../xyz.openbmc_project.Control.Host.NMI.service" |
| 41 | ln -s $TARGET $LINK |
| 42 | |
Andrew Geissler | f95063e | 2020-04-14 15:08:43 -0500 | [diff] [blame] | 43 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service" |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 44 | TARGET="../op-cfam-reset.service" |
| 45 | ln -s $TARGET $LINK |
Andrew Geissler | 4e174d1 | 2020-02-26 14:11:53 -0600 | [diff] [blame] | 46 | |
| 47 | # Only install cfam override if p9 system |
| 48 | if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then |
| 49 | mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires |
| 50 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service" |
| 51 | TARGET="../cfam_override@.service" |
| 52 | ln -s $TARGET $LINK |
| 53 | fi |
Dhruvaraj Subhashchandran | c8aa6a1 | 2020-03-09 13:04:32 -0500 | [diff] [blame] | 54 | |
| 55 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service" |
| 56 | TARGET="../op-continue-mpreboot@.service" |
| 57 | ln -s $TARGET $LINK |
| 58 | |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 59 | # Only install certain units if phal enabled |
Patrick Williams | 8c561ee | 2021-10-22 14:20:12 -0500 | [diff] [blame] | 60 | if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" = phal ]; then |
Andrew Geissler | f158d90 | 2022-04-08 16:24:35 -0500 | [diff] [blame] | 61 | LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-clear-sys-dump-active@0.service" |
| 62 | TARGET="../op-clear-sys-dump-active@.service" |
| 63 | ln -s $TARGET $LINK |
| 64 | |
| 65 | mkdir -p $D$systemd_system_unitdir/multi-user.target.wants |
| 66 | LINK="$D$systemd_system_unitdir/multi-user.target.wants/op-clear-sys-dump-active@0.service" |
| 67 | TARGET="../op-clear-sys-dump-active@.service" |
| 68 | ln -s $TARGET $LINK |
| 69 | |
Ramesh Iyyar | d6d9b54 | 2020-09-17 10:02:08 -0500 | [diff] [blame] | 70 | mkdir -p $D$systemd_system_unitdir/obmc-host-start@0.target.requires |
| 71 | LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service" |
| 72 | TARGET="../phal-reinit-devtree.service" |
| 73 | ln -s $TARGET $LINK |
Chirag Sharma | 5ec16a3 | 2020-12-11 03:45:15 -0600 | [diff] [blame] | 74 | |
| 75 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service" |
| 76 | TARGET="../proc-pre-poweroff@.service" |
| 77 | ln -s $TARGET $LINK |
Andrew Geissler | 4d2fd8d | 2021-06-24 15:28:47 -0500 | [diff] [blame] | 78 | |
| 79 | LINK="$D$systemd_system_unitdir/obmc-host-reset@0.target.requires/op-reset-host-check@0.service" |
| 80 | TARGET="../op-reset-host-check@.service" |
| 81 | ln -s $TARGET $LINK |
Jayanth Othayoth | ad68ba3 | 2021-07-30 06:35:44 -0500 | [diff] [blame] | 82 | |
Jayanth Othayoth | ad68ba3 | 2021-07-30 06:35:44 -0500 | [diff] [blame] | 83 | LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service" |
| 84 | TARGET="../phal-import-devtree@.service" |
| 85 | ln -s $TARGET $LINK |
Jayanth Othayoth | ce7dbec | 2021-07-30 06:46:57 -0500 | [diff] [blame] | 86 | |
| 87 | mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants |
| 88 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/phal-export-devtree@0.service" |
| 89 | TARGET="../phal-export-devtree@.service" |
| 90 | ln -s $TARGET $LINK |
Ramesh Iyyar | d0aedb9 | 2022-02-24 03:35:40 -0600 | [diff] [blame] | 91 | |
| 92 | mkdir -p $D$systemd_system_unitdir/obmc-host-start@0.target.wants |
| 93 | LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.wants/phal-create-boottime-guard-indicator.service" |
| 94 | TARGET="../phal-create-boottime-guard-indicator.service" |
| 95 | ln -s $TARGET $LINK |
| 96 | LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/phal-create-boottime-guard-indicator.service" |
| 97 | ln -s $TARGET $LINK |
Jayanth Othayoth | 633a9cc | 2022-09-12 06:23:45 -0500 | [diff] [blame] | 98 | |
| 99 | mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants |
| 100 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/op-clock-data-logger@0.service" |
| 101 | TARGET="../op-clock-data-logger@.service" |
| 102 | ln -s $TARGET $LINK |
Andrew Geissler | b9b3a4a | 2023-05-12 14:10:34 -0500 | [diff] [blame] | 103 | |
| 104 | mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.wants |
| 105 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.wants/set-spi-mux.service" |
| 106 | TARGET="../set-spi-mux.service" |
| 107 | ln -s $TARGET $LINK |
Jayanth Othayoth | ad68ba3 | 2021-07-30 06:35:44 -0500 | [diff] [blame] | 108 | fi |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 109 | |
Andrew Geissler | aa25e2c | 2021-02-01 14:14:25 -0600 | [diff] [blame] | 110 | # If the memory preserving reboot feature is enabled, set it up |
| 111 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'mpreboot', d)}" = mpreboot ]; then |
| 112 | # on mpreboot systems, obmc-host-crash@.target is used for mpreboot |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 113 | mkdir -p $D$systemd_system_unitdir/obmc-host-crash@0.target.requires |
| 114 | LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-force-warm-reboot@0.target" |
| 115 | TARGET="../obmc-host-force-warm-reboot@.target" |
| 116 | ln -s $TARGET $LINK |
| 117 | |
| 118 | LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/op-enter-mpreboot@0.service" |
| 119 | TARGET="../op-enter-mpreboot@.service" |
| 120 | ln -s $TARGET $LINK |
| 121 | |
Andrew Geissler | aa25e2c | 2021-02-01 14:14:25 -0600 | [diff] [blame] | 122 | # ensure diagnostic mode is shown for MPREBOOT |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 123 | LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-diagnostic-mode@0.target" |
| 124 | TARGET="../obmc-host-diagnostic-mode@.target" |
| 125 | ln -s $TARGET $LINK |
| 126 | else |
Andrew Geissler | aa25e2c | 2021-02-01 14:14:25 -0600 | [diff] [blame] | 127 | # If not a mpreboot system, default to quiesce target in crash target to support |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 128 | # older system designs like witherspoon |
| 129 | mkdir -p $D$systemd_system_unitdir/obmc-host-crash@0.target.wants |
| 130 | LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.wants/obmc-host-quiesce@0.target" |
| 131 | TARGET="../obmc-host-quiesce@.target" |
| 132 | ln -s $TARGET $LINK |
Ramesh Iyyar | d6d9b54 | 2020-09-17 10:02:08 -0500 | [diff] [blame] | 133 | fi |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 134 | } |
| 135 | |
Adriana Kobylak | 8c6707f | 2021-08-06 17:35:36 +0000 | [diff] [blame] | 136 | pkg_prerm:${PN}() { |
Andrew Geissler | 55bd449 | 2020-03-31 13:43:46 -0500 | [diff] [blame] | 137 | LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service" |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 138 | rm $LINK |
Andrew Geissler | f95063e | 2020-04-14 15:08:43 -0500 | [diff] [blame] | 139 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service" |
| 140 | rm $LINK |
| 141 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service" |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 142 | rm $LINK |
Andrew Geissler | b9b3a4a | 2023-05-12 14:10:34 -0500 | [diff] [blame] | 143 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/xyz.openbmc_project.Control.Host.NMI.service" |
| 144 | rm $LINK |
Andrew Geissler | 4e174d1 | 2020-02-26 14:11:53 -0600 | [diff] [blame] | 145 | # Only uninstall cfam override if p9 system |
| 146 | if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then |
| 147 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service" |
| 148 | rm $LINK |
| 149 | fi |
Dhruvaraj Subhashchandran | c8aa6a1 | 2020-03-09 13:04:32 -0500 | [diff] [blame] | 150 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service" |
| 151 | rm $LINK |
Ramesh Iyyar | d6d9b54 | 2020-09-17 10:02:08 -0500 | [diff] [blame] | 152 | |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 153 | # Remove phal specific units if enabled |
Patrick Williams | 8c561ee | 2021-10-22 14:20:12 -0500 | [diff] [blame] | 154 | if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" = phal ]; then |
Ramesh Iyyar | d6d9b54 | 2020-09-17 10:02:08 -0500 | [diff] [blame] | 155 | LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service" |
| 156 | rm $LINK |
Chirag Sharma | 5ec16a3 | 2020-12-11 03:45:15 -0600 | [diff] [blame] | 157 | |
| 158 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service" |
| 159 | rm $LINK |
Jayanth Othayoth | ad68ba3 | 2021-07-30 06:35:44 -0500 | [diff] [blame] | 160 | |
Andrew Geissler | b9b3a4a | 2023-05-12 14:10:34 -0500 | [diff] [blame] | 161 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.wants/set-spi-mux.service" |
| 162 | rm $LINK |
| 163 | |
Jayanth Othayoth | ad68ba3 | 2021-07-30 06:35:44 -0500 | [diff] [blame] | 164 | LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service" |
| 165 | rm $LINK |
Jayanth Othayoth | ce7dbec | 2021-07-30 06:46:57 -0500 | [diff] [blame] | 166 | |
| 167 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/phal-export-devtree@0.service" |
| 168 | rm $LINK |
Ramesh Iyyar | d0aedb9 | 2022-02-24 03:35:40 -0600 | [diff] [blame] | 169 | |
| 170 | LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.wants/phal-create-boottime-guard-indicator.service" |
| 171 | rm $LINK |
| 172 | LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/phal-create-boottime-guard-indicator.service" |
| 173 | rm $LINK |
Jayanth Othayoth | 633a9cc | 2022-09-12 06:23:45 -0500 | [diff] [blame] | 174 | |
| 175 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/op-clock-data-logger@0.service" |
| 176 | rm $LINK |
Andrew Geissler | aa25e2c | 2021-02-01 14:14:25 -0600 | [diff] [blame] | 177 | fi |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 178 | |
Andrew Geissler | aa25e2c | 2021-02-01 14:14:25 -0600 | [diff] [blame] | 179 | # Remove mpreboot specific units if enabled |
| 180 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'mpreboot', d)}" = mpreboot ]; then |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 181 | LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-force-warm-reboot@0.target" |
| 182 | rm $LINK |
| 183 | |
| 184 | LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/op-enter-mpreboot@0.service" |
| 185 | rm $LINK |
| 186 | else |
| 187 | LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.wants/obmc-host-quiesce@0.target" |
| 188 | rm $LINK |
Ramesh Iyyar | d6d9b54 | 2020-09-17 10:02:08 -0500 | [diff] [blame] | 189 | fi |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 190 | } |