blob: 5402f39a5b45b3c29e123fa2c6f4b06b953df77f [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Valgrind memory debugger and instrumentation framework"
2HOMEPAGE = "http://valgrind.org/"
3BUGTRACKER = "http://valgrind.org/support/bug_reports.html"
4LICENSE = "GPLv2 & GPLv2+ & BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
Andrew Geissler4ed12e12020-06-05 18:00:41 -05006 file://include/pub_tool_basics.h;beginline=6;endline=29;md5=41c410e8d3f305aee7aaa666b2e4f366 \
Brad Bishopc342db32019-05-15 21:57:59 -04007 file://include/valgrind.h;beginline=1;endline=56;md5=ad3b317f3286b6b704575d9efe6ca5df \
8 file://COPYING.DOCS;md5=24ea4c7092233849b4394699333b5c56"
9
Brad Bishop96ff1982019-08-19 13:50:42 -040010DEPENDS = " \
Brad Bishopc342db32019-05-15 21:57:59 -040011 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} \
12 "
13
14SRC_URI = "https://sourceware.org/pub/valgrind/valgrind-${PV}.tar.bz2 \
15 file://fixed-perl-path.patch \
16 file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
17 file://run-ptest \
Brad Bishopa34c0302019-09-23 22:34:48 -040018 file://remove-for-aarch64 \
Brad Bishopc342db32019-05-15 21:57:59 -040019 file://0004-Fix-out-of-tree-builds.patch \
20 file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \
21 file://0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch \
22 file://use-appropriate-march-mcpu-mfpu-for-ARM-test-apps.patch \
23 file://avoid-neon-for-targets-which-don-t-support-it.patch \
24 file://valgrind-make-ld-XXX.so-strlen-intercept-optional.patch \
25 file://0001-makefiles-Drop-setting-mcpu-to-cortex-a8-on-arm-arch.patch \
26 file://0001-str_tester.c-Limit-rawmemchr-test-to-glibc.patch \
27 file://0001-sigqueue-Rename-_sifields-to-__si_fields-on-musl.patch \
28 file://0002-context-APIs-are-not-available-on-musl.patch \
29 file://0003-correct-include-directive-path-for-config.h.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040030 file://0005-tc20_verifywrap.c-Fake-__GLIBC_PREREQ-with-musl.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040031 file://0001-memcheck-arm64-Define-__THROW-if-not-already-defined.patch \
32 file://0002-memcheck-x86-Define-__THROW-if-not-defined.patch \
33 file://0003-tests-seg_override-Replace-__modify_ldt-with-syscall.patch \
34 file://0001-fix-opcode-not-supported-on-mips32-linux.patch \
35 file://0001-Guard-against-__GLIBC_PREREQ-for-musl-libc.patch \
36 file://0001-Make-local-functions-static-to-avoid-assembler-error.patch \
37 file://0001-Return-a-valid-exit_code-from-vg_regtest.patch \
38 file://0001-valgrind-filter_xml_frames-do-not-filter-usr.patch \
Brad Bishopa34c0302019-09-23 22:34:48 -040039 file://0001-adjust-path-filter-for-2-memcheck-tests.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050040 file://s390x_vec_op_t.patch \
41 file://0001-none-tests-fdleak_cmsg.stderr.exp-adjust-tmp-paths.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050042 file://0001-memcheck-tests-Fix-timerfd-syscall-test.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040043 "
Andrew Geissler4ed12e12020-06-05 18:00:41 -050044SRC_URI[md5sum] = "495b30af5e5ed62ebb9bb777ee19b27f"
45SRC_URI[sha256sum] = "582d5127ba56dfeaab4c6ced92a742b2921148e28a5d55055aedd8f75f1cf633"
Brad Bishopc342db32019-05-15 21:57:59 -040046UPSTREAM_CHECK_REGEX = "valgrind-(?P<pver>\d+(\.\d+)+)\.tar"
47
48COMPATIBLE_HOST = '(i.86|x86_64|arm|aarch64|mips|powerpc|powerpc64).*-linux'
49
50# valgrind supports armv7 and above
51COMPATIBLE_HOST_armv4 = 'null'
52COMPATIBLE_HOST_armv5 = 'null'
53COMPATIBLE_HOST_armv6 = 'null'
54
55# X32 isn't supported by valgrind at this time
56COMPATIBLE_HOST_linux-gnux32 = 'null'
57COMPATIBLE_HOST_linux-muslx32 = 'null'
58
59# Disable for some MIPS variants
60COMPATIBLE_HOST_mipsarchr6 = 'null'
61COMPATIBLE_HOST_linux-gnun32 = 'null'
62
63# Disable for powerpc64 with musl
64COMPATIBLE_HOST_libc-musl_powerpc64 = 'null'
65
Andrew Geissler82c905d2020-04-13 13:39:40 -050066# brokenseip is unfortunately required by ptests to pass
67inherit autotools-brokensep ptest multilib_header
Brad Bishopc342db32019-05-15 21:57:59 -040068
69EXTRA_OECONF = "--enable-tls --without-mpicc"
70EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEINFO_BITS') != '32']}"
71
72# valgrind checks host_cpu "armv7*)", so we need to over-ride the autotools.bbclass default --host option
73EXTRA_OECONF_append_arm = " --host=armv7${HOST_VENDOR}-${HOST_OS}"
74
75EXTRA_OEMAKE = "-w"
76
77CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
78
79# valgrind likes to control its own optimisation flags. It generally defaults
80# to -O2 but uses -O0 for some specific test apps etc. Passing our own flags
81# (via CFLAGS) means we interfere with that. Only pass DEBUG_FLAGS to it
82# which fixes build path issue in DWARF.
83SELECTED_OPTIMIZATION = "${DEBUG_FLAGS}"
84
85do_configure_prepend () {
86 rm -rf ${S}/config.h
87 sed -i -e 's:$(abs_top_builddir):$(pkglibdir)/ptest:g' ${S}/none/tests/Makefile.am
88 sed -i -e 's:$(top_builddir):$(pkglibdir)/ptest:g' ${S}/memcheck/tests/Makefile.am
89}
90
91do_install_append () {
92 install -m 644 ${B}/default.supp ${D}/${libdir}/valgrind/
93 oe_multilib_header valgrind/config.h
94}
95
96VALGRINDARCH ?= "${TARGET_ARCH}"
97VALGRINDARCH_aarch64 = "arm64"
98VALGRINDARCH_x86-64 = "amd64"
99VALGRINDARCH_x86 = "x86"
100VALGRINDARCH_mips = "mips32"
101VALGRINDARCH_mipsel = "mips32"
102VALGRINDARCH_mips64el = "mips64"
103VALGRINDARCH_powerpc = "ppc"
104VALGRINDARCH_powerpc64 = "ppc64"
105VALGRINDARCH_powerpc64el = "ppc64le"
106
107INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libdir}/valgrind/vgpreload_memcheck-${VALGRINDARCH}-linux.so"
108
109RDEPENDS_${PN} += "perl"
110
111# valgrind needs debug information for ld.so at runtime in order to
112# redirect functions like strlen.
113RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
114
Brad Bishopa34c0302019-09-23 22:34:48 -0400115RDEPENDS_${PN}-ptest += " bash coreutils file \
116 gdb libgomp \
117 perl \
118 perl-module-getopt-long perl-module-file-basename perl-module-file-glob \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500119 procps sed ${PN}-dbg ${PN}-src"
Brad Bishopc342db32019-05-15 21:57:59 -0400120RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
121
122# One of the tests contains a bogus interpreter path on purpose.
123# Skip file dependency check
124SKIP_FILEDEPS_${PN}-ptest = '1'
125INSANE_SKIP_${PN}-ptest = "debug-deps"
126
127do_compile_ptest() {
128 oe_runmake check
129}
130
131do_install_ptest() {
132 chmod +x ${B}/tests/vg_regtest
133
134 # The test application binaries are not automatically installed.
135 # Grab them from the build directory.
136 #
137 # The regression tests require scripts and data files that are not
138 # copied to the build directory. They must be copied from the
139 # source directory.
140 saved_dir=$PWD
141 for parent_dir in ${S} ${B} ; do
142 cd $parent_dir
143
Brad Bishopc342db32019-05-15 21:57:59 -0400144 subdirs=" \
Brad Bishopa34c0302019-09-23 22:34:48 -0400145 .in_place \
Brad Bishopc342db32019-05-15 21:57:59 -0400146 cachegrind/tests \
147 callgrind/tests \
Brad Bishopa34c0302019-09-23 22:34:48 -0400148 dhat/tests \
Brad Bishopc342db32019-05-15 21:57:59 -0400149 drd/tests \
150 gdbserver_tests \
151 helgrind/tests \
Brad Bishopa34c0302019-09-23 22:34:48 -0400152 lackey/tests \
Brad Bishopc342db32019-05-15 21:57:59 -0400153 massif/tests \
154 memcheck/tests \
155 none/tests \
156 tests \
Brad Bishopa34c0302019-09-23 22:34:48 -0400157 exp-bbv/tests \
158 exp-dhat/tests \
159 exp-sgcheck/tests \
Brad Bishopc342db32019-05-15 21:57:59 -0400160 "
Brad Bishopc342db32019-05-15 21:57:59 -0400161 # Get the vg test scripts, filters, and expected files
162 for dir in $subdirs ; do
163 find $dir | cpio -pvdu ${D}${PTEST_PATH}
164 done
165 cd $saved_dir
166 done
167
Brad Bishopa34c0302019-09-23 22:34:48 -0400168 # The scripts reference config.h so add it to the top ptest dir.
169 cp ${B}/config.h ${D}${PTEST_PATH}
170 install -D ${WORKDIR}/remove-for-aarch64 ${D}${PTEST_PATH}
171
172 # Add an executable need by none/tests/bigcode
173 mkdir ${D}${PTEST_PATH}/perf
174 cp ${B}/perf/bigcode ${D}${PTEST_PATH}/perf
175
176 # Add an executable needed by memcheck/tests/vcpu_bz2
177 cp ${B}/perf/bz2 ${D}${PTEST_PATH}/perf
178
179 # Make the ptest dir look like the top level valgrind src dir
180 # This is checked by the gdbserver_tests/make_local_links script
181 mkdir ${D}${PTEST_PATH}/coregrind
182 cp ${B}/coregrind/vgdb ${D}${PTEST_PATH}/coregrind
183
184 # Add an executable needed by massif tests
185 cp ${B}/massif/ms_print ${D}${PTEST_PATH}/massif/ms_print
186
Brad Bishopc342db32019-05-15 21:57:59 -0400187 find ${D}${PTEST_PATH} \
Brad Bishopa34c0302019-09-23 22:34:48 -0400188 \( \
189 -name "Makefile*" \
Brad Bishopc342db32019-05-15 21:57:59 -0400190 -o -name "*.o" \
Brad Bishopa34c0302019-09-23 22:34:48 -0400191 \) \
Brad Bishopc342db32019-05-15 21:57:59 -0400192 -exec rm {} \;
Brad Bishopa34c0302019-09-23 22:34:48 -0400193
194 # These files need to be newer so touch them.
Brad Bishop15ae2502019-06-18 21:44:24 -0400195 touch ${D}${PTEST_PATH}/cachegrind/tests/a.c -r ${D}${PTEST_PATH}/cachegrind/tests/cgout-test
Brad Bishopc342db32019-05-15 21:57:59 -0400196
197 # find *_annotate in ${bindir} for yocto build
198 sed -i s:\.\./\.\./cachegrind/cg_annotate:${bindir}/cg_annotate: ${D}${PTEST_PATH}/cachegrind/tests/ann1.vgtest
199 sed -i s:\.\./\.\./cachegrind/cg_annotate:${bindir}/cg_annotate: ${D}${PTEST_PATH}/cachegrind/tests/ann2.vgtest
200
201 sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann1.vgtest
202 sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann2.vgtest
203
Brad Bishopc342db32019-05-15 21:57:59 -0400204 # handle multilib
205 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
Brad Bishopa34c0302019-09-23 22:34:48 -0400206 sed -i s:@bindir@:${bindir}:g ${D}${PTEST_PATH}/run-ptest
Andrew Geissler82c905d2020-04-13 13:39:40 -0500207
208 # This test fails on the host as well, using both 3.15 and git master (as of Jan 24 2020)
209 # https://bugs.kde.org/show_bug.cgi?id=402833
210 rm ${D}${PTEST_PATH}/memcheck/tests/overlap.vgtest
211
212 # As the binary isn't stripped or debug-splitted, the source file isn't fetched
213 # via dwarfsrcfiles either, so it needs to be installed manually.
214 mkdir -p ${D}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/${BP}/none/tests/
215 install ${S}/none/tests/tls.c ${D}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/${BP}/none/tests/
Brad Bishopc342db32019-05-15 21:57:59 -0400216}
Andrew Geissler82c905d2020-04-13 13:39:40 -0500217
218# avoid stripping some generated binaries otherwise some of the tests will fail
219# run-strip-reloc.sh, run-strip-strmerge.sh and so on will fail
220INHIBIT_PACKAGE_STRIP_FILES = "\
221 ${PKGD}${PTEST_PATH}/none/tests/tls \
222 ${PKGD}${PTEST_PATH}/none/tests/tls.so \
223 ${PKGD}${PTEST_PATH}/none/tests/tls2.so \
224 ${PKGD}${PTEST_PATH}/helgrind/tests/tc09_bad_unlock \
225 ${PKGD}${PTEST_PATH}/memcheck/tests/manuel1 \
226 ${PKGD}${PTEST_PATH}/drd/tests/pth_detached3 \
227"