blob: e67eccc75ce835b117069c7610e76223628c2ebc [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Target Communication Framework for the Eclipse IDE"
2HOMEPAGE = "http://wiki.eclipse.org/TCF"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06003DESCRIPTION = "TCF is a vendor-neutral, lightweight, extensible network protocol mainly for communicating with embedded systems (targets)."
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004BUGTRACKER = "https://bugs.eclipse.org/bugs/"
5
6LICENSE = "EPL-1.0 | EDL-1.0"
7LIC_FILES_CHKSUM = "file://edl-v10.html;md5=522a390a83dc186513f0500543ad3679"
8
Andrew Geissler5199d832021-09-24 16:47:35 -05009SRCREV = "2735e3d6b7eccb05ab232825c618c837d27a5010"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010PV = "1.7.0+git${SRCPV}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050012UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050013SRC_URI = "git://git.eclipse.org/r/tcf/org.eclipse.tcf.agent.git;protocol=https \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014 file://fix_ranlib.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050015 file://ldflags.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016 file://tcf-agent.init \
17 file://tcf-agent.service \
18 "
19
20DEPENDS = "util-linux openssl"
Patrick Williams213cb262021-08-07 19:21:33 -050021RDEPENDS:${PN} = "bash"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022
23S = "${WORKDIR}/git/agent"
24
25inherit update-rc.d systemd
26
Patrick Williams213cb262021-08-07 19:21:33 -050027SYSTEMD_SERVICE:${PN} = "tcf-agent.service"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050028
29INITSCRIPT_NAME = "tcf-agent"
30INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ."
31
32# mangling needed for make
Andrew Geissler82c905d2020-04-13 13:39:40 -050033MAKE_ARCH = "`echo ${TARGET_ARCH} | sed s,i.86,i686, | sed s,aarch64.*,a64, | sed s,armeb,arm,`"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034MAKE_OS = "`echo ${TARGET_OS} | sed s,^linux.*,GNU/Linux,`"
35
36EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'"
37
Brad Bishopd7bf8c12018-02-25 22:55:05 -050038LCL_STOP_SERVICES = "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050039 -DSERVICE_Memory=0 -DSERVICE_Registers=0 -DSERVICE_MemoryMap=0 \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050040 -DSERVICE_StackTrace=0 -DSERVICE_Expressions=0"
41
42
43# These features don't compile for several cases.
44#
Patrick Williams213cb262021-08-07 19:21:33 -050045CFLAGS:append:arc = " ${LCL_STOP_SERVICES}"
46CFLAGS:append:mips = " ${LCL_STOP_SERVICES}"
47CFLAGS:append:mips64 = " ${LCL_STOP_SERVICES}"
48CFLAGS:append:libc-musl = " ${LCL_STOP_SERVICES}"
49CFLAGS:append:powerpc64 = " ${LCL_STOP_SERVICES}"
50CFLAGS:append:powerpc64le = " ${LCL_STOP_SERVICES}"
51CFLAGS:append:riscv64 = " ${LCL_STOP_SERVICES}"
52CFLAGS:append:riscv32 = " ${LCL_STOP_SERVICES}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050053
54do_install() {
55 oe_runmake install INSTALLROOT=${D}
56 install -d ${D}${sysconfdir}/init.d/
57 install -m 0755 ${WORKDIR}/tcf-agent.init ${D}${sysconfdir}/init.d/tcf-agent
Andrew Geissler5199d832021-09-24 16:47:35 -050058 install -d ${D}${systemd_system_unitdir}
59 install -m 0644 ${WORKDIR}/tcf-agent.service ${D}${systemd_system_unitdir}
60 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_system_unitdir}/tcf-agent.service
Patrick Williamsc124f4f2015-09-15 14:41:29 -050061}
62