blob: f0508fbf76d4a03c957831c5ec6daeb6a9af267e [file] [log] [blame]
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +05301SUMMARY = "Phosphor Watchdog application"
2DESCRIPTION = "Application that implements software watchdog"
3HOMEPAGE = "http://github.com/openbmc/phosphor-watchdog"
4PR = "r1"
Patrick Venturea1a628b2018-10-01 20:48:41 -07005PV = "1.0+git${SRCPV}"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +05306LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Patrick Venturea1a628b2018-10-01 20:48:41 -07008
William A. Kennington III7d98c922019-03-28 03:38:35 -07009inherit meson pkgconfig
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053010inherit obmc-phosphor-dbus-service
11
William A. Kennington IIIf33e9a12018-09-14 00:25:00 -070012DEPENDS += "cli11"
William A. Kennington IIIf37d0962019-03-27 20:21:26 -070013DEPENDS += "sdbusplus"
William A. Kennington III83d610a2018-09-13 23:32:19 -070014DEPENDS += "sdeventplus"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053015DEPENDS += "phosphor-dbus-interfaces"
16DEPENDS += "phosphor-logging"
Brad Bishop44f3cce2019-03-22 23:41:42 -040017DEPENDS += "systemd"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053018
Patrick Williamsbb99d222022-01-24 15:55:09 -060019SRC_URI += "git://github.com/openbmc/phosphor-watchdog;branch=master;protocol=https"
Andrew Geissler6a4b3682022-08-10 10:01:28 -050020SRCREV = "d6bc8e88eb6dba6c11daca7371118e943da50f50"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053021S = "${WORKDIR}/git"
22
William A. Kennington III7d98c922019-03-28 03:38:35 -070023EXTRA_OEMESON = " \
24 -Dtests=disabled \
25 "
26
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053027# Copies config file having arguments for host watchdog
Patrick Williamse83c2202021-09-01 16:17:33 -050028SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/watchdog/poweron"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053029
30# Install the override to set up a Conflicts relation
Patrick Williamse83c2202021-09-01 16:17:33 -050031SYSTEMD_OVERRIDE:${PN} += "poweron.conf:phosphor-watchdog@poweron.service.d/poweron.conf"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053032
33# For now, watching PowerOn is the only usecase
34OBMC_HOST_WATCHDOG_INSTANCES = "poweron"
35
36# This is really a DBUS service but the service name is
37# an argument, so making it this way.
38WATCHDOG_TMPL = "phosphor-watchdog@.service"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053039ENABLE_WATCHDOG_TMPL = "obmc-enable-host-watchdog@.service"
Patrick Williams12fc9392021-08-06 09:16:53 -050040SYSTEMD_SERVICE:${PN} += "${WATCHDOG_TMPL}"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053041
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053042# To Enable Host Watchdog early during poweron
Patrick Williams12fc9392021-08-06 09:16:53 -050043SYSTEMD_SERVICE:${PN} += "${ENABLE_WATCHDOG_TMPL}"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053044
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053045WATCHDOG_TGTFMT = "phosphor-watchdog@{0}.service"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053046ENABLE_WATCHDOG_TGTFMT = "obmc-enable-host-watchdog@{0}.service"
47
Andrew Geissler5c76e0c2018-03-27 13:56:26 -070048WATCHDOG_FMT = "../${WATCHDOG_TMPL}:obmc-host-startmin@{1}.target.wants/${WATCHDOG_TGTFMT}"
49ENABLE_WATCHDOG_FMT = "../${ENABLE_WATCHDOG_TMPL}:obmc-host-startmin@{0}.target.wants/${ENABLE_WATCHDOG_TGTFMT}"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053050
Patrick Williamse83c2202021-09-01 16:17:33 -050051SYSTEMD_LINK:${PN} += "${@compose_list(d, 'WATCHDOG_FMT', 'OBMC_HOST_WATCHDOG_INSTANCES', 'OBMC_HOST_INSTANCES')}"
52SYSTEMD_LINK:${PN} += "${@compose_list(d, 'ENABLE_WATCHDOG_FMT', 'OBMC_HOST_INSTANCES')}"