blob: 7140ad7f4e57cd4012cc4f9181a5c56b172bec0c [file] [log] [blame]
Brad Bishop37653df2017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
5PR = "r1"
Patrick Venture5bce7d72018-10-21 08:22:43 -07006PV = "1.0+git${SRCPV}"
Brad Bishop75f03872018-11-03 09:41:57 -07007LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05009
10inherit autotools pkgconfig
Matt Spinlereca58902020-03-06 09:24:33 -060011inherit python3native
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050012inherit obmc-phosphor-dbus-service
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050013inherit phosphor-logging
Marri Devender Raobf369d02017-06-06 08:39:39 -050014inherit phosphor-dbus-yaml
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050015
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050016DEPENDS += "autoconf-archive-native"
17DEPENDS += "systemd"
Matt Spinler017f9422020-03-13 15:57:29 -050018DEPENDS += "${PYTHON_PN}-mako-native"
19DEPENDS += "${PYTHON_PN}-pyyaml-native"
20DEPENDS += "${PYTHON_PN}-native"
Patrick Williams4b32c9a2020-03-31 16:43:15 -050021DEPENDS += "${PYTHON_PN}-sdbus++-native"
22DEPENDS += "sdbusplus"
Deepak Kodihalli0ac54522017-03-23 03:52:28 -050023DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050024DEPENDS += "virtual/phosphor-logging-callouts"
Marri Devender Rao3b1e30e2017-05-14 09:01:35 -050025DEPENDS += "phosphor-logging-error-logs-native"
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050026DEPENDS += "phosphor-logging-native"
Brad Bishop17c08bf2018-10-18 17:07:53 -040027DEPENDS += "libcereal"
Matt Spinlerf319ea62019-07-23 16:04:04 -050028DEPENDS += "sdeventplus"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050029
Michael Tritz026fbaf2017-03-13 14:54:24 -050030PACKAGE_BEFORE_PN = "${PN}-test"
31FILES_${PN}-test = "${bindir}/*-test"
32
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050033PACKAGE_BEFORE_PN += "${PN}-elog"
34FILES_${PN}-elog += "${elog_dir}"
35
Deepak Kodihalli64464772018-08-24 08:05:14 -050036# Package configuration
37LOGGING_PACKAGES = " \
38 ${PN}-base \
Deepak Kodihalli04aa22f2018-08-28 11:39:41 -050039 phosphor-rsyslog-config \
Deepak Kodihalli64464772018-08-24 08:05:14 -050040"
41
42ALLOW_EMPTY_${PN} = "1"
43PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
44SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
45DBUS_PACKAGES = "${LOGGING_PACKAGES}"
46
Deepak Kodihalli64464772018-08-24 08:05:14 -050047FILES_${PN}-base += " \
Patrick Venturecb51ccb2019-04-04 14:49:25 -070048 ${bindir}/phosphor-log-manager \
Deepak Kodihalli64464772018-08-24 08:05:14 -050049 ${libdir}/libphosphor_logging.so.* \
50"
51DBUS_SERVICE_${PN}-base += "xyz.openbmc_project.Logging.service"
52
Deepak Kodihalli04aa22f2018-08-28 11:39:41 -050053DBUS_SERVICE_phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"
54FILES_phosphor-rsyslog-config += " \
Patrick Venturecb51ccb2019-04-04 14:49:25 -070055 ${bindir}/phosphor-rsyslog-conf \
Deepak Kodihalli04aa22f2018-08-28 11:39:41 -050056"
57
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050058SRC_URI += "git://github.com/openbmc/phosphor-logging"
Andrew Geissler5d9464d2020-04-22 15:21:22 +000059SRCREV = "d03d3d91bc39dcae72d07cd59ecbcbe530a7a9ed"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050060
61S = "${WORKDIR}/git"
62
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050063# Do not DEPEND on the specified packages for native build
64# as they will not be available in host machine
Brad Bishop096e4b42018-01-27 00:27:21 -050065DEPENDS_remove_class-native = " \
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050066 virtual/phosphor-logging-callouts \
Patrick Williams4b32c9a2020-03-31 16:43:15 -050067 sdbusplus \
Brad Bishop096e4b42018-01-27 00:27:21 -050068 systemd \
Brad Bishop17c08bf2018-10-18 17:07:53 -040069 libcereal \
Matt Spinlerf319ea62019-07-23 16:04:04 -050070 sdeventplus \
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050071 "
72
73# Do not DEPEND on the specified packages for native SDK build
74# as they will not be available in host machine
75DEPENDS_remove_class-nativesdk = " \
76 virtual/phosphor-logging-callouts \
Patrick Williamsa5647132020-04-08 10:51:39 -050077 sdbusplus \
Brad Bishop17c08bf2018-10-18 17:07:53 -040078 libcereal \
Brad Bishop096e4b42018-01-27 00:27:21 -050079 systemd \
80 phosphor-dbus-interfaces \
Matt Spinlerf319ea62019-07-23 16:04:04 -050081 sdeventplus \
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050082 "
83
84PACKAGECONFIG ??= "metadata-processing install_scripts"
85
Deepak Kodihalli430a5062017-03-28 07:47:51 -050086PACKAGECONFIG[metadata-processing] = " \
87 --enable-metadata-processing, \
88 --disable-metadata-processing, , \
89 "
90
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -050091# Provide a means to enable/disable install_scripts feature
92PACKAGECONFIG[install_scripts] = " \
93 --enable-install_scripts, \
94 --disable-install_scripts, ,\
95 "
96
Matt Spinlerf8510922019-08-08 13:21:24 -050097PACKAGECONFIG[openpower-pels] = " \
98 --enable-openpower-pel-extension, \
Matt Spinler949e4dc2019-09-26 15:17:15 -050099 --disable-openpower-pel-extension, \
Matt Spinler11ba5162019-12-18 14:27:07 -0600100 nlohmann-json nlohmann-fifo cli11 pldm, \
Matt Spinler949e4dc2019-09-26 15:17:15 -0500101 , \
Matt Spinlerf8510922019-08-08 13:21:24 -0500102 "
103
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -0500104# Enable install_scripts during native and native SDK build
105PACKAGECONFIG_add_class-native = "install_scripts"
106PACKAGECONFIG_add_class-nativesdk = "install_scripts"
107
108# Disable install_scripts during target build
109PACKAGECONFIG_remove_class-target = "install_scripts"
110
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -0500111EXTRA_OECONF = " \
112 YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
113 CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
114 "
Marri Devender Rao6c41d2e2017-09-27 10:56:40 -0500115
116BBCLASSEXTEND += "native nativesdk"