blob: 5faf22a26e8bfc214fe8e7ab480223dcf20b13f1 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Performance analysis tools for Linux"
2DESCRIPTION = "Performance counters for Linux are a new kernel-based \
3subsystem that provide a framework for all things \
4performance analysis. It covers hardware level \
5(CPU/PMU, Performance Monitoring Unit) features \
6and software features (software counters, tracepoints) \
7as well."
Joel Stanleye252c312017-12-14 15:11:12 +10308HOMEPAGE = "https://perf.wiki.kernel.org/index.php/Main_Page"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
10LICENSE = "GPLv2"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
12PR = "r9"
13
Joel Stanleye252c312017-12-14 15:11:12 +103014PACKAGECONFIG ??= "scripting tui libunwind"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015PACKAGECONFIG[dwarf] = ",NO_DWARF=1"
Brad Bishop79641f22019-09-10 07:20:22 -040016PACKAGECONFIG[scripting] = ",NO_LIBPERL=1 NO_LIBPYTHON=1,perl python3"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017# gui support was added with kernel 3.6.35
18# since 3.10 libnewt was replaced by slang
19# to cover a wide range of kernel we add both dependencies
Joel Stanleye252c312017-12-14 15:11:12 +103020PACKAGECONFIG[tui] = ",NO_NEWT=1,libnewt slang"
21PACKAGECONFIG[libunwind] = ",NO_LIBUNWIND=1 NO_LIBDW_DWARF_UNWIND=1,libunwind"
22PACKAGECONFIG[libnuma] = ",NO_LIBNUMA=1"
23PACKAGECONFIG[systemtap] = ",NO_SDT=1,systemtap"
24PACKAGECONFIG[jvmti] = ",NO_JVMTI=1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040025# libaudit support would need scripting to be enabled
26PACKAGECONFIG[audit] = ",NO_LIBAUDIT=1,audit"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027PACKAGECONFIG[manpages] = ",,xmlto-native asciidoc-native"
Brad Bishop64c979e2019-11-04 13:55:29 -050028PACKAGECONFIG[cap] = ",,libcap"
Andrew Geisslerb7d28612020-07-24 16:15:54 -050029# Arm CoreSight
30PACKAGECONFIG[coresight] = "CORESIGHT=1,,opencsd"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031
32# libunwind is not yet ported for some architectures
33PACKAGECONFIG_remove_arc = "libunwind"
34PACKAGECONFIG_remove_riscv64 = "libunwind"
Brad Bishop316dfdd2018-06-25 12:45:53 -040035
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036DEPENDS = " \
37 virtual/${MLPREFIX}libc \
38 ${MLPREFIX}elfutils \
39 ${MLPREFIX}binutils \
Brad Bishop316dfdd2018-06-25 12:45:53 -040040 bison-native flex-native xz \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050041"
42
43do_configure[depends] += "virtual/kernel:do_shared_workdir"
44
45PROVIDES = "virtual/perf"
46
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080047inherit linux-kernel-base kernel-arch manpages
Patrick Williamsc124f4f2015-09-15 14:41:29 -050048
49# needed for building the tools/perf Python bindings
Brad Bishop79641f22019-09-10 07:20:22 -040050inherit ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'python3native', '', d)}
51inherit python3-dir
Patrick Williamsc124f4f2015-09-15 14:41:29 -050052export PYTHON_SITEPACKAGES_DIR
53
54#kernel 3.1+ supports WERROR to disable warnings as errors
55export WERROR = "0"
56
Andrew Geissler82c905d2020-04-13 13:39:40 -050057do_populate_lic[depends] += "virtual/kernel:do_shared_workdir"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050058
59# needed for building the tools/perf Perl binding
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080060include ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'perf-perl.inc', '', d)}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050061
62inherit kernelsrc
63
Brad Bishop316dfdd2018-06-25 12:45:53 -040064S = "${WORKDIR}/${BP}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050065SPDX_S = "${S}/tools/perf"
66
Patrick Williamsc124f4f2015-09-15 14:41:29 -050067# The LDFLAGS is required or some old kernels fails due missing
68# symbols and this is preferred than requiring patches to every old
69# supported kernel.
70LDFLAGS="-ldl -lutil"
71
72EXTRA_OEMAKE = '\
Andrew Geissler635e0e42020-08-21 15:58:33 -050073 V=1 \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050074 -C ${S}/tools/perf \
75 O=${B} \
76 CROSS_COMPILE=${TARGET_PREFIX} \
77 ARCH=${ARCH} \
78 CC="${CC}" \
Andrew Geissler82c905d2020-04-13 13:39:40 -050079 CCLD="${CC}" \
80 LDSHARED="${CC} -shared" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050081 AR="${AR}" \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060082 LD="${LD}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050083 EXTRA_CFLAGS="-ldw" \
Joel Stanleye252c312017-12-14 15:11:12 +103084 EXTRA_LDFLAGS="${PERF_EXTRA_LDFLAGS}" \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050085 perfexecdir=${libexecdir} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080086 NO_GTK2=1 \
Joel Stanleye252c312017-12-14 15:11:12 +103087 ${PACKAGECONFIG_CONFARGS} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080088 TMPDIR="${B}" \
Brad Bishop19323692019-04-05 15:28:33 -040089 LIBUNWIND_DIR=${STAGING_EXECPREFIXDIR} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050090'
91
92EXTRA_OEMAKE += "\
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050093 'DESTDIR=${D}' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050094 'prefix=${prefix}' \
95 'bindir=${bindir}' \
96 'sharedir=${datadir}' \
97 'sysconfdir=${sysconfdir}' \
98 'perfexecdir=${libexecdir}/perf-core' \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050099 'ETC_PERFCONFIG=${@os.path.relpath(sysconfdir, prefix)}' \
100 'sharedir=${@os.path.relpath(datadir, prefix)}' \
101 'mandir=${@os.path.relpath(mandir, prefix)}' \
102 'infodir=${@os.path.relpath(infodir, prefix)}' \
Brad Bishop79641f22019-09-10 07:20:22 -0400103 ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'PYTHON=python3 PYTHON_CONFIG=python3-config', '', d)} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500104"
105
Brad Bishopd5ae7d92018-06-14 09:52:03 -0700106# During do_configure, we might run a 'make clean'. That often breaks
107# when done in parallel, so disable parallelism for do_configure. Note
108# that it has to be done this way rather than by passing -j1, since
109# perf's build system by default ignores any -j argument, but does
110# honour a JOBS variable.
111EXTRA_OEMAKE_append_task-configure = " JOBS=1"
112
Brad Bishop316dfdd2018-06-25 12:45:53 -0400113PERF_SRC ?= "Makefile \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400114 tools/arch \
115 tools/build \
116 tools/include \
117 tools/lib \
118 tools/Makefile \
119 tools/perf \
120 tools/scripts \
Brad Bishop64c979e2019-11-04 13:55:29 -0500121 scripts/ \
122 arch/${ARCH}/Makefile \
Brad Bishop316dfdd2018-06-25 12:45:53 -0400123"
124
Joel Stanleye252c312017-12-14 15:11:12 +1030125PERF_EXTRA_LDFLAGS = ""
126
127# MIPS N32
128PERF_EXTRA_LDFLAGS_mipsarchn32eb = "-m elf32btsmipn32"
129PERF_EXTRA_LDFLAGS_mipsarchn32el = "-m elf32ltsmipn32"
130
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500131do_compile() {
132 # Linux kernel build system is expected to do the right thing
133 unset CFLAGS
134 oe_runmake all
135}
136
137do_install() {
138 # Linux kernel build system is expected to do the right thing
139 unset CFLAGS
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500140 oe_runmake install
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500141 # we are checking for this make target to be compatible with older perf versions
Joel Stanleye252c312017-12-14 15:11:12 +1030142 if ${@bb.utils.contains('PACKAGECONFIG', 'scripting', 'true', 'false', d)} && grep -q install-python_ext ${S}/tools/perf/Makefile*; then
Brad Bishop79641f22019-09-10 07:20:22 -0400143 oe_runmake DESTDIR=${D} install-python_ext
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500144 fi
145}
146
Brad Bishop316dfdd2018-06-25 12:45:53 -0400147do_configure[prefuncs] += "copy_perf_source_from_kernel"
148python copy_perf_source_from_kernel() {
149 sources = (d.getVar("PERF_SRC") or "").split()
150 src_dir = d.getVar("STAGING_KERNEL_DIR")
151 dest_dir = d.getVar("S")
152 bb.utils.mkdirhier(dest_dir)
Andrew Geissler82c905d2020-04-13 13:39:40 -0500153 bb.utils.prunedir(dest_dir)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400154 for s in sources:
155 src = oe.path.join(src_dir, s)
156 dest = oe.path.join(dest_dir, s)
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800157 if not os.path.exists(src):
158 bb.fatal("Path does not exist: %s. Maybe PERF_SRC does not match the kernel version." % src)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400159 if os.path.isdir(src):
160 oe.path.copyhardlinktree(src, dest)
161 else:
Brad Bishop64c979e2019-11-04 13:55:29 -0500162 src_path = os.path.dirname(s)
163 os.makedirs(os.path.join(dest_dir,src_path),exist_ok=True)
Brad Bishop316dfdd2018-06-25 12:45:53 -0400164 bb.utils.copyfile(src, dest)
165}
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500166
Brad Bishop316dfdd2018-06-25 12:45:53 -0400167do_configure_prepend () {
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500168 # If building a multlib based perf, the incorrect library path will be
169 # detected by perf, since it triggers via: ifeq ($(ARCH),x86_64). In a 32 bit
Andrew Geissler82c905d2020-04-13 13:39:40 -0500170 # build, with a 64 bit multilib, the arch won't match and the detection of a
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500171 # 64 bit build (and library) are not exected. To ensure that libraries are
172 # installed to the correct location, we can use the weak assignment in the
173 # config/Makefile.
174 #
175 # Also need to relocate .config-detected to $(OUTPUT)/config-detected
176 # for kernel sources that do not already do this
177 # as two builds (e.g. perf and lib32-perf from mutlilib can conflict
178 # with each other if its in the shared source directory
179 #
180 if [ -e "${S}/tools/perf/config/Makefile" ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600181 perfconfig="${S}/tools/perf/config/Makefile"
182 fi
183 if [ -e "${S}/tools/perf/Makefile.config" ]; then
184 perfconfig="${S}/tools/perf/Makefile.config"
185 fi
186 if [ -n "${perfconfig}" ]; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500187 # Match $(prefix)/$(lib) and $(prefix)/lib
188 sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \
189 -e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \
190 -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600191 ${perfconfig}
192 fi
193 # The man pages installation is "$(INSTALL) -d -m 755 $(DESTDIR)$(man1dir)"
194 # in ${S}/tools/perf/Documentation/Makefile, if the mandir set to '?=', it
195 # will use the relative path 'share/man', in the way it will resulting in
196 # incorrect installation for man pages.
197 if [ -e "${S}/tools/perf/Documentation/Makefile" ]; then
198 sed -i 's,^mandir?=,mandir:=,' ${S}/tools/perf/Documentation/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500199 fi
200 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
201 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
202 ${S}/tools/perf/Makefile.perf
203 sed -i -e "s,prefix='\$(DESTDIR_SQ)/usr'$,prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
204 ${S}/tools/perf/Makefile.perf
Andrew Geissler635e0e42020-08-21 15:58:33 -0500205 # backport https://github.com/torvalds/linux/commit/e4ffd066ff440a57097e9140fa9e16ceef905de8
206 sed -i -e 's,\($(Q)$(SHELL) .$(arch_errno_tbl).\) $(CC) $(arch_errno_hdr_dir),\1 $(firstword $(CC)) $(arch_errno_hdr_dir),g' \
207 ${S}/tools/perf/Makefile.perf
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500208 fi
209 sed -i -e "s,--root='/\$(DESTDIR_SQ)',--prefix='\$(DESTDIR_SQ)/usr' --install-lib='\$(DESTDIR)\$(PYTHON_SITEPACKAGES_DIR)',g" \
Patrick Williamsd7e96312015-09-22 08:09:05 -0500210 ${S}/tools/perf/Makefile*
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500211
212 if [ -e "${S}/tools/build/Makefile.build" ]; then
213 sed -i -e 's,\ .config-detected, $(OUTPUT)/config-detected,g' \
214 ${S}/tools/build/Makefile.build
215 fi
216
217 # We need to ensure the --sysroot option in CC is preserved
218 if [ -e "${S}/tools/perf/Makefile.perf" ]; then
219 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/perf/Makefile.perf
220 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600221 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/perf/Makefile.perf
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500222 fi
223 if [ -e "${S}/tools/lib/api/Makefile" ]; then
224 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/api/Makefile
225 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/api/Makefile
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600226 sed -i 's,LD = $(CROSS_COMPILE)ld,#LD,' ${S}/tools/lib/api/Makefile
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500227 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500228 if [ -e "${S}/tools/lib/subcmd/Makefile" ]; then
229 sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/lib/subcmd/Makefile
230 sed -i 's,AR = $(CROSS_COMPILE)ar,#AR,' ${S}/tools/lib/subcmd/Makefile
231 fi
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500232 if [ -e "${S}/tools/perf/config/feature-checks/Makefile" ]; then
233 sed -i 's,CC := $(CROSS_COMPILE)gcc -MD,CC += -MD,' ${S}/tools/perf/config/feature-checks/Makefile
234 fi
235 if [ -e "${S}/tools/build/Makefile.feature" ]; then
236 sed -i 's,CFLAGS=,CC="\$(CC)" CFLAGS=,' ${S}/tools/build/Makefile.feature
237 fi
238
239 # 3.17-rc1+ has a include issue for arm/powerpc. Temporarily sed in the appropriate include
240 if [ -e "${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c" ]; then
241 sed -i 's,#include "util/callchain.h",#include "util/callchain.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/$ARCH/util/skip-callchain-idx.c
242 fi
243 if [ -e "${S}/tools/perf/arch/arm/util/unwind-libunwind.c" ] && [ -e "${S}/tools/perf/arch/arm/tests/dwarf-unwind.c" ]; then
244 sed -i 's,#include "tests/tests.h",#include "tests/tests.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/tests/dwarf-unwind.c
245 sed -i 's,#include "perf_regs.h",#include "perf_regs.h"\n#include "util/debug.h",' ${S}/tools/perf/arch/arm/util/unwind-libunwind.c
246 fi
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500247
248 # use /usr/bin/env instead of version specific python
Andrew Geissler82c905d2020-04-13 13:39:40 -0500249 for s in `find ${S}/tools/perf/ -name '*.py'` `find ${S}/scripts/ -name 'bpf_helpers_doc.py'`; do
250 sed -i -e "s,#!.*python.*,#!${USRBINPATH}/env python3," ${s}
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500251 done
Brad Bishop19323692019-04-05 15:28:33 -0400252
253 # unistd.h can be out of sync between libc-headers and the captured version in the perf source
254 # so we copy it from the sysroot unistd.h to the perf unistd.h
Brad Bishopc342db32019-05-15 21:57:59 -0400255 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h
Brad Bishop79641f22019-09-10 07:20:22 -0400256 install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/include/uapi/asm-generic/unistd.h
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500257}
258
259python do_package_prepend() {
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500260 d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500261}
262
263PACKAGE_ARCH = "${MACHINE_ARCH}"
264
265
266PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
267
268RDEPENDS_${PN} += "elfutils bash"
269RDEPENDS_${PN}-archive =+ "bash"
Brad Bishop79641f22019-09-10 07:20:22 -0400270RDEPENDS_${PN}-python =+ "bash python3 python3-modules ${@bb.utils.contains('PACKAGECONFIG', 'audit', 'audit-python3', '', d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500271RDEPENDS_${PN}-perl =+ "bash perl perl-modules"
Brad Bishop79641f22019-09-10 07:20:22 -0400272RDEPENDS_${PN}-tests =+ "python3"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500273
Joel Stanleye252c312017-12-14 15:11:12 +1030274RSUGGESTS_SCRIPTING = "${@bb.utils.contains('PACKAGECONFIG', 'scripting', '${PN}-perl ${PN}-python', '',d)}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500275RSUGGESTS_${PN} += "${PN}-archive ${PN}-tests ${RSUGGESTS_SCRIPTING}"
276
Brad Bishop19323692019-04-05 15:28:33 -0400277FILES_SOLIBSDEV = ""
278FILES_${PN} += "${libexecdir}/perf-core ${exec_prefix}/libexec/perf-core ${libdir}/traceevent ${libdir}/libperf-jvmti.so"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500279FILES_${PN}-archive = "${libdir}/perf/perf-core/perf-archive"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500280FILES_${PN}-tests = "${libdir}/perf/perf-core/tests ${libexecdir}/perf-core/tests"
Brad Bishop316dfdd2018-06-25 12:45:53 -0400281FILES_${PN}-python = " \
282 ${PYTHON_SITEPACKAGES_DIR} \
283 ${libexecdir}/perf-core/scripts/python \
284 "
285FILES_${PN}-perl = "${libexecdir}/perf-core/scripts/perl"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500286
287
288INHIBIT_PACKAGE_DEBUG_SPLIT="1"
Brad Bishopc342db32019-05-15 21:57:59 -0400289DEBUG_OPTIMIZATION_append = " -Wno-error=maybe-uninitialized"