blob: b85b7993d05962c55a18fe92dfdf04eab3138ab3 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \
2server for multi-processor machines. It is a new implementation of the \
3JACK server core features that aims in removing some limitations of \
4the JACK1 design. The activation system has been changed for a data \
5flow model and lock-free programming techniques for graph access have \
6been used to have a more dynamic and robust system."
7SECTION = "libs/multimedia"
8
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "GPL-2.0-only & LGPL-2.1-only"
Patrick Williamsddad1a12017-02-23 20:36:32 -060010LIC_FILES_CHKSUM = " \
11 file://common/jack/control.h;beginline=2;endline=21;md5=e6df0bf30cde8b3b825451459488195d \
12 file://common/jack/jack.h;beginline=1;endline=19;md5=6b736ed6b810592b135480a5e853392e \
13"
14
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015DEPENDS = "libsamplerate0 libsndfile1 readline"
Patrick Williamsddad1a12017-02-23 20:36:32 -060016
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060017SRC_URI = "git://github.com/jackaudio/jack2.git;branch=master;protocol=https"
18SRCREV = "4f58969432339a250ce87fe855fb962c67d00ddb"
Brad Bishop996bc452019-12-02 13:05:15 -050019
Patrick Williamsddad1a12017-02-23 20:36:32 -060020S = "${WORKDIR}/git"
21
22inherit waf pkgconfig
23
24PACKAGECONFIG ??= "alsa"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib"
Brad Bishop19323692019-04-05 15:28:33 -040026# --dbus only stops building jackd -> add --classic
27PACKAGECONFIG[dbus] = "--dbus --classic,,dbus"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus"
Patrick Williamsddad1a12017-02-23 20:36:32 -060029
30# portaudio is for windows builds only
31EXTRA_OECONF = "--portaudio=no"
32
Patrick Williams213cb262021-08-07 19:21:33 -050033do_install:append() {
Brad Bishop996bc452019-12-02 13:05:15 -050034 if ! ${@bb.utils.contains('PACKAGECONFIG', 'dbus', True, False, d)}; then
35 rm -f ${D}${bindir}/jack_control
36 fi
37}
38
Patrick Williamsddad1a12017-02-23 20:36:32 -060039PACKAGES =+ "libjack jack-server jack-utils"
40
Patrick Williams213cb262021-08-07 19:21:33 -050041RDEPENDS:jack-dev:remove = "${PN} (= ${EXTENDPKGV})"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050042
Patrick Williams213cb262021-08-07 19:21:33 -050043FILES:libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
44FILES:jack-server = " \
Brad Bishop19323692019-04-05 15:28:33 -040045 ${datadir}/dbus-1/services \
46 ${bindir}/jackdbus \
47 ${bindir}/jackd \
48"
Patrick Williams213cb262021-08-07 19:21:33 -050049FILES:jack-utils = "${bindir}/*"
Brad Bishop19323692019-04-05 15:28:33 -040050
Patrick Williams213cb262021-08-07 19:21:33 -050051FILES:${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/*"
Andrew Geissler78b72792022-06-14 06:47:25 -050052
53BBCLASSEXTEND = "native nativesdk"