blob: 8915dd75ea383095bc7ad5a307feda65ecfabdec [file] [log] [blame]
Cyril Burb73580e2017-01-12 18:13:30 +11001SUMMARY = "Phosphor OpenBMC MBOX Daemon"
2DESCRIPTION = "Phosphor OpenBMC MBOX Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
6
7inherit autotools pkgconfig
8inherit obmc-phosphor-systemd
9
10DEPENDS += "autoconf-archive-native"
Andrew Jeffery5ade8402017-04-21 10:18:24 +093011DEPENDS += "systemd"
Patrick Williamsf55db882017-06-30 12:01:49 -050012DEPENDS += "phosphor-logging"
Andrew Jeffery2c567ba2017-04-18 16:30:10 +093013RDEPENDS_${PN} += "libsystemd"
Cyril Burb73580e2017-01-12 18:13:30 +110014
15S = "${WORKDIR}/git"
16
Adriana Kobylak54c65d62017-06-10 09:47:58 -050017SRC_URI += "git://github.com/openbmc/phosphor-mboxd.git"
Cyril Burb73580e2017-01-12 18:13:30 +110018
19SRC_URI += "file://99-aspeed-mbox.rules"
Andrew Jeffery2a0cb542017-01-25 13:17:13 +103020SRC_URI += "file://99-aspeed-lpc-ctrl.rules"
Cyril Burb73580e2017-01-12 18:13:30 +110021SRC_URI += "file://aspeed-lpc-ctrl-h.patch"
22
Patrick Williams91af06d2017-08-06 20:48:39 -050023SRCREV="eb083550701a4e3bda8d4b07e37d1f9fd6017424"
Andrew Jeffery2c567ba2017-04-18 16:30:10 +093024
25PROVIDES += "mboxctl"
Cyril Burb73580e2017-01-12 18:13:30 +110026
27MBOXD_FLASH_SIZE ??= "32M"
28SYSTEMD_SUBSTITUTIONS += "FLASH_SIZE:${MBOXD_FLASH_SIZE}:${PN}.service"
29
30# Hacks because ${STAGING_KERNEL_DIR} points to the kernel source tree, not the
31# installed, pre-processed headers. Requires the aspeed-lpc-ctrl-h patch above.
Saqib Khanc8afc6a2017-03-09 10:28:09 -060032CFLAGS_append = " -I include"
Cyril Burb73580e2017-01-12 18:13:30 +110033
34do_install_append() {
35 install -d ${D}/lib/udev/rules.d
36 install -m 0644 ${WORKDIR}/99-aspeed-mbox.rules ${D}/lib/udev/rules.d
Andrew Jeffery2a0cb542017-01-25 13:17:13 +103037 install -m 0644 ${WORKDIR}/99-aspeed-lpc-ctrl.rules ${D}/lib/udev/rules.d
Cyril Burb73580e2017-01-12 18:13:30 +110038}
Matt Spinler9f77d282017-01-20 15:32:07 -060039
40TMPL = "mboxd-reload@.service"
Andrew Geissler58041192017-07-25 09:12:37 -050041TGTFMT = "obmc-chassis-poweron@{0}.target"
Matt Spinler9f77d282017-01-20 15:32:07 -060042INSTFMT = "mboxd-reload@{0}.service"
43FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
44
45SYSTEMD_SERVICE_${PN} += "mboxd.service"
46SYSTEMD_SERVICE_${PN} += "mboxd-reload@.service"
47SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
Deepak Kodihallidd05b962017-06-29 09:56:24 -050048
Patrick Williams74d4dbc2017-08-09 16:36:51 -050049# Disable virtual-pnor by default.
50PACKAGECONFIG ??= ""
51PACKAGECONFIG[virtual-pnor] = "--enable-virtual-pnor,--disable-virtual-pnor"